PDA

View Full Version : Updating failure



masterswim
3rd April 2006, 12:06 PM
Hi,

The last week I have not been able to do updates using Yum update.

I receive the message,
"Cannot find a valid baseurl for repo: nr-production
Error: Cannot find a valid baseurl for repo: nr-production"

I'm running FC4 with gnome. Anyone with advise on how to fix this?

Alukardian
3rd April 2006, 02:34 PM
fedorafaq.org has an article on how to set up yum and it's repos. also try to clear your yum cache and see if that helps any.

masterswim
4th April 2006, 02:20 PM
I read the yum manual and erased the yum cache. No change in results

Jman
5th April 2006, 03:20 AM
Try temporarily disabling it.
yum --disablerepo=nr-production update

pkpanda
5th April 2006, 03:50 AM
is your internet connection there. are you directly connected to the internet or you are using any proxy

if you are going through proxy then when you start the terminal you need to set the HTTP_PROXY variable before you start yum.

if your are directly connected to the internet then go to web browser and see you can view any web site like google.com etc.

I had the same problem and it was b'cas of connection problem.

All the best.

masterswim
5th April 2006, 11:11 AM
I tried the disable and get no difference. I get the same message.
Cannot find a valid baseurl for repo: nr-testing
Error: Cannot find a valid baseurl for repo: nr-testing

Christy
5th April 2006, 01:55 PM
I tried the disable and get no difference. I get the same message.
Cannot find a valid baseurl for repo: nr-testing
Error: Cannot find a valid baseurl for repo: nr-testing

This isn't the same message. It's for another repository (testing this time, insead of production). Try:

yum --disablerepo=nr-production --disablerepo=nr-testing update

you could also try installing yumex. It allows for easy managing of repositories.

yum --disablerepo=nr-production --disablerepo=nr-testing install yumex

mit
6th April 2006, 09:25 AM
you can use wildcard in '--disablerepo'

Ex.


yum --disablerepo=nr-* update

Christy
6th April 2006, 02:28 PM
you can use wildcard in '--disablerepo'

Ex.


yum --disablerepo=nr-* update


very true, I forgot about that :)