PDA

View Full Version : unable to burn cd/dvd using gnomebaker



lurp
3rd April 2006, 10:43 AM
i tried to copy a disk with gnomebaker and this is the result:

Error trying to open /dev/hdc exclusively ... retrying in 1 second.
readcd: Device or resource busy. Cannot open '/dev/hdc'. Cannot open SCSI driver.
readcd: For possible targets try 'readcd -scanbus'. Make sure you are root.
readcd: For possible transport specifiers try 'readcd dev=help'.

i've tried a chmod 666 /dev/hdc already but without any result.

any suggestions?

thx in advance!

powereds
3rd April 2006, 01:17 PM
ive also tried using gnomebaker but same problem as yours.
i cant burn/erase also with k3b. pls see this thread (http://forum.fedoraforum.org/showthread.php?t=102728).

powereds
3rd April 2006, 01:49 PM
try using k3b, maybe it can help you.
please refer to this thread (http://forum.fedoraforum.org/showthread.php?p=493434#post493434) for troubleshooting.

regards,

lurp
3rd April 2006, 10:16 PM
first of all thanks a lot for your response!

i'll try that as soon as possible!

taurus
4th April 2006, 12:00 AM
See if you can burn it as root!!!

kOoLiNuS
5th April 2006, 02:19 PM
As root i have no problem. :-(


gnomabaker, blanking a cd says me:


######
Cdrecord-Clone 2.01.01a03-dvd (i686-pc-linux-gnu) Copyright (C)
1995-2005 Jörg Schilling
NOTE: This version contains the OSS DVD extensions for cdrtools and thus
may have bugs related to DVD issues that are not present in the original
cdrtools. Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla The original cdrtools author should
not be bothered with problems in this version.
TOC Type: 3 = CD-ROM XA mode 2
cdrecord: Resource temporarily unavailable. Cannot get mmap for 4198400
Bytes on /dev/zero.
######


while, having launched it as root and burning the ISO it says me:
######


cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent
defaults.
cdrecord: Continuing in 5 seconds...
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.85-RH '@(#)scsi-linux-sg.c 1.85
05/05/16 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
Cdrecord-Clone 2.01.01a03-dvd (i686-pc-linux-gnu) Copyright (C)
1995-2005 Jörg Schilling
NOTE: This version contains the OSS DVD extensions for cdrtools and thus
may
have bugs related to DVD issues that are not present in the
original
cdrtools. Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla The original cdrtools author
should
not be bothered with problems in this version.
TOC Type: 3 = CD-ROM XA mode 2
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 2
Capabilities :
Vendor_info : 'HL-DT-ST'
Identifikation : 'CD-RW GCE-8520B '
Revision : '1.00'
Device seems to be: Generic mmc CD-RW.
Current: 0x000A
Profile: 0x000A (current)
Profile: 0x0009
Profile: 0x0008
Profile: 0x0002 (current)
Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
Driver flags : MMC-2 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R
Drive buf size : 1467136 = 1432 KB
FIFO size : 4194304 = 4096 KB
DVD at speed 10.0 in real TAO mode for multi session.
Last chance to quit, starting real write in 5 seconds. 4
seconds. 3 seconds. 2
seconds. 1 seconds. 0 seconds. Operation
starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is OFF.
Turning BURN-Free on
Performing OPC...
Starting new track at sector: 0
Writing time: 34.455s
Average write speed 8.8x.
Min drive buffer fill was 95%
Fixating...
Fixating time: 35.612s
BURN-Free was never needed.
######



K3B, instead, always trying to blank a cd as normal user, says:

######
System
-----------------------
K3b Version: 0.12.14

KDE Version: 3.5.1-2.3 Red Hat
QT Version: 3.3.5
Kernel: 2.6.16-1.2080_FC5
Devices
-----------------------
LITE-ON DVDRW SOHW-812S US0N (/dev/hdd, ) at [CD-R; CD-RW; CD-ROM;
DVD-ROM; DVD-R; DVD-RW; DVD+R; DVD+RW] [DVD-ROM; DVD-R Sequential;
DVD-RW Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; CD-ROM;
CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P;
RAW/R96R; Restricted Overwrite]

HL-DT-ST CD-RW GCE-8520B 1.00 (/dev/hdc, ) at [CD-R; CD-RW; CD-ROM]
[CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16;
RAW/R96P; RAW/R96R]
Used versions
-----------------------
cdrecord: 2.1.1a03

cdrecord
-----------------------
Cdrecord-Clone 2.01.01a03-dvd (i686-pc-linux-gnu) Copyright (C)
1995-2005 Jörg Schilling
NOTE: This version contains the OSS DVD extensions for cdrtools and thus
may
have bugs related to DVD issues that are not present in the
original
cdrtools. Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla The original cdrtools author
should
not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
/usr/bin/cdrecord: Resource temporarily unavailable. Cannot get mmap for
4198400 Bytes on /dev/zero.

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=52 -dao
driveropts=burnfree -eject -overburn
-data /mnt/adottato/SUSE-Linux-10.1-beta9-i386-mini.iso
######


after a quick research on FedoraForums i did also a:
chmod 4755 /usr/bin/cdrdao
apparentely without any change ....

lelad
8th April 2006, 07:33 AM
I have the same problem in k3b and gnomebaker. There is no problem to burn cd as root. But as user I can write cd in k3b using cdrdao only. If I try to use cdrecord I get following message:

System
-----------------------
K3b Version: 0.12.14

KDE Version: 3.5.1-2.3 Red Hat
QT Version: 3.3.5
Kernel: 2.6.16-1.2080_FC5
Devices
-----------------------
HITACHI DVD-ROM GD-2500 0011 (/dev/hdd, ) at [CD-ROM; DVD-ROM] [DVD-ROM; CD-ROM] [Brak]

SAMSUNG CD-R/RW SW-252S R952 (/dev/hdc, ) at [CD-R; CD-RW; CD-ROM] [CD-ROM; CD-R; CD-RW] [Sesja naraz (SAO); TAO; RAW; SAO/R96P; SAO/R96R; Surowe/R16; Surowe/R96P; Surowe/R96R]
K3b
-----------------------
Size of filesystem calculated: 357607

Used versions
-----------------------
cdrecord: 2.1.1a03

cdrecord
-----------------------
Cdrecord-Clone 2.01.01a03-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2005 Jörg Schilling
NOTE: This version contains the OSS DVD extensions for cdrtools and thus may
have bugs related to DVD issues that are not present in the original
cdrtools. Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla The original cdrtools author should
not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
/usr/bin/cdrecord: Resource temporarily unavailable. Cannot get mmap for 4198400 Bytes on /dev/zero.

cdrecord command:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=32 -dao driveropts=burnfree -eject -data -tsize=357607s -

mkisofs
-----------------------
357607
INFO: UTF-8 character encoding detected by locale settings.
Assuming UTF-8 encoded filenames on source filesystem,
use -input-charset to override.

mkisofs command:
-----------------------
/usr/bin/mkisofs -gui -graft-points -volid K3b data project -volset -appid K3B THE CD KREATOR (C) 1998-2005 SEBASTIAN TRUEG AND THE K3B TEAM -publisher -preparer -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-leszek/k3bi2cyca.tmp -rational-rock -hide-list /tmp/kde-leszek/k3b0dYmya.tmp -joliet -hide-joliet-list /tmp/kde-leszek/k3bsU7DIa.tmp -full-iso9660-filenames -iso-level 2 -path-list /tmp/kde-leszek/k3bdAqN7a.tmp


I have set suid bit in cdrdao and cdrecord.
Any ideas?

lelad
8th April 2006, 07:52 PM
Fedora Core 5 - I have found the solution for my problem (described above).
If we want to burn cd as a user we must do following things:
1) set SUID for cdrdao.
2) remove SUID for cdrecord.
3) do not pay attention to messagge of k3b about running cdrecord without root privileges.
And then all programs to burn cd (like k3b, gnomebaker, cd/dvd creator of nautilus) should work properly.
I hope that information described above will be usefull for anybody.

coffee412
10th April 2006, 12:00 PM
For those of you having this problem and dont really care about the security problem with these programs you can fix this by the commands below. Just wanted to give back to the group.
Happy burning!

coffee

su -
cd /usr/bin
chmod 4755 cdrecord
chmod 4755 cdrdao