View Full Version : FC5 - error: X11/Intrinsic.h: No such file or directory

3rd April 2006, 06:36 AM
Hello all,

While trying to compile QtCurve-0.34 from kde-look.org, I got the following error while trying to run ./configure:

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

I looked in the config.log file and this is what I found:

configure:27684: checking for X
configure:27722: gcc -E conftest.c
conftest.c:44:27: error: X11/Intrinsic.h: No such file or directory
configure:27728: $? = 1

For the life of me, I cannot find what provides Intrinsic.h. I installed the xorg-x11-devel package, but that did not provide that file. Can someone please help me with this.

I am running Fedora Core 5 on an x86_64. I get this same error whenever I try to compile most things from kde-look.org.


3rd April 2006, 06:57 AM
Alright, I think the package is libXt-devel that provides that.

At least that's what rpm is telling contains that file. libXt-devel-1.0.0-2.2 to be exact.

3rd April 2006, 07:51 PM
Yes, that fixed it. How did you find out? I tried yum whatprovides Intrinsic.h, and that did not help. I also tried rpmfind.net and did not find it there either.

Thanks for your help.

3rd April 2006, 10:30 PM
I checked to see if I had that file, and I did, then I typed in rpm -q -f /usr/include/X11/Intrinsic.h to see what package had placed it there.

Also, I just now, I typed: yum provides Intrinsic.h and that too listed it as coming from libXt-devel. It's strange that it didn't work for you. It might have been because I already had the package, which is still strange since I thought it would search all packages.