PDA

View Full Version : Error message on shutdown



micklean
2nd April 2006, 05:21 PM
Hi Folks,

Getting an error message "Stopping NFS Failed" when shutting down. Fedora reports that it is started on bootup. Why am I getting this message and what do I have to do to get rid of it?

Thanx
Mick

jcliburn
2nd April 2006, 05:38 PM
Do you use NFS, or would it be okay to turn it off for good?

micklean
2nd April 2006, 09:14 PM
Do you use NFS, or would it be okay to turn it off for good?
Hi jcliburn!

Have no idea what NFS is or why I would use it (I did a FULL install of Fedora core4) so I guess I can toss it. What worries me is that it STARTS fine. Usually an error like that is caused by a service that isn't started in a "run" level during startup but is listed in a "shutdown" run level.

The GUI with this system allows you to define/edit what you want to run at startup, but if you remove a "startup" service it doesn't seem to remove the "shutdown" for same.

I know there is someway to manually edit the "run level" files, but I forgot how! (and only God knows what directory they are in now!)

Thanks
Mick

jcliburn
2nd April 2006, 09:54 PM
It's easy to turn off at the command line. Open a terminal and become root by executing "su -".

Then,

# chkconfig nfs off
# chkconfig nfslock off
# chkconfig portmap off
# chkconfig rpcgssd off
# chkconfig rpcidmapd off
# chkconfig rpcsvcgssd off

Then reboot.

robatino
3rd April 2006, 12:57 AM
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=162446

This bug is gone in FC5, BTW.