PDA

View Full Version : How do i make gthumb work with selinux on (FC5)?



dave26
1st April 2006, 07:32 PM
I have tried to import photos with my Digital camera, normaly this works well with gthumb.

However when i plug in the camera i get the following error:


An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Operation not permitted). Make sure no other program or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.

Everything works well when I turn off SELinux but I would like to keep this running if possible, any solution to this?

Thanks,

Dave

Jman
1st April 2006, 10:46 PM
Read the selinux FAQ (http://fedora.redhat.com/docs/selinux-faq-fc5/) and try to track down some more specifics about what exactly was denied.

dave26
2nd April 2006, 05:51 AM
Thanks for the link Jman:

here is what was printed out in /var/log/audit/audit.log:


type=AVC msg=audit(1143951512.007:187): avc: denied { search } for pid=3924 comm="cat" name="console" dev=hde4 ino=4746808 scontext=system_u:system_r:hald_t:s0 tcontext=system_u:object_r:pam_var_console_t:s0 tclass=dir

type=SYSCALL msg=audit(1143951512.007:187): arch=40000003 syscall=5 success=no exit=-13 a0=bff128dd a1=8000 a2=0 a3=8000 items=1 pid=3924 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm="cat" exe="/bin/cat"

type=CWD msg=audit(1143951512.007:187): cwd="/usr/libexec"

type=PATH msg=audit(1143951512.007:187): item=0 name="/var/run/console/console.lock" flags=101


This was determined useing "tail -f /var/log/audit/audit.log"
so had this tail running and i turned on my camera, which causes gthumb to start.

I'm not sure what to do about this, other than to turn SELinux off or switch to permissive mode.
the only other USB device i have is my mouse, i do not get a denied message when plugging this in.

Regards,

Dave

RahulSundaram
3rd April 2006, 01:28 AM
Thanks for the link Jman:

here is what was printed out in /var/log/audit/audit.log:



This was determined useing "tail -f /var/log/audit/audit.log"
so had this tail running and i turned on my camera, which causes gthumb to start.

I'm not sure what to do about this, other than to turn SELinux off or switch to permissive mode.
the only other USB device i have is my mouse, i do not get a denied message when plugging this in.

Regards,

Dave


Post to fedora-selinux list about this (http://www.redhat.com/mailman/listinfo/fedora-selinux-list ) or file a bug report in http://bugzilla.redhat.com against selinux-targeted-policy.

dave26
3rd April 2006, 04:22 AM
done.

For those who care the bugzilla number is: 187712

neustadt
5th April 2006, 07:31 PM
I had the same problem too. I was wondering if there is some way to disable SE Linux specificially for the USB daemon or whatever controls that.

N

Trek1701
5th April 2006, 08:45 PM
I have the same problem after update from FC4 to FC5 and my SELinux is diseabled.

Trek1701
5th April 2006, 09:32 PM
Adding...

I just receive this message on non-root. As root it works perfectly. I believe it's a permition problem. Any ideas?

panamaszr12
11th April 2006, 04:13 PM
Did any one find a fix I have the same issue?????

Wayne
12th April 2006, 12:38 AM
There was un update to the selinux policy that was *supposed* to fix it but as user I still can't import from my camera although it works fine as root, even with selinux disabled or set to permissive.

Wayne

Wayne
20th April 2006, 01:04 AM
It looks like I fixed it on my box! If you're still working at it look at thread:

http://forums.fedoraforum.org/showthread.php?t=105518

Wayne