PDA

View Full Version : ATI Radeon 9500 pro with Nforce2 (no 3D acc)



moffen
28th March 2004, 10:07 PM
I have searched, have found some answers, but not to Fedora.
Anyone has got that combination work?

I have found the fglrx driver, and installed it, but I don't got any 3d acc.

Anyone have an solution?

ghenry
29th March 2004, 09:58 PM
I'm running a 9500pro on 2.6.5-rc2 adn this works fine.

Do you have the onboard switched off?

Have you a working XF86Config using ATI's config program?

Stupid questions I know. :rolleyes:

James
1st April 2004, 11:50 PM
I have a Radeon 9800 pro, and this is what i did

got to www.ati.com and download thier Linux Driver, rpm.

rpm -Uvh --force fglrx*.rpm (i had to use force to get it to install for me)

Then i pressed ctrl + alt +f1 , logged as root and typed telinit 3. After this i typed fglrxconfig to configure my graphics card and monitor.

Save the file and at prompt type telinit 5 then startx.

You can test if 3d is working by using glxgears or fgl_glxgears.


This website also has a good how to

www.rage3d.com/board

Scroll down to the linux section, and the how to is the first link.

Hope this helps

AMD-Z
3rd April 2004, 05:10 PM
I Have 9500P and nforce2 working perfectly...
all you need to do is to use external agpgart when he asks you what to use in fglrxconfig....

P.S- you need to install the drivers from Nvidia:
http://download.nvidia.com/XFree86/nforce/1.0-0261/NVIDIA_nforce-1.0-0261.src.rpm

build the rpm and install it:
rpm -ihv --force NVIDIA_nforce*****.rpm

moffen
4th April 2004, 05:02 PM
Originally posted by AMD-Z
I Have 9500P and nforce2 working perfectly...
all you need to do is to use external agpgart when he asks you what to use in fglrxconfig....

P.S- you need to install the drivers from Nvidia:
http://download.nvidia.com/XFree86/nforce/1.0-0261/NVIDIA_nforce-1.0-0261.src.rpm

build the rpm and install it:
rpm -ihv --force NVIDIA_nforce*****.rpm

Yes... I have done exactly what you do... but it doesn't work.
Theres still no 3D Acc...

It worked in SUSE but not in Fedora.. I'm running Fedora 1.

moffen
8th April 2004, 02:40 PM
No answers?

The ones who has Fedora working with ATI RADEON 9500 pro and Nforce2, can you please describe exactly how you got it to work?

Prometheus
8th April 2004, 04:25 PM
what do you consider "3d acceleration"? What are you basing this on? I have the exact same combo of chipset and gfx card (A7n8x deluxe and 9500 pro) and it appears to work. Im jsut wondering if the program you are using say that there is no 3d accelation is messed up. I jsut installed the drivers and it worked, thats why im wonderin what you are basing this on

moffen
8th April 2004, 04:37 PM
Originally posted by Prometheus
what do you consider "3d acceleration"? What are you basing this on? I have the exact same combo of chipset and gfx card (A7n8x deluxe and 9500 pro) and it appears to work. Im jsut wondering if the program you are using say that there is no 3d accelation is messed up. I jsut installed the drivers and it worked, thats why im wonderin what you are basing this on

If I write fglrx_glxinfo in terminal, there is written :

DRI Acceleration : NO

And if I try to play for example Tux Racer, it's so slow so I can see it doesn't work.

(In Suse it worked, but I will use Fedora)

Prometheus
8th April 2004, 04:59 PM
huh, strange indeed. Can you get into the gfx config file (i forgot its exact name, fglrxconfig i think but im not sure) and playwith the settings in there? I havent tried this, but it might just work. If all else fails, you might want to try upgrading the kernel to 2.6. Thats the best i got, but ill keep looking.

Mark_Den
10th April 2004, 04:45 PM
It seems you might have two issues here. One with AGP, and the other with the FGLRX drivers.

Keep in mind, that AGP 3.0 (8X) is going to have some hurdles in a 2.4 kernel. This should be the first thing you should get running before even going with the FGLRX package. I'd suggest going with the stock X drivers and working to get Direct Rendering working (basically reflecting yes through dmesg).

Now I'll admit, there may not be a solution for that with an NForce chip. I don't have an NForce nor have I worked on one, so I'm not sure what solutions are out there for this.

Now having said that, if you have that working (things like Tux and Chromium will run much better btw), you'll first want to remove the MesaGL libraries before installing the FGL drivers by doing a rpm -e --nodeps <package name>

You can find the package you have installed by doing a

rpm -qa | grep Mesa Again, you're looking at the GL, not the GLU

When you install the drivers, I would suggest dropping to an init 3 and installing from there like your normally would and going with the external gart as someone else suggested...of course you might want to edit the XF86Config-4 and change that to use internal to make sure...I always get confused as to which I should be using there :)