PDA

View Full Version : HELP!! I broke something!



jjordan2004
30th March 2006, 03:27 PM
Ok, last night I was working on my FC5 box, installing some apps and such, and before I went to bed I installed vsftp and reboot my machine. When I did that I just got a black screen with the big X cursor and nothing else, so I shut it off and went to bed. When I woke up this morning I turned on my machine and got an error message. It went something like this:

error while loading shared libraries libsepol.so.l permessions denied
waiting for /sys/device/pci0000:00/0000:00:07.2/vsbl/1-2/1-2:1:0/bus failed
setting hostname failed
checking filesystem failed

an error occured during file system check

Can anyone helping? Things were going so well until this happened.

bob
30th March 2006, 04:08 PM
That lib is associated with SELinux. Try disabling it. Also, you should be getting an option to do a manual system check. Many times I've had a glitch that was solved if you simply let the manual check go through it's paces and fix itself.

jjordan2004
30th March 2006, 11:55 PM
Okay, I tried to go into the Interactive Help and I just get a black screen with the X cursor. And I do not know how to disable SELinux. Any other suggestions?

bob
31st March 2006, 12:09 AM
Well, it sounds like you've gotten past the SELinux problem. So, did you install a new kernel and are trying to boot into that one? Have you got a Nvidia card and need to load drivers? http://forums.fedoraforum.org/showthread.php?t=101701 (see the post from Twistedkaos if that's the problem). You can always use the Rescue CD to boot and make changes if needed.

jjordan2004
31st March 2006, 12:15 AM
well i have an nvidia card, but everything was working fine before i installed vsftp. could that be the problem?

bob
31st March 2006, 12:25 AM
Well, there was an update yesterday to a new kernel (2.6.16-1.2080-FC5) and I noticed that yum REMOVED the old kernel, so you might not be booting into the one you expected. If you've got the new kernel, try using the Livna drivers as described in that thread I mentioned and see if it works.

Vsftp shouldn't have any problems associated with this, although it might be involved in the SELinux glitch.

Flounder
31st March 2006, 12:27 AM
If it's when X is coming up sounds like a problem with X check your refresh rates in xorg.conf with the ones for your monitor in the manual should you have it. If they're not the same change the ones in xorg.conf to match the manuals.

bob
31st March 2006, 12:47 AM
Well, I'll agree that it sounds like 'X' is failing to start. Try this: At the Grub menu, stop it by hitting any key but 'enter' and then type 'e' to edit. Next, arrow-key down to the kernel line for the kernel that you're going to boot and again type 'e' to edit that line. Then, at the end of the line, type "runlevel 3' to boot into a text mode. Then hit 'enter' to save the change and hit 'b' to boot. That will get you into a login screen. Sign in as your user and type: "startx". You will probably see your system complaints at that moment that indicating there's a problem. Let us know the complaints, although I think that those Livna drivers could be the solution.

jjordan2004
31st March 2006, 01:05 AM
Okay, I tried to boot in to text mode. But no luck. It gives me the same error. 'An error occured during the file system check.' It then puts me into a shell. Can I install those drivers from that?

bob
31st March 2006, 01:28 AM
No, we're stuck a bit here. I thought you were past the file-check error stage and nearly booted. Back to the SELinux situation, I'm afraid. It's the most likely glitch, since that's the error and you mentioned installing vsftpd which SELinux can have a bit of a snit about. If you can boot with the Rescue CD, edit /etc/selinux/config and change to 'selinux=disabled'. EDIT: Sorry, just re-read the last post and you mention you've been put in a shell, so you can skip the rescue cd and just sign in as root to make the change:

You may have to use 'vi' to edit that file. If so, you can do it fairly easily like this:

"vi /etc/selinux/config"
Then it will open the config file and you can use the arrow keys to scroll down to the line and you may have to use the 'insert' and the delete key to make changes. Once done, hit 'esc' then type: ":wq" to save your changes (or ":q!" if you've messed up and need to just get out of there). Exit, reboot and hopefully you'll have some luck for a change.

jjordan2004
31st March 2006, 01:49 AM
Victory, I got it back up and working. Do you recommend I do anything so that doesn't happen again?

bob
31st March 2006, 01:49 AM
Also found a better link on those drivers: http://forums.fedoraforum.org/showthread.php?t=101784 . Keep in mind that if you can't get 'X' to start and have to work in a text mode, gedit won't work. You'll have to use 'vi' or 'nano' instead. The rest of the instructions are great though.

Firewing1
31st March 2006, 01:50 AM
You mentioned "turned it off" -- forcibly as in unplug or a proper shutdown?
An error in the fscheck I don't think is SELinux -- The lib for SElinux just happens to be corrupted... If it was SELinux you'd get a "audit:numbers_here {avc_denied:action}" message and it'd just continue.
When you get dropped to this shell, try:

fsck -CcfkD LABEL=/
It will take A WHILE probably, and the unfornate part is you have to watch. Every 5 min come back to check on it, as it will ask you questions on when to fix. Reply
ymeaning "yes" to all of them. Reboot, you should be OK.
In some cases of filesystem (fs) corruption, entire files are removed. I've had this happen and it was a system file, so I had to reinstall. SO, just so you know, be prepared for the worst case senario.
Firewing1

bob
31st March 2006, 01:54 AM
Thanks, Firewing1. I believed we'd done the manual fscheck earlier without success (post #3) , but it sure won't hurt to try again.

jjordan2004
31st March 2006, 01:55 AM
i disabled selinux, and it booted into X. should i run the fsck as well?

bob
31st March 2006, 01:59 AM
No need if disabling SELinux fixed it. Might want to install those drivers for 3D, but otherwise you're set. Congrats!

Firewing1
31st March 2006, 02:18 AM
I'd go for it anyways. You'll have to single-user boot it first, though.
Glad to hear you got it working!
Firewing1

jjordan2004
31st March 2006, 02:27 AM
ok i installed the drivers.(i think) but i am still getting that pci error when i boot. it is described in post #1. any suggestions?

Firewing1
31st March 2006, 02:30 AM
What's the error? PCI interrupts?
EDIT: Oh, you mean this?
waiting for /sys/device/pci0000:00/0000:00:07.2/vsbl/1-2/1-2:1:0/bus failed
That's fine, I had that for a while, too. Udev glitches. The system still runs fine after, and updates fixes it:
yum update
Firewing1