PDA

View Full Version : rpmbuild - requires tag



daneel971
30th March 2006, 09:26 AM
Does someone know if it is possible in the "Requires" section of a a specfile specifying two different packages as alternatives?
I mean something like

Requires: foo >= 1.0 or bar >=2.0
so that the rpm will be built if one of the two packages (foo or bar) is installed.
Thanks in advance.

buddha
30th March 2006, 03:30 PM
seems like it is valid if I read this right:

http://fedora.redhat.com/docs/drafts/rpm-guide-en/ch-specfile-syntax.html#id3045258

daneel971
31st March 2006, 07:14 AM
Thanks for the link. It doesn't work, but it does give useful info. :)

Jman
31st March 2006, 11:55 PM
Perhaps with conditionals. Also discussed in that rpm guide.