PDA

View Full Version : Xine



tomahawker
29th March 2006, 11:41 PM
how can I get Xine to play DVDs?

Iron_Mike
29th March 2006, 11:56 PM
Go to System -->Preferences --Removable drives and Media, Cllick on Multimedia tab, for the video dvd disks, erase the TOTEM and put this in there:

xine --auto-play --auto-scan dvd

tomahawker
30th March 2006, 12:08 AM
it tells me there is no mrl

tomahawker
30th March 2006, 01:28 AM
okay, it now plays till the FBI warning to stops, tried multiple DVDs still same thing. Any ideals?

Iron_Mike
30th March 2006, 05:38 AM
You need the this file: libdvdcss

tomahawker
30th March 2006, 06:24 AM
I have that file installed, that's why I think I can get thru the previews, It just when the actual movie menu starts is when it stops, I have tried mplayer also, but I get worst results. I get nothing, except for a constantly access sound for my dvd drive. And when I log out I get "hdc read error" window. I'm starting to think it might be a device problem. Now correct me if I'm wrong, I thought only hard drives had the designation of "hd" and then a letter for each physical drive after that, such as "hda, hdb, hdc". I can't remeber what cd/dvd drives were suppose to be, but under /dev I see this:

dvd
dvd-hdc
dvdrw
dvdrw-hdc
dvdwriter
dvdwriter-hdc

same for cd also

Is this normal? or do I have a problem with /dev?

buddha
30th March 2006, 06:49 AM
Make sure you have all the libdvd* packages:

$ rpm -qa | grep libdvd

libdvdnav-0.1.10-0.lvn.1.4
libdvdcss-1.2.9-0.lvn.1.4
libdvdplay-1.0.1-0.lvn.3.4
libdvdread-0.9.4-0.lvn.1.4

Mine are from the Livna repository. All my DVDs play fine.

Salamandra
30th March 2006, 11:01 AM
I suggest you to follow:

http://stanton-finley.net/fedora_core_5_installation_notes.html

I got xine working that way, only had to correct one dma issue:

As root edit:
/etc/rc.d/rc.local

and add:

/sbin/hdparm -d 1 /dev/dvd

At the bottom line.


Good luck.

TheRoot
30th March 2006, 02:43 PM
Make sure you have all the libdvd* packages:

$ rpm -qa | grep libdvd

libdvdnav-0.1.10-0.lvn.1.4
libdvdcss-1.2.9-0.lvn.1.4
libdvdplay-1.0.1-0.lvn.3.4
libdvdread-0.9.4-0.lvn.1.4

Mine are from the Livna repository. All my DVDs play fine.

I do not have this library
libdvdplay-1.0.1-0.lvn.3.4

tomahawker
30th March 2006, 03:23 PM
thanks guys, adding what buddha said worked. I'll keep what you said salamandra in mind if I run into anymore problems