View Full Version : NTFS Installation: yum reports "Nothing to do"

29th March 2006, 08:43 PM
I tried to follow "http://easylinux.info/wiki/Fedora_fc5#Windows" to install NTFS support for my FC 5 Linux. I first downloaded the most current yum.conf as instructed in the document. Then I gave a "yum -y install kernel-module-ntfs-$(uname -r)" which resulted to:

[root@greatsoft etc]# yum -y install kernel-module-ntfs-$(uname -r)
Setting up Install Process
Setting up repositories
core [1/3]
extras [2/3]
updates [3/3]
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: kernel-module-ntfs-2.6.15-1.2054_FC5
Nothing to do

NTFS is not installed:

[root@greatsoft etc]# /sbin/modprobe ntfs
FATAL: Module ntfs not found.

Can anyone help me?



29th March 2006, 08:48 PM
yum install kmod-ntfs
they just renamed the package..
edit: livna repositry is needed

29th March 2006, 08:53 PM
same problem here, can't make it work with this command:
"yum -y install kmod-ntfs-2.6.15-1.2054_FC5smp"

I have also tried using the RPM from this site: http://www.linux-ntfs.org/content/view/187/ with no success.

29th March 2006, 09:14 PM
you need to have the livna repositry installed

rpm -ivh http://rpm.livna.org/livna-release5.rpm
and then just type:
yum install kmod-ntfs-smp

30th March 2006, 08:21 PM
Thanks, baschti, that worked perfectly!

It also downloaded a new kernel for me. In GRUB it now displays both kernels. How can I get rid of the old one?

And can someone tell me how I can bring FC to mount all my NTFS partitions automatically at startup?

30th March 2006, 08:33 PM
open terminal type:
rpm -q kernel
the above will show you all the available kernels and then:
rpm -e kernelyoudonotneed

30th March 2006, 08:42 PM
to mount all your NTFS partitions automatically at startup you need to change your etc/fstab


31st March 2006, 08:49 PM
u must compile the kernel, it will works... go ahead. Since the source is obtained at kernel.org.