PDA

View Full Version : powerbook keyboard - FC5



Emastreet
29th March 2006, 06:54 PM
Hi all,
I'm much more than a newbie...
This is my first installation of gnu/linux and Fedora on my pbook.

I can not fully use the keyboard (italian): which means that I can type everything but the keys that with mac os require the "alt key", such as the "@". Some other, like the "" is not mapped at all: it's on the "3" key and if I press shift and 3, I'm expected to type , not 3, like it happens with FC5.
I've already searched in the forum and all the solutions provided are not working on my pb.
Any suggestion?
Thanks a lot,
Ema

bogwire
29th March 2006, 10:44 PM
to provide system-wide (affecting all users) access to the 3rd level function of a key (for example, the Euro Sign using the E key) using the "Apple key" (= command key), just like the "Alt Gr" key would do it on machines intended for Windows, edit the '/etc/X11/xorg.conf' file as root:

# --> Look for the following section:
Section "InputDevice"
Identifier "Keyboard0"

# --> Add this:
# Layout Option "Press Left Win-key to choose 3rd level"
Option "XkbOptions" "lv3:lwin_switch"

EndSectionIf you are logged in into the desktop, log out and re-login for the changes to take effect.

Now, pressing Apple+E should give the Euro Sign and Apple+Q the @ symbol. Note that the latter will not work with alt+L as known from MacOS X.

Emastreet
30th March 2006, 06:57 PM
Thanks Bogwire, but it did't work.
I switched to the English keyboard: I just need to remember where the keys are, but at least I have all of them

Ema

bogwire
31st March 2006, 10:41 PM
Thanks Bogwire, but it did't workHm, could you post the output of
grep -vP '^\s*[#]' < /etc/X11/xorg.conf?

Emastreet
1st April 2006, 08:00 AM
here it is, bogwire:


[Emanuele@localhost ~]$ grep -vP '^\s*![#]' < /etc/X11/xorg.conf

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbRules" "xfree86"
Option "XkbOptions" "lv3:lwin_switch"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Color LCD"
DisplaySize 250 180
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 70.0
VertRefresh 60.0 - 60.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "nVidia Corporation NV34M [GeForce FX Go5200]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

[Emanuele@localhost ~]$

bogwire
1st April 2006, 11:41 AM
You did not execute
grep -vP '^\s*[#]' < /etc/X11/xorg.conf
but the output is OK to show your relevant
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbRules" "xfree86"
Option "XkbOptions" "lv3:lwin_switch"
EndSectionsection.

That looks OK for an Italian keyboard (however, my default FC5 config did not include the "xfree86" line). Pressing both the Apple and E keys should give you the Euro sign, but it doesn't?

I have
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
Option "XkbOptions" "lv3:lwin_switch"
EndSectionfor the German keyboard and it works.

Emastreet
1st April 2006, 01:16 PM
It worked! :)
This is what I've done: I erased
Option "XkbRules" "xfree86"
and I've added the line you have:
Option "XkbVariant" "nodeadkeys"

Then I logged out as root, rebooted the system and logged on as normal user. It asked me to use the keyboard Gnome settings and now everything works fine!

Now I can concentrate on learning fedora!
Thanks a lot, bogwire
Ema