PDA

View Full Version : How to access my HD?



DragonSlayerz
29th March 2006, 05:55 PM
I just recently installed Fedora.
Before I was using SuSE and I was able to access my other HD(contains Windows files), but in Fedora, when I click on the other HD, it would pop up saying "Error. Permission Denied."
Could someone please help me solve this problem? :confused:

Lluisanunez
29th March 2006, 06:04 PM
Do you have FC5 or FC4?

steve1961
29th March 2006, 06:06 PM
I just recently installed Fedora.
Before I was using SuSE and I was able to access my other HD(contains Windows files), but in Fedora, when I click on the other HD, it would pop up saying "Error. Permission Denied."
Could someone please help me solve this problem? :confused:


You need to edit your fstab file so that you can mount the drive as an ordinary user. Check the entry in /etc/fstab and if necessary edit according to the instructions in this how to:

http://easylinux.info/wiki/Fedora_fc5#Windows

ibpalle
29th March 2006, 06:09 PM
...my other HD(contains Windows files), but in Fedora, when I click on the other HD, it would pop up saying "Error. Permission Denied."...

You probably need the ntfs file system driver for your kernel. Do a google search for your kernel version ntfs (get the kernel version by issuing a uname -a in the shell)

If you have FC5 there may be an additional problem if you are running on the initially released kernel. That will pass when the kernel is updated.

DragonSlayerz
29th March 2006, 06:17 PM
I tried:

[root@localhost lxuser]# yum -y install kernel-module-ntfs-$(uname -r)
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/3]
updates [2/3]
extras [3/3]
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: kernel-module-ntfs-2.6.15-1.2054_FC5
Nothing to do
[root@localhost lxuser]#

then i tried
mkdir /media/windows
mount /dev/hda1 /media/windows/ -t ntfs -o nls=utf8,umask=0222

then i got this message

[root@localhost lxuser]# mount /dev/hdb1 /media/windows/ -t ntfs -o nls=utf8,umask=0222
mount: unknown filesystem type 'ntfs'

RHamel
29th March 2006, 06:43 PM
Did you notice this message?

No Match for argument: kernel-module-ntfs-2.6.15-1.2054_FC5
That means no ntfs package was found. Which means no ntfs support was loaded. I think it's fairly safe to say that there is no ntfs rpm's in the core, updates, and extras repositories. So unless you setup another repository that has ntfs packages, you are going to need to manually download the correct rpm. I haven't done it myself, but you might try these instructions:
http://stanton-finley.net/fedora_core_5_installation_notes.html#NTFS

Tashiro
29th March 2006, 07:05 PM
Moved to General Support.

Tashiro

zerovice
29th March 2006, 08:03 PM
check out linux-ntfs.org go to the download page and you'll see NTFS Tools and Library download the src or the src.rpm and you should be good to go. Have done this with no problems on both FC4 or FC5. You are still going to have to edit fstab if you want to access this as any other user than root....

zerovice
30th March 2006, 01:36 PM
And.... I am a crack smoker. sorry about the ntfsprogs bit, I meant to say all you need is kernel-module-ntfs-2.6.15-1.2054_FC5-2.1.26-0.rr.10.0.i686.rpm from http://sourceforge.net/project/showfiles.php?group_id=13956