PDA

View Full Version : FC5 TLS amsn



hobbsy4
29th March 2006, 02:48 PM
Hi.
I have Fedora 5 64 bit running on my machine, I've just come from windows to linux a few days ago.

I want to use AMSN, but keep getting error messages in regards to TLS installing. Now I have downloaded and installed the TLS thru amsn, but it still doesn't work. It does advise, and i believe that this is the case, that for some operating systems, you may have to 'compile and install tls manually'

I have no idea of how to compile the source, can you please help me?

The download path for the tls packages is http://sourceforge.net/project/showfiles.php?group_id=13248

Thanks in advance for your help,
Chris.

PeTzZz
29th March 2006, 07:35 PM
1. If you haven't installed development tools yet then open Package Manager, choose development, check Development Tools and Apply changes.
2. Download tls1.5.0-src.tar.gz.
3. Open the terminal, type su -, enter root password, press enter. Now you have root access in the terminal.
4. Now install openssl-devel, tcl-devel and tk-devel with the command yum install openssl-devel tcl-devel tk-devel.
4. Then type nautilus, press enter. Now locate that source file, open it and extract it to /opt directory.
5. In nautilus (file manager) go to /usr/local, create directory ssl. Now go to /usr directory, right click on the directory include and choose Make Link (or similar). Copy that created link to /usr/local/ssl and rename it to just include.
6. Close the file manager.
7. Type cd /opt/tls1.5.
8. Now begin the compilation. Type ./configure, make and then make install.
9. Now you can close the terminal if you want.
10. Open amsn (you can find it from the menu). Then choose Tools-->Settings. Open the Advanced tab. Scroll down and paste /usr/local/lib/tls1.50 to the textbox what wants TLS path. Save and restart amsn. That's it.

Note: the ssl directory and that directory link is just for workaround of tls compilation problem.

hobbsy4
29th March 2006, 11:39 PM
I have gotten up to and done step 7. When I type /configure it come up with:

bash: /configure: No such file or directory

The source file that I extracted contained a folder with 3 files, pkgIndex.tcl, tls.tcl and libtls1.50.so

PeTzZz
30th March 2006, 12:22 AM
I have gotten up to and done step 7. When I type /configure it come up with:
bash: /configure: No such file or directory
You forgot dot before /configure. It should be ./configure.

The source file that I extracted contained a folder with 3 files, pkgIndex.tcl, tls.tcl and libtls1.50.so
That is tls1.5.0-linux-x86.tar.gz what you downloaded. You should use tls1.5.0-src.tar.gz.

pil
30th March 2006, 12:29 AM
You didn't download the source, what you got is the compiled tls library for linux. The source package is named tls1.5.0-src.tar.gz (with "src" meaning source), just download it from the same sourceforge page.

hobbsy4
30th March 2006, 12:50 AM
Ok i downloaded the source now, and have extracted it to the opt folder, made the link in the ssl folder to the folder include which is in usr.
I ran the ./configure, and then make and then make install, and I got this:

[Chris@Chris ~]$ su -
Password:
[root@Chris ~]# cd /opt/tls1.5
[root@Chris tls1.5]# ./configure
loading cache ./config.cache
checking for gcc... cc
checking whether the C compiler (cc ) works... yes
checking whether the C compiler (cc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether cc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking if libgcc is needed to resolve openssl symbols... no
checking whether make sets ${MAKE}... yes
checking for ranlib... ranlib
checking for Cygwin environment... no
checking for object suffix... o
checking for mingw32 environment... no
checking for executable suffix... no
checking for Tcl configuration... configure: warning: Can't find Tcl configuration definitions
[root@Chris tls1.5]# make
make: *** No targets specified and no makefile found. Stop.
[root@Chris tls1.5]# make install
make: *** No rule to make target `install'. Stop.
[root@Chris tls1.5]#


can you see what the problem is?
Thanks,
Chris

PeTzZz
30th March 2006, 01:21 AM
Did you install tcl-devel and tk-devel? It was the fourth step:

yum install openssl-devel tcl-devel tk-devel
If you didn't add tcl-devel and tk-devel to the end then just run it again as root and then continue with the step 8.

(you can also check if they are installed with the command yum info tcl-devel tk-devel - then the repo line should say installed if the package is installed)

If you actually have installed them then run ldconfig as root and try to continue with the step 8 again.

hobbsy4
30th March 2006, 01:41 AM
Yes, i have run that.

I ran it again, and the after downloading a few 1kb files, it just had the line 'nothing to do' and the bottom.

I then ran cd /opt/tls1.5 , then ./configure

the same message came up. :confused:

PeTzZz
30th March 2006, 01:52 AM
So it seems they are installed.

But try running

./configure --with-tk=/usr/lib/tk8.4/ --with-tcl=/usr/lib/tcl8.4/
as root in /opt/tls1.5.

hobbsy4
30th March 2006, 01:58 AM
Ok, i forgot to mention that I did check the repo line and it did say installed. the ldconfig didn't seem to make any difference.

I just ran the last line that you sent, here are the results:

[root@Chris tls1.5]# ./configure --with-tk=/usr/lib/tk8.4/ --with-tcl=/usr/lib/tcl8.4/
loading cache ./config.cache
checking for gcc... cc
checking whether the C compiler (cc ) works... yes
checking whether the C compiler (cc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether cc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking if libgcc is needed to resolve openssl symbols... no
checking whether make sets ${MAKE}... yes
checking for ranlib... ranlib
checking for Cygwin environment... no
checking for object suffix... o
checking for mingw32 environment... no
checking for executable suffix... no
checking for Tcl configuration... configure: error: /usr/lib/tcl8.4/ directory doesn't contain tclConfig.sh

PeTzZz
30th March 2006, 02:02 AM
Run updatedb as root (it takes some time) and then run locate tclConfig.sh. It should give a path where tclConfig.sh is located. Paste it here, if it finds something of course.

hobbsy4
30th March 2006, 02:07 AM
Ok it found it:

/usr/lib64/tclConfig.sh

PeTzZz
30th March 2006, 02:18 AM
Oh, it seems that in 64 bit system tcl-devel and tk-devel files are installed elsewhere. So try:

./configure --with-tcl=/usr/lib64 --with-tk=/usr/lib64

hobbsy4
30th March 2006, 02:37 AM
Oh, it seems that in 64 bit system tcl-devel and tk-devel files are installed elsewhere. So try:

./configure --with-tcl=/usr/lib64 --with-tk=/usr/lib64
I ran that, it went ok. amsn isn't working yet but i've gtg, i'll put the details here later tonight sometime

Thanks for your help
Chris.

hobbsy4
30th March 2006, 06:51 AM
Hey,
ok this is the 2nd time that I ran that coding, then the make , then make install. I also followed step 10, but it isn't working yet. is it possible that the path /usr/local/lib/tls1.50 isn't valid with 64bit?

anyway here is the results of the tls config and make install (2nd time round)

[root@Chris ~]# cd /opt/tls1.5
[root@Chris tls1.5]# ./configure --with-tcl=/usr/lib64 --with-tk=/usr/lib64
loading cache ./config.cache
checking for gcc... (cached) cc
checking whether the C compiler (cc ) works... yes
checking whether the C compiler (cc ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether cc accepts -g... (cached) yes
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking if libgcc is needed to resolve openssl symbols... no
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... (cached) ranlib
checking for Cygwin environment... (cached) no
checking for object suffix... (cached) o
checking for mingw32 environment... (cached) no
checking for executable suffix... (cached) no
checking for Tcl configuration... (cached) found /usr/lib64/tclConfig.sh
checking for existence of /usr/lib64/tclConfig.sh... loading
checking for Tcl public headers... (cached) /usr/include
checking for building with threads... no (default)
checking how to build libraries... shared
checking for build with symbols... no
checking for tclsh... (cached) /usr/lib64/../bin/tclsh8.4
creating ./config.status
creating Makefile
creating pkgIndex.tcl
[root@Chris tls1.5]# make
make: Nothing to be done for `all'.
[root@Chris tls1.5]# make install
/bin/sh ./config/mkinstalldirs /usr/local/lib
/bin/sh ./config/mkinstalldirs /usr/local/bin
/bin/sh ./config/mkinstalldirs /usr/local/lib/tls1.50
/usr/bin/install -c libtls1.50.so /usr/local/lib/libtls1.50.so
: /usr/local/bin/libtls1.50.so
sed -e "s#\@RELPATH\@#..#" \
-e "s#\@tls_LIB_FILE\@#libtls1.50.so#" \
< ./pkgIndex.tcl.in > pkgIndex.tcl
/usr/bin/install -c -m 644 pkgIndex.tcl /usr/local/lib/tls1.50
/bin/sh ./config/mkinstalldirs /usr/local/include
Installing header files in /usr/local/include
Installing ./tls.h
/usr/bin/install -c -m 644 ./tls.tcl /usr/local/lib/tls1.50
[root@Chris tls1.5]#


cheers,
Chris

PeTzZz
30th March 2006, 07:38 AM
It should be installed now.

I also followed step 10, but it isn't working yet. is it possible that the path /usr/local/lib/tls1.50 isn't valid with 64bit?
Now I think all is about that path what should be put to that textbox. Does /usr/local/lib/tls1.50 contain pkgIndex.tcl and tls.tcl? As of the log it seems that the path should be /usr/local/lib/tls1.50 in 64bit too.

Hm. I don't have any experience with 64bit system. The posted how-to worked for me with 32bit and for some others too (with 32bit system).

Try ldconfig again as root and restart amsn. I think that it doesn't help, but who knows.

I don't have any more ideas at the moment (I am quite busy too today).

:)

hobbsy4
30th March 2006, 07:55 AM
Yeah that folder does contain the two files. It isn't working atm, but hopefully i work it out. Thanks for all your help.

If anyone else has any suggestions, they are very welcome!

Cheers,
Chris

wins0ck
11th May 2006, 10:50 AM
1. If you haven't installed development tools yet then open Package Manager, choose development, check Development Tools and Apply changes.
2. Download tls1.5.0-src.tar.gz.
3. Open the terminal, type su -, enter root password, press enter. Now you have root access in the terminal.
4. Now install openssl-devel, tcl-devel and tk-devel with the command yum install openssl-devel tcl-devel tk-devel.
4. Then type nautilus, press enter. Now locate that source file, open it and extract it to /opt directory.
5. In nautilus (file manager) go to /usr/local, create directory ssl. Now go to /usr directory, right click on the directory include and choose Make Link (or similar). Copy that created link to /usr/local/ssl and rename it to just include.
6. Close the file manager.
7. Type cd /opt/tls1.5.
8. Now begin the compilation. Type ./configure, make and then make install.
9. Now you can close the terminal if you want.
10. Open amsn (you can find it from the menu). Then choose Tools-->Settings. Open the Advanced tab. Scroll down and paste /usr/local/lib/tls1.50 to the textbox what wants TLS path. Save and restart amsn. That's it.

Note: the ssl directory and that directory link is just for workaround of tls compilation problem.
I just want you to know, after A LOT of frustration trying to get aMSN to work from having the same tls problem, I followed all of your steps and it is now working for me, I am so glad I came across this post, Thank you!! :)

ilbh
29th May 2006, 04:56 PM
hi. i have a similar problem:
when i do
./configure
it says:
configure: error: bad ssl-dir: cannot find openssl/opensslv.h under /usr/local/ssl/include

i did install openssl-devel...

ilbh
29th May 2006, 05:03 PM
hmm
my problem was with selinux
:D
solved, i just set it to permissive.
is it recomended?

ajhtiredwolf
9th September 2006, 01:07 AM
Yeah I had the same problem even after i followed all of those steps it still wouldnt work... so i just run it as root, then it works just fine, just change the shortcut onamsn to include logging in as root and you wont have the problem anymore.