PDA

View Full Version : FC5 - Error Dependencies



orbitz
29th March 2006, 10:54 AM
Hi :)

Im tryng to install this programm Qemu-Admin from OLPC-SDK-repo but the installation from yum does not finish in correct way, beacause there are of the problems with these dependencies :

1) perl-Time-HiRes
2) libdbus-1.so.1

demands from the package perl-Net-DBus;

the strange thing is that the 2 dependencies already are installed in the system FC5

1) perl-Time-HiRes (in the subdirectory of Perl )
2) libdbus-1.so.2 (i don't succeed to install the version libdbus-1.so.1 because it is contained in the package dbus-0.33-3.i386.rpm, that it goes in conflict with that one installed in the system the dbus-0.6x)

cbonner
29th March 2006, 11:23 AM
Maybe try uninstalling the packages first, then installing the program Qemu-Admin.

I had similar problems with other packages and programs.

orbitz
30th March 2006, 01:31 PM
Then I have tried reinstall Perl and the errors of dependencies remain.

I have the necessity to install package Perl-Net-DBus as i can make ?

Probably package Perl-Net-DBus goes to try Perl-Time-HiRes in the subdirectory of Perl v5.8.7, while in FC5 the Perl-Time-HiRes package is installed in the subdirectory of Perl v5.8.8. As i can make in order to force the search during the installation in 5.8.7 ?

jpoder
9th June 2006, 04:45 PM
I'm experiencing the same problems trying to install the olpc software. I have tried from both a clean installation of FC4 and FC5 both with the same problems/dependancies. If anyone has a solution, could they please post?

thx.

jim

cubicsilver
10th June 2006, 07:23 AM
I had the same problem

I did a "yum clean all", tried again and it worked.

jpoder
12th June 2006, 04:23 PM
Tried the "yum clean all" method, but still did not work. :( I think I may try posting to the OLPC reflector.