PDA

View Full Version : FC5: compiling xine-lib



LocutusOfBorg
29th March 2006, 07:37 AM
I get the following error when compiling xine-lib in FC5

greedyh.asm:133: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
Does someone know what's going wrong?
Thanks,
LoB

giulix
29th March 2006, 01:46 PM
What version and for which platform ? Oddly enough

./configure --with-xv-path=/usr/lib --with-xxmc-path=/usr/lib --with-xxmc-lib=/usr/lib --with-xvmc-lib=/usr/lib/libXvMC.so

compiles fine on a C610 Dell laptop (PIII)...
btw, if you don't have any special requirements, there's one already available at freshrpms (http://bordeaux.freshrpms.net/rpm.html?id=735)

LocutusOfBorg
29th March 2006, 02:02 PM
I tried recompiling both the freshrpms and the cambuca/daily srpms - it's always worked on FC4.
The reasons why I want to do so is that xine has a annoying bug in the faad code which results in slow playing multichannel aac audio.
I can fix it copying in the libfaad directory of the xine-lib sources the *.h and *.c files from the libfaad2 directory of MPlayer, and rebuilding the rpm.
I know that MPlayer (which is my favourite and most used player) works out of the box, but I'd like to resolve this as well.

giulix
29th March 2006, 02:09 PM
I see... well, I compiled xine-lib-1.1.1.tar.gz from here (http://xinehq.de/index.php/releases) and had no problems.

LocutusOfBorg
29th March 2006, 02:17 PM
Tonight I'm going to retry it. I've found another thread on this forum: same issue, no answers...
Some googling suggested me to use another compiler - I will try, but with GCC4 in FC4 xine-lib has always succeded. Strange.
Anyway, thanks for your interest. :)

Bandit
29th March 2006, 03:40 PM
Get Xine 1.1.2 from the CVS.
1.1.1 will not compile to save my life, its a GCC/Kernel/Something else also issue as far as I can tell.

Then just use this to configure:

./configure --prefix=/usr --with-mozilla

Try just that. Everything else should detect and install without a hich unless your missing a dev file.

Cheers,
Bandit

LocutusOfBorg
30th March 2006, 07:09 AM
I managed to rebuild the rpm with the modifications in the faad code I wanted using gcc32 instead of gcc 4.