PDA

View Full Version : SELinux and Quake 4 issue



borgi2008
29th March 2006, 05:49 AM
Hello,

today i updated quake 4 to 1.1 and now i have problems with selinux and quake4. if i start it it seems that it cannot load it libriaries. here is a small output of dmesg


audit(1143607276.216:1432): avc: denied { execmod } for pid=3330 comm="quake4.x86" name="pbcl.so" dev=sda6 ino=24448306 scontext=user_u:system_r:unconfined_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=file
audit(1143607276.272:1433): avc: denied { execmod } for pid=3330 comm="quake4.x86" name="pbsv.so" dev=sda6 ino=24448305 scontext=user_u:system_r:unconfined_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=file
audit(1143607276.288:1434): avc: denied { execmod } for pid=3330 comm="quake4.x86" name="pbcl.so" dev=sda6 ino=24448306 scontext=user_u:system_r:unconfined_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=file
audit(1143607276.328:1435): avc: denied { execmod } for pid=3330 comm="quake4.x86" name="pbsv.so" dev=sda6 ino=24448305 scontext=user_u:system_r:unconfined_t:s0 tcontext=system_u:object_r:default_t:s0 tclass=file


/files/games/quake4/pb
[hendrik@geekpc pb]$ ls -Z
drwxrwxrwx hendrik hendrik system_u:object_r:lib_t htm
-rwxrwxrwx hendrik hendrik system_u:object_r:lib_t pbag.so
-rwxrwxrwx hendrik hendrik system_u:object_r:lib_t pbags.so
-rwxrwxrwx hendrik hendrik system_u:object_r:lib_t pbcl.so
-rwxrwxrwx hendrik hendrik system_u:object_r:lib_t pbcls.so
-rwxrwxrwx hendrik hendrik system_u:object_r:lib_t PBEULA.txt
-rwxrwxrwx hendrik hendrik system_u:object_r:lib_t pbsv.so

any help is welcome

borgi2008

imdeemvp
29th March 2006, 05:51 AM
Now, have you disabled it yet? if not, you should...

borgi2008
29th March 2006, 05:52 AM
yes i had it set to "setenforce 0" and it runs just fine. but i don't want selinux disabled.

imdeemvp
29th March 2006, 05:55 AM
Maybe if you trying running quake 4 in the terminal as root that will do the trick.

borgi2008
29th March 2006, 02:47 PM
Hello,

i've tested it but without effort. it does not work as root. :confused: I think SElinux is a very good ide and so i don't want to disable it

borgi2008