PDA

View Full Version : permission deined for NTSF drives



cameraman
29th March 2006, 04:15 AM
I have 2 ntsf Drives that i store all my photos on I would like to be able to access them in FC5 when i had my system set up with XP those drives were sharing capable... i did not change that back before i took XP off my system.. neither drive has an operating system on it... all the error says is permission denied ... the error by konquer but both the drives show up in the storage media window any help would be very apperciated

jhetrick62
29th March 2006, 05:19 AM
You need to compile ntfs into your kernel. Read this link: http://stanton-finley.net/fedora_core_5_installation_notes.html#NTFS

After following the link to enable ntfs support in your kernel, then you probably need to add statements in your fstab similar to this. Man mount for more info.
//dev/hda# /mnt/mountpoint ntfs ro, user, defualts 0 0

There are many options for the option line, you will have to use the ones you want. If you want them mounted everytime you boot, add option "auto" to the sequence.

Jeff

cameraman
29th March 2006, 03:19 PM
Thanks for the help but this did not allow me to access the drives still only give the same error

baschti
29th March 2006, 03:35 PM
hi,
try:
su - //enter password to become root
yum install kmod-ntfs //to enable ntfs read support (need livna repositry)
fdisk -l //to find the correct partition (/dev/hdxx)
mount -t ntfs /dev/hdxx /path/to/mount
if that all works edit your /etc/fstab, insert an entry like
/dev/hda1 /mnt/windows/c ntfs ro,defaults,umask=0222 0 0

jhetrick62
29th March 2006, 03:37 PM
Did you have strict permissions set to limit other users from viewing or changing these files when you were running XP?

Jeff

ceg4048
30th March 2006, 06:28 PM
Hello,
I am having similar difficulties as the original poster. The issue is not whether the ntfs driver is loaded, they are. This is a permission issue because in my case if an ntfs external hard drive is plugged into the usb port as a non-root user I get a konqueror message "could not enter folder /media/medianame" upon attempted access. Root can access the drive, however, if root attempts to change permission via the gui (i.e right click->properties->permission an error message is received after changing the fields and clicking OK. This does not occur when a FAT32 external drive is plugged in.

Could you advise what the command is via terminal? The chown command is still a mystery to me even after having read the man page.

Cheers,