PDA

View Full Version : Removing Repos



phefner
29th March 2006, 03:46 AM
I know this is probably a very simple question, but I have been trying to change repos and have gotten myself into a bit of a pickle.

I originally had the Livna repo in YUM. I removed it from yum.reposd folder, and proceeded to install the freshrpms repo. Well, that one didn't work out so I tried to go back to the Livna repo. When I try to install the release-5.rpm file again, I get a message stating that it is already installed, however it doesn't show up in the yum.reposd folder and when I create the text file with the proper info in it, it still doesn't show up in yumex.

Can anyone tell me how to uninstall this livna repo rpm so I can reinstall it again. Is there an easier way?

I've searched throughout the forum and can't find an answer. I've also googled, with no luck either. I've tried yum remove livna-release-5.rpm but it says that it isn't found anywhere. I also tried rpm -e livna-release-5.rpm and I get the same message.

Thanks well in advance,

phefner
29th March 2006, 03:49 AM
woops! Nevermind, I figured it out. rpm -q is my friend!!!!

bob
29th March 2006, 04:01 AM
You can also keep the freshrpms.repo and simply change the 'enabled=1' to 'enabled=0' so that it doesn't normally call it up. Then, if you want to use it, you'd simply type: "yum --enablerepo=freshrpms install programname" . I try to keep them all hanging around, just in case.

phefner
29th March 2006, 04:18 PM
thanks Bob. I felt so stupid because 2 minutes after I made this post, I figured out what I needed to do. I have re-installed the livna repo and freshrpms, but as you pointed out, I have freshrpms disabled so that it doesn't show up.

thanks for the tip!