PDA

View Full Version : FC5: Nautilus always opens window on login



Seehund
28th March 2006, 05:44 PM
Does anyone know how I can get rid of the Nautilus window that insists on opening everytime I login to GNOME?

I want Nautilus running (handling the desktop), I just don't want an open window working on listing my rather huge home dir as soon as I start a session.

This behaviour started when I messed with the session-properties applet to get the Firestarter control program to run on login.

I've tried closing the window, set "save session on logout" and log out.
Didn't work, the window is still there on login.

I've tried killing Nautilus and removing the "nautilus --sm-config-prefix /nautilus-<randomcharacters>/" process from the session-properties applet. Clicked "apply". Then I logged out with "save session" turned on. I logged back in, Nautilus was gone and the desktop was empty as expected, and I set Nautilus to draw the desktop and turned off "save session". Logged out and logged in again. The goddamn window is back!

What to do now?

Seehund
29th March 2006, 03:23 PM
Bada-bump!

giulix
29th March 2006, 05:11 PM
Delete the saved session: System->Preferences->More Preferences->Sessions, click on Default (I think it is) and press Delete.

Seehund
29th March 2006, 10:07 PM
Delete the saved session: System->Preferences->More Preferences->Sessions, click on Default (I think it is) and press Delete.

Thanks, that did get rid of the Nautilus window while still letting Nautilus draw the desktop.

Alas, it also got rid of Firestarter and GKrellm, and as soon as I saved the session with those running on logout, the bleedin' Nautilus window was back the next time I logged in! Argh.

In case anyone else gets this problem, this finally worked for me:

1. Delete the Default session as per giulix' instructions.
2. Add what you want to run in the "Start-up programs" [translated from Swedish] list in gnome-session-properties. Click "Close". Do NOT touch anything else.
3. Again, do NOT touch anything in session properties. Do NOT use "save session on logout". Forget about trying to change the starting order for your programs, their rules for re-starting, or anything else, it will force an open Nautilus window upon your poor desktop at every login.

Conclusion: Either Nautilus or GNOME's session management is b0rken?