PDA

View Full Version : Refresh rate issues



Mikha
28th March 2006, 08:21 AM
Hey, I'm having problems with my refresh rate. I change it to one setting, but each time I boot it changes it back to another setting. Is there a config file or something that I need to change?

Saint Mike
28th March 2006, 08:52 AM
look in


[root@localhost ~]# gedit /etc/X11/xorg.conf

If ya doing it in gnome, im not sure on this but you might need to change it to save session info when ya log out.

System --> preferances --> more prefferances --> sessions

Mikha
29th March 2006, 04:13 AM
The xorg.conf file doesn't have any settings for refresh rate, at least nothiing I can manipulate to keep it from changing. I save every session so if that was the way to fix it then I would have never had the problem.

BoyWonder410
29th March 2006, 08:49 AM
i'm having the same problem, and i do have gnome set to save session.

stanmc
29th March 2006, 05:09 PM
i'm having the same problem, and i do have gnome set to save session.
When you go to applications/System/Preferences/Screen Resolution do you find the correct Hz there? When you change it to what you want, does it remain after you click Apply?

Mikha
30th March 2006, 12:10 AM
Yes and yes. I'm able to change it, but it resets back to the default when I restart my computer.

BoyWonder410
4th April 2006, 08:03 PM
same here.

stanmc
5th April 2006, 01:28 AM
same here.
Just wondering what Hz you are trying to set it for. I'm running 1152x864 resolution with 85Hz and my nVidia 6200TC card is as stable as can be. It doesn't reset either. I'm running Gnome and FC5.

My xorg.conf shows the following for my monitor.

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ViewSonic PT775"
DisplaySize 320 240
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Are you trying to set a very high refresh rate? Maybe that is what is causing the reset.

James Bridge
6th April 2006, 08:07 PM
I get the same problem with refresh rate: I want to use 70 Hz but rebooting always makes it go back to 75. The help page (for Gnome) says that Preferences - Screen resolution ought to let me set resolution and refresh rate, which it does, and also should have a check box to let me choose the new setting as the default. This check box is missing.

It used to work in FC4, and it's the same video card and monitor.

xorg.conf seems to store the possible values; where are the default values?

bluegum
8th April 2006, 01:16 PM
SAme issues here it sets mine to 85 HZ
and it flickers like crazy every boot,
I have to change it down to 60 to get it to not flicker..
but every reboot I have to redo it from 85 back to 60
running nvidia Gforce 6800 ultra... @ 1024X768 32
so its not like i am trying to tax out the system..

I have to set this to 60 EVERY reboot

http://handgunplace.com/images/fc5_screen.JPG

doornail
8th April 2006, 04:00 PM
I just went through this at work yesterday setting up an LCD monitor. The manufacturer recommended a 60hz refresh and FC would only offer 75hz. After some searching I found the answer was to use the gtf command to calculate a modeline.


usage: gtf x y refresh [-v|--verbose] [-f|--fbmode] [-x|--xorgmode]

x : the desired horizontal resolution (required)
y : the desired vertical resolution (required)
refresh : the desired refresh rate (required)
-v|--verbose : enable verbose printouts (traces each step of the computation)
-f|--fbmode : output an fbset(8)-style mode description
-x|--xorgmode : output an Xorg-style mode description (this is the default
if no mode description is requested)

I wanted 1280x1024 at 60hz, so I typed:


$ gtf 1280 1024 60

# 1280x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 108.88 MHz
Modeline "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync


Copy and paste the output into the "Monitor" section of your xorg.conf.

Good luck.

bluegum
9th April 2006, 04:06 PM
I just went through this at work yesterday setting up an LCD monitor. The manufacturer recommended a 60hz refresh and FC would only offer 75hz. After some searching I found the answer was to use the gtf command to calculate a modeline.


usage: gtf x y refresh [-v|--verbose] [-f|--fbmode] [-x|--xorgmode]

x : the desired horizontal resolution (required)
y : the desired vertical resolution (required)
refresh : the desired refresh rate (required)
-v|--verbose : enable verbose printouts (traces each step of the computation)
-f|--fbmode : output an fbset(8)-style mode description
-x|--xorgmode : output an Xorg-style mode description (this is the default
if no mode description is requested)

I wanted 1280x1024 at 60hz, so I typed:


$ gtf 1280 1024 60

# 1280x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 108.88 MHz
Modeline "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync


Copy and paste the output into the "Monitor" section of your xorg.conf.

Good luck.

Great tip and i did that
but witht he same results have to change from 85HZ to 60HZ every reboot
heres my monitor section

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Samsung SyncMaster 997DF/927DF/997MB/927MB/927DFI/927MBI"
DisplaySize 350 260
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
ModeLine "1152x854_60.00" 80.6 1152 1216 1336 1520 854 855 858 884 -hsync +vsync
Option "dpms"
# 1152x854 @ 60.00 Hz (GTF) hsync: 53.04 kHz; pclk: 80.62 MHz
EndSection

James Bridge
9th April 2006, 07:30 PM
I tried it too, but no joy. Gnome doesn't remember the setting. Does it work with KDE?

steve1961
9th April 2006, 08:34 PM
After the latest nvidia driver upgrade I found that I didn't even have the option to change my refresh rate from 75hz to 60hz, it was stuck at 75. So I tried inserting the modeline in the monitor section, but no difference. However, after googling this issue it seems that you also have to modify the screen section of xorg.conf. In the default section I changed "1280x1024" to "1280x1024_60" as below:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024_60.00"
EndSubSection

When rebooting the refresh rate is now set to 60hz.

James Bridge
10th April 2006, 11:27 PM
Success! Thanks to steve1961 and doornail.

bluegum
12th April 2006, 06:55 PM
now my X wont start i try to install the nvidia drivers and it says u have X running
i then edited as above poster did and i am sutck with boot errors cant start x etc etc..
:(

JubJub
31st October 2006, 07:18 PM
steve1961 & doornail,

I know this thread is old, but I just found it very useful. After beating my head against the wall with my system for a while I found this post and everything is working.

Thanks