PDA

View Full Version : Videolan client quits when playing files



Keelan
28th March 2006, 07:32 AM
When I open files with videolan the client quits without displaying any error message. I can see the first screen of the movies, and the seeker goes forward for about 2 seconds, then the client disappears.
I've tried .avi, .mov, etc. The codecs are installed and they play just fine in mplayer.

daneel971
28th March 2006, 08:13 AM
Same here. I use the freshrpms version, and I tried it with some matroska file. If you run it from a terminal, you will see the error log.

Keelan
28th March 2006, 10:29 AM
Thank you. Did just that :)

vlc: pcm_plug.c:384: snd_pcm_plug_change_channels: Forutsetningen (assertion) «snd_pcm_format_linear(slv->format)» feilet.
Avbrutt (SIGABRT)

Directly translated to english:
vlc: pcm_plug.c:384: snd_pcm_plug_change_channels: Prerequisite (assertion) «snd_pcm_format_linear(slv->format)» failed.
Interrupted (SIGABRT)

Now what could this be about? The sound settings?

(Any idea how to get error messages in english, and not localized, without changing the language config?)

Keelan
28th March 2006, 10:48 AM
For reference, it was the ALSA device setting. Fixed it perfectly.
I've decided to go with mplayer because of the wmv support, even though I do not like the GUI much. Guess I can't have it all.

Lluisanunez
28th March 2006, 10:53 AM
You can change the gui for mplayer with
yum install mplayer-skins

Keelan
28th March 2006, 05:44 PM
You can change the gui for mplayer with
yum install mplayer-skins

Yes, it's growing on me for every skin shift. Thank you :)

Shobhit Jindal
30th March 2006, 09:47 AM
Hey keelan how did ye fix the problem below ??

vlc: pcm_plug.c:384: snd_pcm_plug_change_channels: Prerequisite (assertion) «snd_pcm_format_linear(slv->format)» failed.
Interrupted (SIGABRT)

Marvelous
30th March 2006, 09:51 AM
i would like to know the steps as well.. cause i suddenly started to have the same problem

Keelan
30th March 2006, 10:09 AM
Hey keelan how did ye fix the problem below ??

vlc: pcm_plug.c:384: snd_pcm_plug_change_channels: Prerequisite (assertion) «snd_pcm_format_linear(slv->format)» failed.
Interrupted (SIGABRT)

Changed the setting in vlc that has to do with the ALSA device (don't have vlc installed so can't say exactly where it is).
I am guessing the guide found at http://stanton-finley.net/fedora_core_5_installation_notes.html#VLC will explain it.


Hit enter. Wait for the installation to complete. Close the terminal. VLC will be available in "Applications" > "Sound & Video" as "VideoLAN Client". (You will probably have to configure VLC for your sound card. Open VLC. Select "Settings" > "Preferences". Tick the "Advanced options" check box in the lower right hand corner. Maximize the GUI window. Under "Audio" > "Output modules" select "ALSA". Click on the "Refresh list" button. Select your ALSA device name from the drop down menu. Alternately you may have to select "OSS" rather than "ALSA" depending on your sound system. Be sure to click the "Save" button in the lower left corner when you are finished.)

Shobhit Jindal
30th March 2006, 10:28 AM
thnx dude .. hav got my feel good factor back

Marvelous
31st March 2006, 12:07 AM
@Keelan
Thanks it doesnt crash anymore