PDA

View Full Version : Totem-Xine sound configuration problem on FC5



PilotJLR
28th March 2006, 02:11 AM
Hello all,

Since the version of totem in livna for FC5 would only crash on my machine, I installed Totem-Xine 1.2.1.

It would great on AVI and MPEG files... but when I try to play a dvd, the sound doesn't work properly. Problem is, the DVD's audio is in 5.1 Dolby Digital. I have 2 speakers... so I try to configure the audio preferences in totem-xine to "Stereo." Although it takes the preferences change, the problem isn't solved.
Also, every time I restart Totem-Xine, the preferences go right back to Digital 5.1.

Anyone know how to fix this? Maybe even a manual way to set the sound prefs?

THANKS!

Firewing1
28th March 2006, 02:34 AM
Heh, did you use my howto? lol Totem-xine 1.2.1...
Anyways, if you did it's a simple matter of:
su -
rpm -Uhv http://rpm.livna.org/livna-release5.rpm
yum update totem-xine
Firewing1

PilotJLR
28th March 2006, 02:49 AM
haha - I did, yes... thank you for it, too! Got most of Totem working right off the bat!

I removed the symlinks from before, then ran this update... on version 1.4.0 now from livna. Must be brand new; at least, I don't recall this being in livna a couple days ago.

Anyway - I'm using version 1.4.0 now... WMV and AVI and MPG files work great. Now no audio whatsoever in a DVD.

Interestingly, the audio properties now default to "AC3 Passthrough." Even when I change this to stereo, it's a no go.

Anything else I should check or update???
Thanks again!

Firewing1
28th March 2006, 03:56 AM
Try running the soundcard configuration and seeing if that works....
Firewing1

jtl
28th March 2006, 09:47 PM
Hm, nice to see a working totem-xine - but unfortunately it works only when I start it with a media file already given (be it avi, mp3 or whatever....) just starting totem gives:

[~] $ totem
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
(Details: serial 82 error_code 11 request_code 140 minor_code 19)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

I'm a bit at a loss what to do next.... This happens on a fully updated FC5

Firewing1
28th March 2006, 10:42 PM
So your saying this only happens if you supply a path in the CLI? If so, report a bug at rpm.livna.org
Firewing1

jtl
28th March 2006, 11:06 PM
No the other way around. It crashes when I DON'T start it with a path already given. A bug is already filed.

PilotJLR
29th March 2006, 04:10 AM
To confuse the matter more... I have another sound problem.

Firewing1 - I ran the soundcard detection applet. It detects the proper sound card, but the test sound does NOT play. Despite this, my mp3 players all work, totem-xine now plays DVD audio properly too. When I mount a DVD iso file, though, totem-xine will NOT play any audio at all.

I've played several DVD's from iso files on the hard disk; it always worked flawlessly in FC4.

So I have no idea what's going on with the sound now... do you think this is something for bugzilla? Or am I missing something here?

Thanks!

Firewing1
29th March 2006, 04:43 AM
Yup, definetly for bugzilla.
bugzilla.redhat.com
Firewing1