View Full Version : Agere Modem - I'm at the end of my rope!

28th March 2004, 03:07 AM
Ok, I have a newly-purchased Compaq Presario X1030US laptop. I have resized the NTFS partition to 30 GB, leaving around 8GB for Linux (I plan to leave my .ogg collection on the Windows drive if I can get it to work right--but that's another question for another time). I have tried Fedora Core 1, Mandrake 9.1 and Knoppix 3.3, and none of them have worked with my modem yet. However, looking around the internet I get the impression that it *should* work.

In Windows XP, the modem registers as "Agere Systems AC'97 Modem." I really don't know that much about it other than that.

I have tried so many different things it's not funny: kernel 2.4.22, kernel 2.6.4, slmdm-7.9.10 (or whatever--can't remember the number exactly, but it's the one that's supposed to work on my model), ltmodem...several other packages...I've even tried an Agere driver and nothing I have tried seems to work (and last time I tried, scanmodem gave me nothing). I was never able to dial with kppp or with Gnome's network utility (normally I get error number 7, if that helps any). Dunno if it's my comp or my install procedure, but I'm not getting anywhere.

I'm relatively new to Linux, but I'm not a total newbie (but i prolly know less than I think I know). I can edit config files with vim (oops, now all you Emacs folks won't help me...shoot :-) and compile a kernel if I have to.

But I really have no idea where to start troubleshooting this thing and I don't have a ton of time to pursue it. The lack of internet access (I'm still on dialup around here) is really holding back the % of time that I use Linux vs. the time that I use WinXP. Theoretically, I should only have to boot back into Windows to do SWGB (hey, i think it's a good game, ok?) and UT2004, but in practice I just can't make Linux do everything that I need to do. And it's annoying the you know what out of me. :-(

FYI, right now I'm using the "Desktop" installation of Fedora Core 1 with a few added packages (ie. kernel source). I have also installed the kernel module to access my NTFS partition.

If I had a LUG near me I would go there...but I don't know anyone else around here with any level of expertise in Linux...so I'm coming here. :-)

How do I even begin troubleshooting this? I really want this to work. Basically, I need to know what I need and how to install it properly. But I would like to actually understand what I'm doing if possible (I like to think that I'm half-way intelligent).

I appreciate any and all help rendered. (read: "PLEASE HELP ME CAUSE I'M DESPERATE") ;-)

-- Michael

PS. Sorry for the long post, but I wanted to be descriptive.

28th March 2004, 09:26 AM
You can play UT2004 on Linux. I am ;), and you may have some NTFS issues with writing to the windows partitions with you .ogg files. For some help on that i suggest you search the forum for NTFS.

I also fully understand about the modem problem, I too am stuck on a 56K modem. I also couldn't get the modem to work on this computer and had problems like you, in the end I just went out and brought a proper external serial modem for 20 ($35?). One of the best buy's i've ever made, it may be a pain to have to carry it around with the modem, but its much better than fighting with the drivers.

Have you tried the linmodem how-to? http://walbran.org/sean/linux/linmodem-howto.html

28th March 2004, 06:56 PM
You can play UT2004 on Linux. I am , and you may have some NTFS issues with writing to the windows partitions with you .ogg files. For some help on that i suggest you search the forum for NTFS.

Yeah, I d/l'ed the Linux demo (haven't tried it yet) so we'll see how that goes. When does the full game come out for Linux (or is it already out)?

On the NTFS, yeah, you may be right...I'm not sure what to do. Right now I can access them from Linux but I have to be root, which stinks. I might shrink the NTFS partition again and make a FAT32 partition or something for them...'cause I need to use them from Windows, too.

I've looked at so many daggone modem how-tos and tutorials on the 'net that I'm not sure if I have seen this one yet or not. But I'll check it out. ;-)

$35? That's not bad. Maybe I'll just do that and save myself some time and trouble. Is yours USB or what? What about a PCMCIA modem? I'm not currently using my slot for anything. Which would be more reliable (right now I just really want to get SOMETHING to work)?

29th March 2004, 07:34 AM
Mines a serial port modem. You can generally tell if its a hardware modem, by the fact that their normally external modems and usually connect to the serial ports on your computer.

You can find a serial port modem here (http://www.ebuyer.com/customer/products/index.html?action=c2hvd19wcm9kdWN0X292ZXJ2aWV3&product_uid=62632). I also need to revise that figure of $35, they're more expensive where you are. $57.34 in fact.

And yes, UT2004 is out!

29th March 2004, 05:47 PM
The X1030 doesn't have a plain old serial port. I have 3 USB 2.0, 1 firewire (4-pin) and one PCMCIA.

$60? Hmmmm....that's less appetizing...especially if there's any shipping costs involved.

Shoot...it just really annoys me that I can't get the internal one to work. There's a forum specifically for my laptop (http://www.x1000forums.com/) and I've been reading posts on there (ie. http://www.x1000forums.com/index.php?showtopic=1854) about the modem and lots of people seem to have it working. I'm just not sure what I'm doing wrong. I've installed slmdm-2.7.10 (I've also tried changing the line in amrmo_init.c like they said) and lsmod shows that it's in there. /dev/modem is a link to /dev/ttyS0. I've even installed a driver I found somewhere on Agere's website. Neither kppp or Gnome's network utility nor the Modem Lights panel will do anything meaningful (one time the Modem Lights thing said I was connected but I didn't believe it because I couldn't actually do anything on the internet). Querying the modem in kppp results in a "Modem Ready" message but the ATI strings come back blank. At one time I was getting intelligent ATI strings but I can't remember how I got that.

BTW, I was a little vague on details in my first post, sorry...in Linux, running lspci I get a line that mentions Intel 82801DB AC '97 (sorry I don't have the whole line, I just wrote down that much). I'm assuming that's the chipset info. In Windows XP device manager, I get the following info:

Agere Systems AC'97 Modem
PCI Bus 0, Device 31, Function 6
IRQ is 10

One thing I noticed was the COM port number. In Windows it says COM4 but in Linux I'm using ttyS0. Maybe I should try ttyS3?

Also, I know this just complicates things further, but my modem volume seems to be permanently muted. I can't get any noise in Windows or Linux. It used to, but I can't remember when it stopped. It still works fine in Windows, though, I just don't hear anything when it dials. I don't really mind, but it's kind of annoying because I'm not entirely sure whether or not it's doing anything in Linux.


On a side note, I installed the UT2004 Linux demo and it doesn't work. The game loads but the levels won't. But I'll figure that out later. Right now I just want internet access. If I could get that then I could move 60-80% of my computer tasks to Linux.

Thanks so much for your patience!

29th March 2004, 08:34 PM
Most likely its a winmodem most laptop modems are :(.



get the scanmodem tool it will tell you what chipset you are currently running and suggest a driver for you :).

It worked great for me !! now if only i can get that demand dialing to work

30th March 2004, 06:03 AM
Ok, this scanmodem worked...I'm attaching the resulting ModemData.txt.

Well, I guess I'm off to download and try slmdm-2.9.6. I thought I had already tried that, but I guess I'll try again.

Do I need to somehow uninstall slmdm-2.7.10 first? Guess I'll try "make uninstall".

*sigh* This is why Linux is not a major player in the desktop market yet...only idiots like me would stick with something this long to make it work! ;-)

Yeah, I know it's the modem company's fault and not Linux's...whatever... ;-)

30th March 2004, 07:25 AM
Don't give up yet! The modem was my biggest frustration, and at the end of the day the reason why it wouldn't work was ultimately windows. As the "winmodem" was designed with software which would only work in windows...

30th March 2004, 07:35 PM
I am currently doing the same thing working on my winmodem using the readme file I setup the modem driver though you may wanna have the driver load on boot by using chkconfig once you get everything working :). I have made kppp work when I startup the driver in a terminal and point kppp to /dev/ttySL0 and it dials and connects successfully

if you wanna use wvdial
wvdialconfig /dev/wvdial.conf will make wvdial detect your modem however you will have to still edit the conf file not only to put provider info in but you may have to put Stupid mode=1 in which hands it off to pppd to do the authenication then pppd may not work argh !

If you want to use pppd you have to make a dialing script. Which i have not been able to successfully do yet but it seems pppd is the only software capable of demand dialing (sigh). Faund an awsome site that will create scripts for you : http://www.linux.net.nz/pppconfig/
however now pppd gives me seg faults argh !

By far kppp seems the easiest just to see if your modem is working :D

31st March 2004, 06:19 AM
Yehaaaaaa!!!!!!!!!!!! I'm posting this from Mozilla 1.4 on Fedora Core 1 Linux! Yeah, baby. :-)

Is it just me or is Mozilla 1.4 kind of old? They've got at least 1.6 now (plus 1.7 beta or whatever). Oh, well...I've got some updating to do. Maybe I'll just install FireFox .8 anyway...that's what I was using on Windows.

So what did I do to get it to work? I'm not entirely sure. Basically, I d/l'd slmodem-2.9.6 and installed it. Not sure what I did differently from all the other times, but it now all I have to do is:

/usr/sbin/slmodemd --country=USA

And kppp dials and connects without a hitch. Wow...this is really cool. :-)

Ok, here's a little problem that I *know* someone knows how to fix. Right now the /usr/sbin and /sbin folders don't seem to be in my PATH variable. Where is the "appropriate" config file to add them to? .bashrc in root? .bash_profile in root? profile in /etc? I'm rather confused on this (rather simple) point.

Ok, well, I got the modem working this morning. All day I've been trying to get other stuff working. After spending about six or seven hours altogether doing basically nothing I've come to conclude that I'm going around in circles. :-( Here's a brief rundown of what I did:

-- tried ndiswrapper .6 for wireless centrino - froze my machine when I tried to load the Windows drivers (and I mean FROZE; i had to physically press the power button)

-- tried ndiswrapper .3, .4 and .5, all same results

-- tried different version of windows drivers; same result

-- tried driverloader from linuxant; same result

-- tried intel's experimental centrino driver; same result

At this point I'm getting really p/o'd. :-( So I decided to forget that for a while.

Looked into suspend-to-disk (hibernate--something I used in Windows all the time), but it appears to me that you have to recompile the kernel to get it to work and I would rather avoid that. Is there any way to hibernate without recompiling the kernel? I guess not, though, since it's kind of a function of the kernel...oh well.

Then I made a big mistake. I tried installing the ATI graphics drivers. Suffice it to say that they didn't work well at all (made graphics slow and killed my resolution) and I spent about an hour getting rid of them and getting my 1280x800 resolution back. Right now I actually have "Radeon 9500" selected even though my card is a Mobility Radeon 9200. Hey, it works.

So after I got that working again, I tried fiddling around with the UT2004 demo. I found that it works in Software mode (looks terrible) but it still freezes in OpenGL mode.

Sooooooooo.....what works?

- 1280x800 display
- keyboard, touchpad and USB mouse
- modem and browser
- OOo and NetBeans
- sound, XMMS and .ogg files
- access to my NTFS partition and USB key drive
- Chromium (addictive little game) and UT2004 demo in software mode
- the Gimp (replacing the PSP that I use in Windows)

What doesn't work?

- wireless card
- UT2004 demo in OpenGL mode
- volume buttons (not a big deal)
- Blender (but I've seen the problem before and I know how to fix it)

What haven't I tried?

- 10/100 ethernet
- firewire
- SD slot
- PCMCIA slot
- printing
- VGA out
- infrared
- Palm pilot sync (I have a Tungsten E...haven't installed the pilot app yet)
- battery (been using the adapter all this time)

Anyway...things are finally starting to shape up. Thanks for your patience and suggestions. Running Linux as a primary OS as been a dream of mine for many years and now it's looking like that might actually be happening. :-D

9th January 2005, 12:35 PM
if you wanna use wvdial
wvdialconfig /dev/wvdial.conf will make wvdial detect your modem however you will have to still edit the conf file not only to put provider info in but you may have to put Stupid mode=1 in which hands it off to pppd to do the authenication then pppd may not work argh !

I've tried using this... Yesterday I got my modem working (fresh installation of FC3, and installed the appropriate drivers for my winmodem.

Now I boot up today, and my modem won't work!!

Yesterday I could do [root@astro ~]# wvdialconf /etc/wvdial.conf and it would come up with all the detecting as OK. But as soon as i've rebooted... I try the same thing and I get:

[root@astro ~]# wvdialconf /etc/wvdial.conf
Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
ttyS1<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS1<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS1<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Port Scan<*1>: S2 S3 S4 S5 S6 S7

Sorry, no modem was detected! Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wvdial/

If you still have problems, send mail to wvdial-list@lists.nit.ca.
[root@astro ~]#

Now I tried reinstalling the RPM, but it's already there. so I can't do that... I've tried:
[root@astro ~]# modpobe DriverName
-bash: modpobe: command not found

but I get that error..

Now what the hell an I doing wrong!!!!!!!!!!!!!!!!!!!!!!!!!!

Working one day, not the next... I am totally at the end of my rope... It took me 3 days to get my winmodem working in the first place..... and now.....??