PDA

View Full Version : FC5 and Smart 2 Raid problems



Mesu
26th March 2006, 10:15 PM
Hi,

Had another thread in here but it was headen in dark terratory. Could not see how to close it but needed this new path, , , , I think.

Installing FC5. No hard drives found. Driver cpqarray loads but does not see drives.

Dmesg shows the following:

cpqarray Device 0x10 found at bus 0 dev 1 func 0
cpqarray Finding drives on ida0 <4> cpqarray ida0: idaSendPciCmd Timeout, no command list address returned !
cpqarray error sending ID controller

I do not understand for sure what the problem could be. It seems to find the raid controller but not the drives in it?

RH 7.0 works fine but is kernel 2.4 series.

Any ideas ?

Thanks,

Mesu

Mesu
27th March 2006, 03:30 AM
More info

FC4 loads fine. When I compare Dmesg results the only difference I see before the errors is:

cpqarray Device 0x10 found at bus 0 dev 1 func 0
ACPI Interupt link [ITR3] enebled at IRQ5 PCI setting IRQ5 as level Triggered
ACPI PCI interupt 0000.00.01.0[A] -> Link [ITR3]-> GSI5 (level,low) -> IRQ5
cpqarray finding drives on ida0 (integrated Array)
cpqarray ida/c0d0:blksz=512 nr_blks=35520480
cpqarray starting firmware background processing ida/c0d0:p1 p3 p4 <>

FC5
At start it seems to block all PCI interupts. IRQ5 has an "*" next to it. Then the loader starts from there.

FC5 Does not show ACPI interupt link [ITR3] or anything like it. It also uses IRQ 17, not 5.
SELinux is also loading during this time.

cpqarray Device 0x10 found at bus 0 dev 1 func 0
ACPI PCI interupt 0000.00.01.0[A] -> GSI19 (level,low) -> IRQ17
cpqarray Finding drives on ida0 <4> cpqarray ida0: idaSendPciCmd Timeout, no command list address returned !
cpqarray error sending ID controller

Hope someone can decode this and maybe give me a hint.

Thanks in advance,

Mesu

Mesu
30th March 2006, 04:20 AM
WORKS

Just thought I would post this for future seekers.

PROBLEM FIXED !

Seems FC5 reads IRQ ACPI difference than FC4 and older. For Compaq using Smart Array 2 I had to do the following.

1 At the install boot prompt type in "linux noprobe noapic noapci" without the quotes. Can also be "linux rescue or linux text noprobe noapic noapc"

Once I did this I had to enter the drivers when asked to select drivers
YOU MUST SELECT DRIVERS IN THIS ORDER !

I selected :

1 Compaq smart/2 RAID Controller (cpqarray)
2 Symbios 53c896 (sym53c8xx)

The cpqarray then loads and finds drives. THEN the symbios driver loads and causes no problems. I think it is searching for SCSI tape drive devices. If it loads first it returns device not supported error and the cpqarray driver cannot locate SCSI drives.

I also learned from a HP friend that this works on all his various HP and Compaq units.

Hope this helps someone.

Mesu