PDA

View Full Version : Intel Wireless Pro 2200BG and FC5



Pages : [1] 2

tomahawker
26th March 2006, 04:01 PM
Ok, I have search till my eyes were bleeding, I have downloaded and tried installing "drivers", "firmware", or whatever there else using various of instructions out there causing me to reinstall FC5 multiple times(no doubt cause I screwed something up). I am about to chuck my laptop, but I won't cause my wife will kill me.

I am tring to get my wireless card to work.

I can go to Administration -> Network, and click on the Hardware tab and see "Intel Corporation PRO/Wireless 2000BG | Ethernet | eth1 | ok"

When I tried to make a new wireless connection, I cannot see my wireless card in the list. But when I go to new ethernet connection I can see my wireless card there.

I have tried setting up a new ethernet connection and it didn't work, so I figured I needed to setup wireless connection but I can't find my wireless card in that category. What do I need to do?

jim
26th March 2006, 04:10 PM
What have you installed? rpms ? firmware only ?
before continuing reply to the above question We are going to go step by step so dont run away

tomahawker
26th March 2006, 04:20 PM
also .tgz whatever that is

jim
26th March 2006, 04:25 PM
what is the output of


rpm -qa | grep ipw2200


rpm -qa | grep ieee

post the results

Iron_Mike
26th March 2006, 04:32 PM
FC5 comes with drivers for the Intel Pro Wireless modules, since it is listed under hardware, the only thing you need is to add the firmware to the /lib/firmware directory. Go to sourceforge and grab firmware version 2.4, DO NOT grab the 3.0 version of the firmware as they are specific to to higher version of the driver itself. Unzip the 2.4 and copy the files to the /lib/firmware and reboot the computer. Check to see if shows up under the Network wireless menu

jim
26th March 2006, 04:40 PM
FC5 comes with drivers for the Intel Pro Wireless modules, since it is listed under hardware, the only thing you need is to add the firmware to the /lib/firmware directory. Go to sourceforge and grab firmware version 2.4, DO NOT grab the 3.0 version of the firmware as they are specific to to higher version of the driver itself. Unzip the 2.4 and copy the files to the /lib/firmware and reboot the computer. Check to see if shows up under the Network wireless menu

He has tried many diferent things here so I'm going to walk him through the process.

FYI a simple reboot will NOT get the wireless working. you don't even need to reboot in most cases
the ipw2200 module neds to be unloaded and then reloaded But this thread is gettting off task here

tomahawker
26th March 2006, 04:52 PM
output was:

[root@localhost ~]# rpm -qa | grep ipw2200
[root@localhost ~]# rpm -qa | grep ieee
libieee1284-0.2.9-3.2.1
[root@localhost ~]#

jim
26th March 2006, 04:56 PM
Good

Output of


ls /lib/firmware

tomahawker
26th March 2006, 04:57 PM
[root@localhost ~]# ls /lib/firmware
[root@localhost ~]#

jim
26th March 2006, 05:01 PM
ok

Now go to here http://ipw2200.sourceforge.net/firmware.php?fid=6 Scroll to the botom of the page click the I Agree and download the file to your desktop

then NOT as root


ls ~/Desktop

jim
26th March 2006, 05:03 PM
Question Are you logged in as root ?

tomahawker
26th March 2006, 05:05 PM
Hold on, I'm logged in as root, let me switch to my user login

tomahawker
26th March 2006, 05:09 PM
I'm back,
here is the output

[tomahawker@localhost ~]$ ls Desktop
Home.desktop ipw2200-fw-2.4.tgz System.desktop trash.desktop
[tomahawker@localhost ~]$

jim
26th March 2006, 05:13 PM
Issue each command NOT as root
mkdir tmp
mv ~/Desktop/*-2.4.tgz ~/tmp
cd tmp
ls
pwd

jim
26th March 2006, 05:18 PM
post the results from the above post

herrib
26th March 2006, 05:19 PM
I don't want to interfer in the thread ...

But there's a simple way, based on the livna repository, to set up a ipw2200 connection:

0- first of all, you will open a console with root rights:

$ su -
$ password: <the root password>

1- the ipw2200 drivers are part of the kernel . To verify:

# lsmod | grep ipw2200
ipw2200 95633 0
ieee80211 28681 1 ipw2200

3-To install the firmware, which is not provided, for legal matters:
* set up the Livna repository:


# rpm -ivh http://rpm.livna.org/livna-release5.rpm
* download and install the firmware:

# yum install ipw2200-firmware
* unload and load the module:

# rmmod ipw2200
# modprobe ipw2200

4- use system-config-network (it will be launched in a graphic interface):

# system-config-network&

5- set up the wireless connection (-> new connection ....)

Nota: don't forget to read the release note. "Fedora systems use Network Manager to automatically detect, select, and configure wired and wireless network connections. Wireless network devices may require third-party software or manual configuration to activate after the installation process completes. For this reason, Fedora Core 5 provides Network Manager as an optional component.

Refer to http://fedoraproject.org/wiki/Tools/NetworkManager for more information on how to install and enable Network Manager"

jim
26th March 2006, 05:22 PM
There is no need to install any rpm for this device more corruption happens from the rpms being install

jim
26th March 2006, 05:26 PM
As anyone can see tomahawker has posted many threads about this topic myself included have give half A*s responses. So as a curtisy to tomahawker, Please refrain from posting till he is able to connect with his wireless.

herrib
26th March 2006, 05:29 PM
Don't you trust the livna repositories? The rpm way is the basic way to manage the Fedora system, not only for newbies. There is no more garanties with tarballs especially if the user is a newby isn'it?

The ipw2200 firmware rpm is used by many of us and is a straight and simple way (thanks to yum ...).

jim
26th March 2006, 05:41 PM
I don't want to interfer in the thread ...

But there's a simple way, based on the livna repository, to set up a ipw2200 connection:

0- first of all, you will open a console with root rights:

$ su -
$ password: <the root password>

1- the ipw2200 drivers are part of the kernel . To verify:

# lsmod | grep ipw2200
ipw2200 95633 0
ieee80211 28681 1 ipw2200

3-To install the firmware, which is not provided, for legal matters:
* set up the Livna repository:


# rpm -ivh http://rpm.livna.org/livna-release5.rpm
* download and install the firmware:

# yum install ipw2200-firmware
* unload and load the module:

# rmmod ipw2200
# modprobe ipw2200

4- use system-config-network (it will be launched in a graphic interface):

# system-config-network&

5- set up the wireless connection (-> new connection ....)

Nota: don't forget to read the release note. "Fedora systems use Network Manager to automatically detect, select, and configure wired and wireless network connections. Wireless network devices may require third-party software or manual configuration to activate after the installation process completes. For this reason, Fedora Core 5 provides Network Manager as an optional component.

Refer to http://fedoraproject.org/wiki/Tools/NetworkManager for more information on how to install and enable Network Manager"

you'll also note that the page http://fedoraproject.org/wiki/IPW2200 was wriiten by me.

herrib
26th March 2006, 05:44 PM
Good work! May I mention that there's another way?

jim
26th March 2006, 05:44 PM
to finish this up
su -
roots password

cp * /lib/firmware
ls /lib/firmware

rmmod ipw2200
then
modprobe ipw2200

next run neat

click the devices tab and add a new wireless device

Any questions from this point forward post back with your question
as mentioned above visit http://fedoraproject.org/wiki/Tools/NetworkManager

jim
26th March 2006, 05:48 PM
Lets wait til Tom posts back with his results

tomahawker
26th March 2006, 05:57 PM
[tomahawker@localhost ~]$ mkdir tmp
[tomahawker@localhost ~]$ mv ~/Desktop/*-2.4.tgz ~/tmp
[tomahawker@localhost ~]$ cd tmp
[tomahawker@localhost tmp]$ ls
ipw2200-fw-2.4.tgz
[tomahawker@localhost tmp]$ pwd
/home/tomahawker/tmp
[tomahawker@localhost tmp]$


sorry, the kids are being a little difficult

jim
26th March 2006, 05:59 PM
tar -zxvf ipw2200-fw-2.4.tgz
su -
roots password
cd /home/tomahawker/tmp
cp * /lib/firmware
ls /lib/firmware

rmmod ipw2200

modprobe ipw2200

post the results

tomahawker
26th March 2006, 06:12 PM
[tomahawker@localhost ~]$ cd tmp
[tomahawker@localhost tmp]$ tar -zxvf ipw2200-fw-2.4.tgz
LICENSE
ipw-2.4-boot.fw
ipw-2.4-bss.fw
ipw-2.4-bss_ucode.fw
ipw-2.4-ibss.fw
ipw-2.4-ibss_ucode.fw
ipw-2.4-sniffer.fw
ipw-2.4-sniffer_ucode.fw
[tomahawker@localhost tmp]$ su -
Password:
[root@localhost ~]# cd home/tomahawker/tmp
-bash: cd: home/tomahawker/tmp: No such file or directory
[root@localhost ~]# cd /home/tomahawker/tmp
[root@localhost tmp]# cp* /lib/firmware
-bash: cp*: command not found
[root@localhost tmp]# rmmod ipw2200
[root@localhost tmp]# modprobe ipw2200
[root@localhost tmp]#

jim
26th March 2006, 06:14 PM
cp * /lib/firmware

tomahawker
26th March 2006, 06:14 PM
[root@localhost tmp]# cp * /lib/firmware
[root@localhost tmp]# ls /lib/firmware
anaconda-ks.cfg ipw-2.4-boot.fw ipw-2.4-ibss_ucode.fw
install.log ipw-2.4-bss.fw ipw-2.4-sniffer.fw
install.log.syslog ipw-2.4-bss_ucode.fw ipw-2.4-sniffer_ucode.fw
ipw2200-fw-2.4.tgz ipw-2.4-ibss.fw LICENSE
[root@localhost tmp]# rmmod ipw2200
[root@localhost tmp]# modprobe ipw2200
[root@localhost tmp]#

jim
26th March 2006, 06:16 PM
ls /lib/firmware
as long as you see all the files there then continue on

Now run neat

with the devices tab select New

Select Wireless Connection
click Forward select the IPW2200 device

tomahawker
26th March 2006, 06:26 PM
SUCCESS!!!!!!!!!!!!!!!!!

Now I'm having trouble getting on my home network.

I'll save that till I get home, have to go to work now

Thanks for all the help fedorajim, very much appricated

jim
26th March 2006, 06:28 PM
No problem

When you get home try running NetworkManager

See http://fedoraproject.org/wiki/Tools/NetworkManager

tomahawker
27th March 2006, 04:19 AM
Is networkmanager available for the KDE desktop?

Mavtech
27th March 2006, 06:31 AM
Very nice! I too am kinda new to this. I got my 2200 to be recognized following these directions. You're the man Jim! Now, how to set up WPA?

jim
27th March 2006, 11:37 AM
Networkmanager will not work under KDE KDE lacks the libraries to run it
See http://fedoraproject.org/wiki/Tools/NetworkManager

alternative would be
A. switch to Gnome :)
B. try to use kwifi

powereds
28th March 2006, 02:51 AM
hi fedorajim.

thank you very much for your posts/help here. it greatly helped me.
im now able to connect back to the ap [open and not ours]. :D

now, the problem is how to connect to our ap [wpa-personal psk security].

your technical expertise is greatly needed by the linux/fedora community.
we hope you can help us.

regards,

powereds
28th March 2006, 03:23 AM
hi all.

im now able to connect to our with wpa personal psk secured ap using network manager. :D

thanks to fedorajim and all.

regards,

Z4ns4tsu
28th March 2006, 06:12 AM
Ok, I followed the instructions just like you put them in Jim, but I'm having a completely different problem. Here's the copy from terminal.



[Jon@localhost ~]$ ls /lib/firmware
ipw-2.4-boot.fw ipw-2.4-ibss.fw ipw-2.4-sniffer_ucode.fw
ipw-2.4-bss.fw ipw-2.4-ibss_ucode.fw LICENSE
ipw-2.4-bss_ucode.fw ipw-2.4-sniffer.fw
[Jon@localhost ~]$ su
Password:
[root@localhost Jon]# rmmod ipw2200
bash: rmmod: command not found


Any help would be greatly appreciated. I'm running FC5 on an IBM T42 with a built-in Intel 2200 BG.

powereds
28th March 2006, 06:33 AM
run it from /sbin dir,

/sbin/rmmod ipw2200

jim
28th March 2006, 11:28 AM
They are starting to work on KNetworkManager V .1 should be released soon once they find a home to house to source code.

Not sure if this is the offical location

http://websvn.kde.org/trunk/kdenonbeta/knetworkmanager/

Z4ns4tsu
28th March 2006, 08:32 PM
run it from /sbin dir,

/sbin/rmmod ipw2200


Thanks. I am a super newbie, so I'm pretty unfamiliar with all the shortcuts as of yet.

jim
28th March 2006, 10:32 PM
No shortcut

you can run root 2 ways

su -
su

the difference is where you are placed in roots path

n0!z3
29th March 2006, 12:03 AM
Hello, i'm a portuguese, end i dont write very well englis! sorry...

A do the code in the consola, and add a new divece, but the new device dont work... give a error, ERROR for Wireless Request "Set Bit Rate" (8b20) :
SET faild on divece eth1 ; invalid argument

Anyone help me...

.....

jim
29th March 2006, 12:12 AM
Do you use Gnome? if so see NetworkManager
http://fedoraproject.org/wiki/Tools/NetworkManager

Z4ns4tsu
29th March 2006, 03:20 AM
Alright, I logged in correctly to root, but now I've got another error. Here we go.



[root@localhost firmware]# ls
ipw2200-fw-2.4.tgz ipw-2.4-bss_ucode.fw ipw-2.4-sniffer.fw
ipw-2.4-boot.fw ipw-2.4-ibss.fw ipw-2.4-sniffer_ucode.fw
ipw-2.4-bss.fw ipw-2.4-ibss_ucode.fw LICENSE
[root@localhost firmware]# rmmod ipw2200
ERROR: Module ipw2200 does not exist in /proc/modules

jim
29th March 2006, 03:30 AM
post the output of

cat /proc/modules

Z4ns4tsu
29th March 2006, 03:36 AM
Here you go. Thanks.



[root@localhost firmware]# cat /proc/modules
radeon 96097 0 - Live 0xf8bf1000
drm 63701 1 radeon, Live 0xf8bc7000
ppdev 8645 0 - Live 0xf8a59000
autofs4 19013 1 - Live 0xf8b7a000
hidp 15937 2 - Live 0xf8b75000
rfcomm 34517 0 - Live 0xf8b81000
l2cap 23617 10 hidp,rfcomm, Live 0xf8a5e000
bluetooth 44069 3 hidp,rfcomm,l2cap, Live 0xf8b69000
sunrpc 136573 1 - Live 0xf8b8f000
ip_conntrack_netbios_ns 3009 0 - Live 0xf897c000
ipt_REJECT 5441 1 - Live 0xf8a52000
xt_state 2241 6 - Live 0xf8a23000
ip_conntrack 49261 2 ip_conntrack_netbios_ns,xt_state, Live 0xf8b5b000
nfnetlink 6489 1 ip_conntrack, Live 0xf8a3e000
xt_tcpudp 3265 8 - Live 0xf8991000
iptable_filter 3137 1 - Live 0xf895c000
ip_tables 11657 1 iptable_filter, Live 0xf8a26000
x_tables 12613 4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables, Live 0xf8a39000
dm_mirror 19985 0 - Live 0xf8a33000
dm_multipath 18121 0 - Live 0xf89fa000
dm_mod 50521 2 dm_mirror,dm_multipath, Live 0xf8a44000
video 14917 0 - Live 0xf8987000
ibm_acpi 25025 0 - Live 0xf8a2b000
button 6609 0 - Live 0xf8902000
battery 9285 0 - Live 0xf89f6000
ac 4933 0 - Live 0xf8974000
ipv6 225569 14 - Live 0xf8a65000
lp 12297 0 - Live 0xf898c000
parport_pc 25445 1 - Live 0xf89d8000
parport 34313 3 ppdev,lp,parport_pc, Live 0xf89ce000
floppy 57733 0 - Live 0xf89e0000
nvram 8393 1 - Live 0xf8978000
ehci_hcd 29005 0 - Live 0xf897e000
uhci_hcd 28881 0 - Live 0xf894b000
ieee80211 27464 0 - Live 0xf8954000
ieee80211_crypt 5120 1 ieee80211, Live 0xf8905000
e1000 98733 0 - Live 0xf89b4000
snd_intel8x0m 16077 0 - Live 0xf8871000
snd_intel8x0 30301 1 - Live 0xf8942000
snd_ac97_codec 83937 2 snd_intel8x0m,snd_intel8x0, Live 0xf895e000
snd_ac97_bus 2497 1 snd_ac97_codec, Live 0xf88e5000
snd_seq_dummy 3781 0 - Live 0xf88e3000
snd_seq_oss 28993 0 - Live 0xf8908000
snd_seq_midi_event 7105 1 snd_seq_oss, Live 0xf883f000
snd_seq 47153 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event, Live 0xf8935000
snd_seq_device 8909 3 snd_seq_dummy,snd_seq_oss,snd_seq, Live 0xf88df000
snd_pcm_oss 45009 0 - Live 0xf8929000
snd_mixer_oss 16449 1 snd_pcm_oss, Live 0xf887a000
snd_pcm 76869 4 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm_ oss, Live 0xf8915000
snd_timer 22597 2 snd_seq,snd_pcm, Live 0xf88e8000
snd 50501 12 snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_seq_ oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_o ss,snd_pcm,snd_timer, Live 0xf88ef000
soundcore 9377 1 snd, Live 0xf8876000
snd_page_alloc 10441 3 snd_intel8x0m,snd_intel8x0,snd_pcm, Live 0xf8830000
i2c_i801 8397 0 - Live 0xf8834000
i2c_core 20673 1 i2c_i801, Live 0xf8838000
ext3 116169 2 - Live 0xf88c1000
jbd 52693 1 ext3, Live 0xf8842000
[root@localhost firmware]#

jim
29th March 2006, 03:45 AM
Well Appears that you do not have the driver installed. are you using a custom kernel or something?

try the modprobe ipw2200 see if it gets loaded ( probably not but worth a shot )


Go here
http://prdownloads.sourceforge.net/ipw2200/ipw2200-1.0.8.tgz?download
Download from the nearest mirror and save it

then follow here to install
http://ipw2200.sourceforge.net/INSTALL


or if all else fails re-install. or wait till a new kernel is available

Z4ns4tsu
29th March 2006, 03:57 AM
Yeah, I followed those instructions the first time I tried this and one of the things that it told me to do was to delete all the files that started with ipw in "/lib/modules/2.6.15-1.2054_FC5/kernel/drivers/net/wireless" which apparently got rid of that "ipw2200.ko" that modprobe wanted to interact with. Where can I get these kernel files? Could I re-insert the disk and get them off of there?

jim
29th March 2006, 04:02 AM
you can try to grab the kernel off the CD/DVD and then try to install with

rpm -Uvh kernel<Insert version here >.rpm

Z4ns4tsu
29th March 2006, 05:07 AM
Wow, I may just decide to re-install...I've only been up and running with FC5 for about 2 days. Here's the error info from that last command.



[root@localhost tmp]# rpm -Uvh kernel-2.6.15-1.2054_FC5.i686.rpm
Preparing... ########################################### [100%]
package kernel-2.6.15-1.2054_FC5 is already installed

crusher88
29th March 2006, 06:59 PM
I don't want to interfer in the thread ...

But there's a simple way, based on the livna repository, to set up a ipw2200 connection:

0- first of all, you will open a console with root rights:

$ su -
$ password: <the root password>

1- the ipw2200 drivers are part of the kernel . To verify:

# lsmod | grep ipw2200
ipw2200 95633 0
ieee80211 28681 1 ipw2200

3-To install the firmware, which is not provided, for legal matters:
* set up the Livna repository:


# rpm -ivh http://rpm.livna.org/livna-release5.rpm
* download and install the firmware:

# yum install ipw2200-firmware
* unload and load the module:

# rmmod ipw2200
# modprobe ipw2200

4- use system-config-network (it will be launched in a graphic interface):

# system-config-network&

5- set up the wireless connection (-> new connection ....)

Nota: don't forget to read the release note. "Fedora systems use Network Manager to automatically detect, select, and configure wired and wireless network connections. Wireless network devices may require third-party software or manual configuration to activate after the installation process completes. For this reason, Fedora Core 5 provides Network Manager as an optional component.

Refer to http://fedoraproject.org/wiki/Tools/NetworkManager for more information on how to install and enable Network Manager"


This was by far the easiest solution to me! Thanks :)

jim
30th March 2006, 01:52 AM
This was by far the easiest solution to me! Thanks :)
Installing a package that could eventually break your system. I hope that everyone has read
Livina & rpmforge being not compatable

Z4ns4tsu
31st March 2006, 05:08 AM
Yeah, the rpms from AtRPM are probably the reason that I'm going to have to re-install this weekend. I think I'll stick with what works instead of pushing my luck.

arostad
31st March 2006, 09:26 AM
OK

I have a laptop with a FC5 on it with a 2200BG card, it shows up in networking as an ethernet device (eth1) even know it says pro wireless next to it. SO I did exactly as you said and nothing happened.. It still says it's a ethernet device hmm I must of screwed up somewhere. Here is my output.

[arostad@localhost ~]$ rpm -qa | grep ipw2200
[arostad@localhost ~]$ rpm -qa | grep ieee
libieee1284-0.2.9-3.2.1
[arostad@localhost ~]$ ls /lib/firmware
[arostad@localhost ~]$ mkdir tmp
[arostad@localhost ~]$ mv ~/Desktop/*-2.4.tgz ~/tmp
[arostad@localhost ~]$ cd tmp
[arostad@localhost tmp]$ ls
ipw2200-fw-2.4.tgz
[arostad@localhost tmp]$ pwd
/home/arostad/tmp
[arostad@localhost tmp]$ tar -zxvf ipw2200-fw-2.4.tgz
LICENSE
ipw-2.4-boot.fw
ipw-2.4-bss.fw
ipw-2.4-bss_ucode.fw
ipw-2.4-ibss.fw
ipw-2.4-ibss_ucode.fw
ipw-2.4-sniffer.fw
ipw-2.4-sniffer_ucode.fw
[arostad@localhost tmp]$ su -
Password:
[root@localhost ~]# cd /home/arostad/tmp
[root@localhost tmp]# cp * /lib/firmware
[root@localhost tmp]# ls /lib/firmware
ipw2200-fw-2.4.tgz ipw-2.4-bss_ucode.fw ipw-2.4-sniffer.fw
ipw-2.4-boot.fw ipw-2.4-ibss.fw ipw-2.4-sniffer_ucode.fw
ipw-2.4-bss.fw ipw-2.4-ibss_ucode.fw LICENSE
[root@localhost tmp]# rmmod ipw2200
[root@localhost tmp]# modprobe ipw2200



yes yes i'm a newb.. gotta start somewhere i guess..
Please help!!

powereds
31st March 2006, 10:18 AM
did u already start the NetworkManager?also NetworkManagerDispatcher?
System>Admin>Server Settings>Services -->NetworkManager

jim
31st March 2006, 11:48 AM
OK

I have a laptop with a FC5 on it with a 2200BG card, it shows up in networking as an ethernet device (eth1) even know it says pro wireless next to it. SO I did exactly as you said and nothing happened.. It still says it's a ethernet device hmm I must of screwed up somewhere. Here is my output.

[arostad@localhost ~]$ rpm -qa | grep ipw2200
[arostad@localhost ~]$ rpm -qa | grep ieee
libieee1284-0.2.9-3.2.1
[arostad@localhost ~]$ ls /lib/firmware
[arostad@localhost ~]$ mkdir tmp
[arostad@localhost ~]$ mv ~/Desktop/*-2.4.tgz ~/tmp
[arostad@localhost ~]$ cd tmp
[arostad@localhost tmp]$ ls
ipw2200-fw-2.4.tgz
[arostad@localhost tmp]$ pwd
/home/arostad/tmp
[arostad@localhost tmp]$ tar -zxvf ipw2200-fw-2.4.tgz
LICENSE
ipw-2.4-boot.fw
ipw-2.4-bss.fw
ipw-2.4-bss_ucode.fw
ipw-2.4-ibss.fw
ipw-2.4-ibss_ucode.fw
ipw-2.4-sniffer.fw
ipw-2.4-sniffer_ucode.fw
[arostad@localhost tmp]$ su -
Password:
[root@localhost ~]# cd /home/arostad/tmp
[root@localhost tmp]# cp * /lib/firmware
[root@localhost tmp]# ls /lib/firmware
ipw2200-fw-2.4.tgz ipw-2.4-bss_ucode.fw ipw-2.4-sniffer.fw
ipw-2.4-boot.fw ipw-2.4-ibss.fw ipw-2.4-sniffer_ucode.fw
ipw-2.4-bss.fw ipw-2.4-ibss_ucode.fw LICENSE
[root@localhost tmp]# rmmod ipw2200
[root@localhost tmp]# modprobe ipw2200



yes yes i'm a newb.. gotta start somewhere i guess..
Please help!!

you done good!
as previously stated Start NetworkManager and Viola you'll be connected barring some weird encryption...

arostad
31st March 2006, 06:26 PM
I did start the network manager and nothing changed in there.. I went to add and chose wireless and there was no wireless device to choose on the next screen. It was the same way when I started.

jim
31st March 2006, 11:55 PM
Please record your desktop with what your trying to do
su -c "yum install byzanz"

Please see here to add Desktop Recorder
http://www.fedorajim.homelinux.com/movies/fc5/add_desktop_recorder

Please upload your recording to some server and post the link
Please Save the recorded video to /tmp NOT your home folder if you save it to your home folder, nautilus will crash

arostad
1st April 2006, 01:10 AM
Well I turned the computer back on and WAM it was in there as a wireless device after a reboot. I'm still having trouble connecting to my wireless network. I use WAP2 with a mixed pre share key (TKIP+AES). Does fedora support that or do I need to change it to plain old kinda secure WEP?

jim
1st April 2006, 01:26 AM
It does but it is a PITA to configure

Sticking with a WEP passphrase for home should be no problem

Iron_Mike
1st April 2006, 02:14 AM
It's not too much of a PITA, You will have to go to /etc/wpa_supplicant and then edit the wpa_supplicant.conf. After that hop over to /etc/sysconfig and edit the wpa_supplicant file. Look in the Networking forum there is a sorta "howto" by me. It involves using NetworkManager, WPA Supplicant and the IPW series of cards but it does work and once configured, is sweet.....

dtraser
1st April 2006, 02:22 AM
I just want to say thanks to both Jim and Iron_Mike, I finally got my wireless working. I used the simple steps provided by Jim and only had to edit /etc/sysconfig/wpa_supplicant. Restarted the wpa_supplicant service and NetworkManager service and viola! (Of course there were probably other steps in there that i forgot but the basics are there) :)

Thanks again guys. I fought this for 2 days. Feel sort of stupid now that I know how easy it actually was.

One note i learned, if you are connected to a wired network, i had to unplug the CAT 5 and then connect wireless by selecting it from NetworkManager.

jim
1st April 2006, 02:24 AM
I got lucky I was connected once :eek:

But i'll try again later there is a new version of NetworkManager in testing now 0.6.02
I'll try after that gets pushed to core

Iron_Mike
1st April 2006, 02:42 AM
I've been pretty lucky so far been running wpa personal with aes for the last 7 days, a couple hiccups, the major one is sometimes NetworkManager shows your wireless device as ETH0 when it should be ETH1, it still work fines whatever NM assigns it, but just an glitch, and sometime the logout screen locksup at eth1 or eth0 when it shutsdown if you let it ride when it is mis-assigned

arostad
1st April 2006, 04:14 AM
Yes thank you guys very much. It's hard to find somebody that will help newbs now a days without crucifying them for asking a simple question.

arostad
1st April 2006, 10:00 AM
ok this may be a little off topic but after I got my wireless card working I installed NetworkManager acording to the instructions on this page..

http://www.fedorajim.homelinux.com/pages/pages/NetworkManagerInfo.html

Everything went great and I had no errors BUT when I try to turn on the little icon at the top with the NetworkManagerInfo command I get the error below. Anybody got a clue why it did this?

[arostad@localhost ~]$ NetworkManagerInfo
bash: NetworkManagerInfo: command not found
[arostad@localhost ~]$


Here is a run through the install steps just for kicks

[arostad@localhost ~]$ rpm -qa | grep NetworkManager
NetworkManager-glib-0.6.0-3
NetworkManager-0.6.0-3
NetworkManager-gnome-0.6.0-3
[arostad@localhost ~]$ su -
Password:
[root@localhost ~]# chkconfig NetworkManager on
[root@localhost ~]# service NetworkManager start
Setting network parameters...
Starting NetworkManager daemon: [ OK ]
[root@localhost ~]# service network restart
Shutting down interface eth1: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0:
Determining IP information for eth0... failed; no link present. Check cable? [FAILED]
Bringing up interface eth1:
Determining IP information for eth1... done. [ OK ]
[root@localhost ~]#

powereds
1st April 2006, 11:37 AM
try to run from the terminal with root permission the command 'neat'
on the devices tab, select the wireless device
press edit button
select hardware device tab
press 'probe' button
ok
file ->save ->ok -> close the ui
issue the command 'service network restart' on the terminal.

you can monitor the network connection by adding by icon on the panel.

the steps above solve my problem after rebooting my system.
i noticed that the after rebooting my system the mac address are swap.
i dont know why it happened always.

arostad
1st April 2006, 08:57 PM
Well I noticed the monitor would show up on boot up for root all the time... so I just deleted my user account and recreated it and now it boots up on startup for that account too. I wish they would just included this wireless manager in FC5 by default.. Thanks for the help.. My problem is solved!

tom_h4000
4th April 2006, 07:12 PM
i was trying to get my wireless working under fc5 when i noticed this thread. i followed the instructions given and the wireless card showed up under wireless connections. i set it up but upon activation it could not obtain an ip address. thus internet connections don't work. however when i run kwifi it finds the wireless and connects, but still the internet doesn't work.
Any help would be greatly appreciated.

landoncz
4th April 2006, 09:04 PM
i was trying to get my wireless working under fc5 when i noticed this thread. i followed the instructions given and the wireless card showed up under wireless connections. i set it up but upon activation it could not obtain an ip address. thus internet connections don't work. however when i run kwifi it finds the wireless and connects, but still the internet doesn't work.
Any help would be greatly appreciated.

I'm not an expert, but you can try these commands as root:


# ifdown eth1
# ifup eth1


Where eth1 is your wireless device (usually eth0 or eth1). It seems like for some reason I need to do this after I have connected to the wireless network to sucessfully get an IP address. It is sort of like the Windoze equivalent of "repair network connection"....

tom_h4000
4th April 2006, 09:30 PM
I'm not an expert, but you can try these commands as root:


# ifdown eth1
# ifup eth1


Where eth1 is your wireless device (usually eth0 or eth1). It seems like for some reason I need to do this after I have connected to the wireless network to sucessfully get an IP address. It is sort of like the Windoze equivalent of "repair network connection"....

Thanks i tried but says bash: ifdown: command not found.
The same for ifup

tom_h4000
4th April 2006, 09:39 PM
i tried /sbin/ifup eth1 and it says determining ip information but then fails. i dont know the problem as it should be assigned by dchp. i am using a wireless router with wep encryption. this works in windows so i assume its not a router problem.
any further help would be greatly appreciated

rspock
4th April 2006, 10:00 PM
You will have to go to /etc/wpa_supplicant and then edit the wpa_supplicant.conf. After that hop over to /etc/sysconfig and edit the wpa_supplicant file.
What i need to change in this file?

However i disable the protection of my router but the net does not work!

I install everything and the network card work all right but i can't connect to my router. Infact with KwiFiManager I recive this error: " wrong wep key" also with security option disable on the router

Iron_Mike
4th April 2006, 11:34 PM
Are you using just WEP or WPA / WPA2

powereds
5th April 2006, 01:10 AM
i noticed that the after rebooting my system the mac address are swap.
my previous /etc/modprobe.conf:

alias eth0 e100
alias eth1 e100
....
so i replaced the first alias eth0 to:

alias eth0 ipw2200
alias eth1 e100

however when i run kwifi it finds the wireless and connects, but still the internet doesn't work.
try:

dhclient eth0 or
dhclient eth1

rspock
5th April 2006, 10:33 AM
Are you using just WEP or WPA / WPA2

I try with wep, wpa2 and without protection but i have always the same error!

I have set up manually the router's mac address but on the kWiFimanager I see "Access Point: unknow"

rspock
6th April 2006, 02:36 PM
Nobody can help me ;(

rspock
6th April 2006, 07:04 PM
please,please.

powereds
7th April 2006, 12:16 PM
I install everything and the network card work all right but i can't connect to my router. Infact with KwiFiManager I recive this error: " wrong wep key" also with security option disable on the router
try to use the NetworkManager.
i used before the kwifimanager but i cant connect also so i switched to NetworkManager.
we got the same errors too before switching.
i even restored my wpa_supplicant.conf to default settings and still can detect wep secured wlan but didnt login coz im not authorized.

note: pls post after you tried.

regards,

rspock
8th April 2006, 08:21 AM
Ok now it si ok, I have install a new kernel *.2080 and evetything is ok.

Only a little problem; in menu, administrator, network, i set up the wireless connection for start at boot but don't work, i need to start it at every start up. During the boot i can see the start procedure.

rspock
15th April 2006, 12:38 PM
New problem now!
when i start wpa i see this error:

wpa_driver_hostap_set_wpa: enabled=1
wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.

and the scan off ap will start but the network connection is down!

if i type iwconfig eth1 I see this:

eth1 unassociated ESSID:"xxx" Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.412 GHz Access Point: 00:14:C1:0D:A6:3C
Bit Rate=0 kb/s Tx-Power=20 dBm
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:xxxxxx Security mode:open
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Another question: in the amministrator->network->eth1->wireless setting, key field what sould i write?

desktek234
4th May 2006, 04:38 AM
this thread needs to be a sticky here, in laptops, and in networking.

if anyone else out there is searching, these instructions also work for iwp2100b. just get the 2100b firmware from sourceforge, and put 2100 in place of 2200 in jims instructions and youre good to go.

thanks alot Jim

Z4ns4tsu
12th May 2006, 08:56 PM
I finally got arround to re-installing and then followed Jim's instructions. Wireless works fine for me now.

BlastXng
17th May 2006, 02:38 AM
It does but it is a PITA to configure

Sticking with a WEP passphrase for home should be no problem

I wouldn't recommend this. Where I live there are so many wireless networks around, that you can (if you'd like hop on just about anyone that you can, or so I have heard :D ) if you are inclinded hop onto almost any of them without any security at all. What a joy...!!!

Doesn't FC5 support WPA with at least PSK? :eek:

I haven't tried yet for I am using WEP with MAC ACL's on one SSID with WPA-PSK on another; however I couldn't get WPA to work correctly on FC5. so gave up on that. :(

Kudos to Jim for all his work here. Good Stuff! :p

fatima
24th May 2006, 05:28 PM
cp * /lib/firmware
When I unziped .tdz in tmp directory I could see 8 files as indicated here .
But after
su
password
and
cp * /lib/firmware
and
[root@localhost tmp]# ls /lib/firmware/
ipw2200-fw-2.4.tgz ipw-2.4-bss_ucode.fw ipw-2.4-sniffer.fw
ipw-2.4-boot.fw ipw-2.4-ibss.fw ipw-2.4-sniffer_ucode.fw
ipw-2.4-bss.fw ipw-2.4-ibss_ucode.fw LICENSE

but here should be 12 files.
how will I get the rest of three files.
I will really appriciate your help
thanks

fatima
24th May 2006, 05:45 PM
[root@localhost tmp]# cp * /lib/firmware
[root@localhost tmp]# ls /lib/firmware
anaconda-ks.cfg ipw-2.4-boot.fw ipw-2.4-ibss_ucode.fw
install.log ipw-2.4-bss.fw ipw-2.4-sniffer.fw
install.log.syslog ipw-2.4-bss_ucode.fw ipw-2.4-sniffer_ucode.fw
ipw2200-fw-2.4.tgz ipw-2.4-ibss.fw LICENSE
[root@localhost tmp]# rmmod ipw2200
[root@localhost tmp]# modprobe ipw2200
[root@localhost tmp]#

I trying to set up wireless using your instructions step by step but I am stuck here.
I didn't get all files here. I can see just 9 files. and not

anaconda-ks.cfg
install.log
install.log.sylog

how will I get the remaining files

foolish
27th May 2006, 12:13 PM
Let me just step in here to make some points on the tarball vs. rpm debacle. Rpms are the better solution in most cases. Rpms will use the rpm database and it will keep track of all files on your system. However, rpms are all related to each other, so one rpm requires another. ATRpms is not an add-on repository of Fedora Core. ATRpms, and by extension RPMForge, replaces Core files. As soon as you replace files in Core you're no longer running Fedora Core, you're running something else which is based on Fedora. Doing this may solve some problem you're having with Fedora Core, but it may also mean you add completely new ones, and problems that can't really be solved by people who know about Fedora.

Does this mean you shouldn't use rpms from community repositories? Absolutely not. Add-on packages are mostly safe. Add-on packages from respected, well-established community efforts are indeed safe and a better solution that tarballs. rpm.livna.org is a driven by community members, many of whom are also involved in the Fedora project itself. rpm.livna.org uses the same setup as Fedora Extras to verify the quality of the packages, and livna.org even makes use of the very same build system. As you might have guessed, I'm telling you to use livna.org for your add-on packages. Livna.org is however only compatible with Fedora Core and Extras. This means you should never mix in other repositories, and I don't see why you would. All packages essentially fit into either Fedora Core & Extras or livna.org.

So, to install the firmware for ipw2200, enable livna.org, install the ipw2200-firmware package and restart your network devices, commonly done by rebooting. Using the tarballs will work, but there's no point in not using the rpms.

This discussion will end here. If anyone wish to discuss the points argued here further, please refer to this thread: http://forums.fedoraforum.org/showthread.php?p=537680

JoneYee
25th June 2006, 03:46 AM
I have been trying to emulate the steps outline here (absolute n00b here to Linux and Fedora), need help getting my Intel 2200BG connected to my wireless adhoc access point.

In Network configuration, I can select the deivce when creating the connection, however when the proper credentials are entered for the connection, including WEP key, it fails to cennect.

Any help appreciated, tell me what you need to know and how to find it please.

JoneYee
25th June 2006, 04:22 AM
I have tried to connect both with network manager and thru neat and I get "check cable" everytime no matter if I have WEP on or not.

This is why people get frustratd on day 1, I have internet connectivity, but I need the wireless card to work. It is recognized in neat and can be configured, however everytime i activate it, it cannot derive ip information.

The same with Network Manager.

Please Help

atery
26th June 2006, 12:32 PM
I have tried to connect both with network manager and thru neat and I get "check cable" everytime no matter if I have WEP on or not.

This is why people get frustratd on day 1, I have internet connectivity, but I need the wireless card to work. It is recognized in neat and can be configured, however everytime i activate it, it cannot derive ip information.

The same with Network Manager.

Please Help
I've got the similar problem. I am running a 2.6.15-1.2054-FC5 (downloaded from the officela website, 5CD). I copied the firmware to the right directory, and reboot works fine, the system can recognise my 2200 as a wireless card. Then i creat a new wireless connection, turn up the NetworkManager. The NM can CORRECTLY detect my wireless network, by showing its name and the strength of the signal. However, when I click that network, and typed in my WEP key, after a few minute detecting IP, the asking key window turned up again. If i try ifup eth1, wouldn't work again.

I also tried to iwconfig eth1 enc and essid, wouldn't work either. My key is definitely right, any suggestions?

pandiatonicism
3rd July 2006, 11:06 AM
I'm sorry to send you a message directly like this and please feel free to read at your convinience, I just really need your help. I've had the same problem with my ipw2200 wireless card that alot of peaple have been having and have been reading your post and the guide on your site. I even re-installed fedora core 5 and started your directions from scratch. I followed you instructions completely and it seemed to work at first. That is the eth1 (hardware) was now acually registered as a wireless card and not a ethernet card. I added a new device specifying the ipw wireless card but was not able to get the "radar" added to my toolbar nor could I acually connect to anything with the wireless card. I would get the "check cabe?" notification, both on startup and when I tried to activate the device. The strangest thing has now happened, strange because it has occured with no help from me. I took a break from the problem and booted up tonight and the hardware "eth1" ipw2200 has now reverted back to an ethernet card and is no longer a wireless card. The new device I created based on the ipw wireless hardware is still shown as a wireless device but I don't get the "check cable?" notification I get the "eth1 does not seem to be present" notification. I can't help but think that this has somthing to do with the little pup software updater. I ran all the updates yesterday, so maybe the firmware isn't regesterd the same? Anyway, I never did get it to work and now I seem to be farther from that goal. In one of the other post you asked for some output, I figure it should give you heads up here as well.

-CURRENT-

[root@ip68-227-41-91 ~]# rpm -qa | grep ipw2200

[root@ip68-227-41-91 ~]# rpm -qa | grep ieee
libieee1284-0.2.9-3.2.1

[root@ip68-227-41-91 ~]# ls /lib/firmware
ipw-2.4-boot.fw ipw-2.4-ibss.fw ipw-2.4-sniffer_ucode.fw
ipw-2.4-bss.fw ipw-2.4-ibss_ucode.fw LICENSE
ipw-2.4-bss_ucode.fw ipw-2.4-sniffer.fw

[root@ip68-227-41-91 ~]# lsmod | grep ipw2200
ipw2200 103581 0
ieee80211 31625 1 ipw2200

[root@ip68-227-41-91 ~]# rmmod ipw2200

[root@ip68-227-41-91 ~]# modprobe ipw2200

(no change)
Thank you

Iron_Mike
3rd July 2006, 12:56 PM
If you are running the latest kernel 2139, you need version 3.0 of the firmware not 2.4

sentry
3rd July 2006, 02:05 PM
Hello,

If you have the Livna repo enabled and are running FC5 you can install the drivers via yum for the 2200 and the 2915.

yum install ipw2200-firmware
A yum search ipw2200 returns:

ipw2200-firmware.noarch 3.0-1.lvn5 livna
Matched from:
ipw2200-firmware
Firmware for the ipw2200-driver
This package contains the firmware needed by the ipw2200 driver. The
ipw2200 driver supports the ipw2200-802.11bg and ipw2915-802.11abg
WLAN-Cards from Intel found in many Centrino notebooks.

Usage of the firmware is subject to the terms contained in
/usr/share/doc/ipw2200-firmware-3.0/LICENSE. Please read
the license carefully.
http://ipw2200.sourceforge.net/


ipw2200-firmware.noarch 2.4-1.lvn5 livna
Matched from:
ipw2200-firmware
Firmware for the ipw2200-driver
This package contains the firmware needed by the ipw2200 driver. The
ipw2200 driver supports the ipw2200-802.11bg and ipw2915-802.11abg
WLAN-Cards from Intel found in many Centrino notebooks.

Usage of the firmware is subject to the terms contained in
/usr/share/doc/ipw2200-firmware-2.4/LICENSE. Please read
the license carefully.
http://ipw2200.sourceforge.net/

Borongas
3rd July 2006, 09:08 PM
This message is For FEDORAJIM,
thank you for your posting so far, they have helped me get this far. I did everything that you said and I had no error messages. But I still cant get wireless.When I try to activate my wireless device in network config it says "device eth1 does not seem to be present, delaying installation. and when i try to access yum is says cannot find a valid baseurl for repo: core. what is going on? please help me, thanks in advance.

Borongas
3rd July 2006, 09:46 PM
ok so i got everything apparently working and enabled and still I go to click on internet and It comes up with nothing, someone please help me im a total linux nub and I would appreciate any and all help. thanks

Borongas
4th July 2006, 12:49 AM
nevermind a fellow from work helped me out... thanks anyways

Borongas
4th July 2006, 12:56 AM
sorry to keep posting like a nooober but now I need the same help with centos 4.3 I have been looking but I cant find much help. PLEASE if anybody knows how to get the intel pro wireless 2915 blah yada going on cent os please help me as I will be forever gratefull. I GOT THESE CHEESEBURGERS MAN!!!!

pandiatonicism
4th July 2006, 03:27 AM
Iron Mike, thanks for the tip. I deleted the files in /lib/firmware and put the new ones in. The wirless card is now regestering as a wireless card(thank god). I am still getting the "check cable?" notification when I try to activate the device. Any idea what I'm doing wrong?

pandiatonicism
4th July 2006, 03:57 AM
i'm still gettin the "check cable?" from system-config-network but I can see my wireless network in the "NetworkManager Applet". I'm guessing that I need to enable WEP or enable WAP or WIP my computer in to shape one way or the other.

pandiatonicism
4th July 2006, 04:22 AM
it's working now.....boy I feel like an idiot after all that........It was so simple. What took me 3 days should have taken about two minutes.

jim
4th July 2006, 01:36 PM
If you are running the latest kernel 2139, you need version 3.0 of the firmware not 2.4
Is this documented somewhere ? if so i'll update my site

pandiatonicism
5th July 2006, 08:16 AM
I don't know if it is documented, but it definately was true in my experience.

marcelkraan
10th July 2006, 07:31 PM
oke tomahawker is not here anymore but i'am still with you :)

[root@laptop ~]# rpm -qa |grep ipw2200
ipw2200-1.1.0-40.rhfc5.at
ipw2200-kmdl-2.6.17-1.2145_FC5-1.1.0-40.rhfc5.at
ipw2200-firmware-2.4-7.at

[root@laptop ~]# rpm -qa |grep ieee
libieee1284-0.2.9-3.2.1
ieee80211-kmdl-2.6.17-1.2145_FC5-1.1.14-11.rhfc5.at

Is this oke or it it to mutch?
I have the same errors and the same config!

Laura
12th July 2006, 03:58 AM
Similar problem here. I've just installed FC5 on an Acer TravelMate 4150. Got the firmware installed for the 2200BG. Can set it up in network manager as an 'inactive' device, but attempting to activate always results in

Determining IP information for eth1... failed; no link present. Check cable?

Network uses WPA2 and WPA with TKIP and AES encryption. Works fine with MacOS X and Windows. It's not a hardware issue, the windows partition on this laptop connects to the network fine. Laptop can connect via standard ethernet on fedora partition. Currently ethernet is eth2 with wireless as eth1 but this seems to change a lot, not sure what happened to eth0.

Any ideas? Help would be much appreciated.

Laura.

pandiatonicism
12th July 2006, 04:02 AM
Laura the Linux babe,
check this site out.

http://www.fedorajim.homelinux.com/pages/pages/NetworkManagerInfo.html

Iron_Mike
12th July 2006, 04:12 AM
Similar problem here. I've just installed FC5 on an Acer TravelMate 4150. Got the firmware installed for the 2200BG. Can set it up in network manager as an 'inactive' device, but attempting to activate always results in

Determining IP information for eth1... failed; no link present. Check cable?

Network uses WPA2 and WPA with TKIP and AES encryption. Works fine with MacOS X and Windows. It's not a hardware issue, the windows partition on this laptop connects to the network fine. Laptop can connect via standard ethernet on fedora partition. Currently ethernet is eth2 with wireless as eth1 but this seems to change a lot, not sure what happened to eth0.

Any ideas? Help would be much appreciated.

Laura.


Or....http://forums.fedoraforum.org/showthread.php?t=101489

Laura
12th July 2006, 04:14 AM
I have NetworkManager-0.6.0-3

However, bash doesn't recognise 'NetworkManagerInfo'. Or chkconfig, or service for that matter!

Iron_Mike
12th July 2006, 04:24 AM
I have NetworkManager-0.6.0-3

However, bash doesn't recognise 'NetworkManagerInfo'. Or chkconfig, or service for that matter!

Used to be, go to system -->admin -->services and put check marks in the top 2 services, NetworkManager and NetworkManagerDispatcher save and then do the same for runlevel 3 and save. Reboot and do you have a new icon on your top panel???

Laura
12th July 2006, 04:24 AM
Okay, works in GUI but not terminal for some reason

However, while Network Manager is now happily running, it still won't connect via WPA or WPA2. Password definitely correct.

Iron_Mike
12th July 2006, 04:25 AM
Okay, works in GUI but not terminal for some reason

However, while Network Manager is now happily running, it still won't connect via WPA or WPA2. Password definitely correct.

Now read this.....http://forums.fedoraforum.org/showthread.php?t=101489

Iron_Mike
12th July 2006, 04:30 AM
Okay, works in GUI but not terminal for some reason

However, while Network Manager is now happily running, it still won't connect via WPA or WPA2. Password definitely correct.

Just a quick note, if you are running the 2133 or higher kernel you wil need the 3.0 version of the firmware....

Mike...

Iron_Mike
12th July 2006, 04:43 AM
Is this documented somewhere ? if so i'll update my site

Yep it is documented : http://www.ces.clemson.edu/linux/fc2-ipw2200.shtml

Laura
12th July 2006, 04:58 AM
Now read this.....http://forums.fedoraforum.org/showthread.php?t=101489

According to the service config, having followed that advice 'NetworkManager dead'. Had a bit of fuss even getting ethernet back.

Probably I've done something very wrong, but it's 5am so I'll try again after some sleep.

Laura.

Laura
12th July 2006, 03:55 PM
I think the 'dead' message was due to wpa_supplicant starting. Having stopped that all seems okay.

I can detect local networks but cannot connect to any, including my neighbour's unsecured one.

Iron_Mike
13th July 2006, 11:19 PM
I think the 'dead' message was due to wpa_supplicant starting. Having stopped that all seems okay.

I can detect local networks but cannot connect to any, including my neighbour's unsecured one.

Are you running Networkmanager by any chance?? If so turn off your wireless/wired options "Activate on Boot" uncheck them in Network configuration. Also turn off the "wpa_supplicant" service. Let NM turn on the functions when it needs. Create a wireless network profile in NM select the encryption, ssid, key etc. IF you are using encryption the first time you click on your ssid under NM, a window should pop up and ask for the the default keyring manager password, use the same password as your login, next it should ask for your wep/wpa/wpa2 key.

The reason to turn off "activate on boot" is so your ethernet or wireless is looking for a connection while booting. But as soon as you plug a cable in it will try to connect, if you disconnect the cable it will start wireless scanning and you will see a list of wireless APs under NM

Laura
13th July 2006, 11:34 PM
I am running Network Manager and have turned off WPA supplicant.

I detect local networks but cannot connect to any, open or encrypted.

Iron_Mike
14th July 2006, 03:37 AM
I am running Network Manager and have turned off WPA supplicant.

I detect local networks but cannot connect to any, open or encrypted.

OK, now what is your network config?? DHCP, STATIC, does your ethernet connect when you plug it in, is your router set for DHCP/STATIC, what does your /etc/resolve look like, ant errors in your /var/log/dmesg file????

Laura
14th July 2006, 09:34 PM
Got it working :D

Just needed to adjust the settings in network config.

Thankyou very much for all the help, really do appreciate it. Iron_Mike, you are an angel :)

Iron_Mike
14th July 2006, 11:52 PM
Got it working :D

Just needed to adjust the settings in network config.

Thankyou very much for all the help, really do appreciate it. Iron_Mike, you are an angel :)

Good for you glad you got it working.
Thanks.....

fpierre
1st August 2006, 03:34 PM
Hi all

I have read messages from Jim and Iron_Mike on this forum.

I have installed ipw2200(2.4) firmware

When I want to activate wireless(eth1), I get a message saying it cannot find IP adress, that no link is found,
and ask to check a cable(!)

below is result of iwconfig

eth1 radio off ESSID:"fptoto11" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate=0 kb/s Tx-Power=off
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:4341-4645-4341-4645-4341-0000-00 Security mode:open
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


F.P.

PS I have installed FC5 on a Dell latitude D410

catflop
2nd August 2006, 12:21 AM
It looks like the wireless card has been turned off from looking at the first line of iwconfig output. Try hitting the function key and F2 (at least that's the key combo on my Dell Inspiron) to enable the wireless card.

Laura
2nd August 2006, 01:32 AM
fpierre, sounds like you have the same problem I had.

Start by enabling network manager as mentioned in Iron_Mike's post and go from there- worked for me :)

fpierre
4th August 2006, 02:06 PM
Hi all

I have read messages from Jim and Iron_Mike on this forum.

I have installed ipw2200(2.4) firmware

When I want to activate wireless(eth1), I get a message saying it cannot find IP adress, that no link is found,
and ask to check a cable(!)

below is result of iwconfig

eth1 radio off ESSID:"fptoto11" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate=0 kb/s Tx-Power=off
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:4341-4645-4341-4645-4341-0000-00 Security mode:open
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


F.P.

PS I have installed FC5 on a Dell latitude D410

I got the answer from the forum:
***************
It looks like the wireless card has been turned off from looking at the
first line of iwconfig output. Try hitting the function key and F2 (at
least that's the key combo on my Dell Inspiron) to enable the wireless card.
***************
Indeed, it did something; iwconfig becomes :
eth1 IEEE 802.11g ESSID:"fptoto11" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462 GHz Access Point: 00:07:CB:51:FD:6B
Bit Rate=5.5 Mb/s Tx-Power=20 dBm
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:4341-4645-4341-4645-4341-0000-00 Security mode:open
Power Management:off
Link Quality=96/100 Signal level=-29 dBm Noise level=-87 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

and message from net configuring says only it cannot find IP address,
but no more message about link and cable
==> BIG PROGRESS -- THANK

But I am stuck in this business of IP adressing, I guess DHCP stuff.
I have configured the wireles similarly to ethernet(eth1), and ethernet
has no problem to get a DHCP address.

Suggestion welcome.

Thanks again

F.P.

catflop
4th August 2006, 08:50 PM
Try running
dhclient eth1
from console, and see what happens. It should be able to pull an IP address from your router.

fpierre
5th August 2006, 05:06 PM
Hi all,

Following answers from catflop and Laura, I did 2 things :

1) "dhclient eth1" which gave me the output :"grep dhclient /var/log/messages"


Aug 4 14:56:03 localhost NET[4279]: /sbin/dhclient-script : updated /etc/resolv.conf
Aug 4 15:02:34 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
Aug 4 15:02:38 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
Aug 4 15:02:47 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
Aug 4 15:02:56 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
Aug 4 15:03:03 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
Aug 4 15:03:11 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 17
Aug 4 15:03:28 localhost dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
Aug 4 15:03:35 localhost dhclient: No DHCPOFFERS received.
Aug 4 15:03:35 localhost dhclient: No working leases in persistent database - sleeping.
A

2) then, thinking again at network-config where I had filled
in WEP key as alphanumeric characters, I realised it
was expecting hexadecimal, and I added0x in front
...AND MY WIRELESS WORK!

Many thanks to all of you,

F.P.

fpierre
12th August 2006, 10:41 PM
I thought I had solved all problems with Intel Wireless Pro 2200BG and FC5
BUT it did not work with WPA key, only WEP.

looking at http://fedoranews.org/cms/node/478
and http://www.fedoraforum.org/forum/showthread.php?p=487181&mode=threaded
I edited /etc/wpa_supplicant/wpa_supplicant.conf :

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
ssid="fptoto11"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk="*************"
}

I rebooted, and - while activating the eth1(wireless) - I got the message syaing it
could not find IP, and suggested to check cable.

Suggestion welcome.

wsculver
20th August 2006, 06:26 AM
You are the man. I am new to this Linux stuff although 20 years networking.

The key was the Network Manager piece and I messed up cause I tried to hack around thinking that the Network Configuration was the Network Manager.

Thanks much Jim.

Iron_Mike
20th August 2006, 02:42 PM
I thought I had solved all problems with Intel Wireless Pro 2200BG and FC5
BUT it did not work with WPA key, only WEP.

looking at http://fedoranews.org/cms/node/478
and http://www.fedoraforum.org/forum/showthread.php?p=487181&mode=threaded
I edited /etc/wpa_supplicant/wpa_supplicant.conf :

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
ssid="fptoto11"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk="*************"
}

I rebooted, and - while activating the eth1(wireless) - I got the message syaing it
could not find IP, and suggested to check cable.

Suggestion welcome.


One thing to remeber is if you are using any form of encryption whether it is WEP/WPA/WPA2 and using DHCP to obtain an IP address and DNS info etc. You must be authenicated to the AP BEFORE any DNS/IP info is handed down to the adapter. By starting your network adapter using "activate on boot" from Network Configuration menu causes the adapter to look for an IP address before authenicating with the IP, this is why you get the "could not find IP, check cable error etc. With this in mind it is better to turn off "activate on boot" and use NetworkManager, in this respect NM will ask for WEP/WPA/WPA2 password and wait for authenication before activating the wireless scripts. One caveat though with NM, by default it looks for unsecure wireless APs and will try to connect to automatically to it. I wish they would change this, but it is how it works.

wsculver
20th August 2006, 07:24 PM
Jim -

Your instructions worked well getting my 2915abg set up on 2.6.15-1.2054_FC5, but can't seem to get it to work on 2.6.17-1.2174_FC5. Any thoughts on what I might be missing?

Thanks.
Bill

Iron_Mike
20th August 2006, 08:16 PM
Jim -

Your instructions worked well getting my 2915abg set up on 2.6.15-1.2054_FC5, but can't seem to get it to work on 2.6.17-1.2174_FC5. Any thoughts on what I might be missing?

Thanks.
Bill

They changed the version of the ipw2200 driver in Fedora Core, you will need to change to newer firmware 3.0

wsculver
20th August 2006, 08:56 PM
Thanks Mike. I kind of thought there might be an answer along those lines. So I will run the older driver version on the earlier build and the newer version on the newer build? Any conflicts? Both builds are on same machine. Also, is there any way to merge these two builds or get rid of the older one once I am happy with the updated config?

Iron_Mike
20th August 2006, 09:10 PM
Thanks Mike. I kind of thought there might be an answer along those lines. So I will run the older driver version on the earlier build and the newer version on the newer build? Any conflicts? Both builds are on same machine. Also, is there any way to merge these two builds or get rid of the older one once I am happy with the updated config?

Shouldn't be a problem as the firmware versions have different naming conventions

cr4ck3r
3rd September 2006, 09:26 PM
First, I followed the instruction with the firmware version 2.4 ---> It didn't work.
Then I try the firmware version 3.0. It now can recognize my wireless card. But I still cannot connect to the wireless network. Which setting should I set? Auto, Managed or Ad-hoc? I can connect to wireless network in Window (without any encryption) and I use static IP with my wireless router.
By the way, I try to activate my wireless card, but after a while (about 20 seconds) my wireless automatically became Inactive. I dont know why. Did I miss something in the instruction?
Please help.

cr4ck3r
3rd September 2006, 09:47 PM
problem solved, just do a reboot, everything goes smoothly

amaab
6th September 2006, 11:48 PM
This must be the closest I have ever been to get my 2200 card working. I think I have everything right but when I do neat and add new device I can't find my 2200 card and my network manager applet only shows my wired connection.
Is there something I have mised her?
Please ask for the information you feel you need for helping me out here.

Iron_Mike
7th September 2006, 12:36 AM
This must be the closest I have ever been to get my 2200 card working. I think I have everything right but when I do neat and add new device I can't find my 2200 card and my network manager applet only shows my wired connection.
Is there something I have mised her?
Please ask for the information you feel you need for helping me out here.


Need more info, what kernel version are you using, and whether or not you have tried to change the default drivers and ieee80211 subsystem. Also have you installed the firmware into your /lib/firmware directory and what version of firmware are you using?

amaab
7th September 2006, 01:19 AM
kernel ver: 2.6.15-1.2054_FC5
firmware intalled into /lib/firmware, ver 2.4

followed the begining of this thread, don't think I have changed the driver. thougth it was already in the kernel. Or I'm totaly wrong there. Have done nothing about ieee80211 subsystems.

Iron_Mike
7th September 2006, 02:01 AM
kernel ver: 2.6.15-1.2054_FC5
firmware intalled into /lib/firmware, ver 2.4

followed the begining of this thread, don't think I have changed the driver. thougth it was already in the kernel. Or I'm totaly wrong there. Have done nothing about ieee80211 subsystems.


Let's try the easy way first, go to the /lib/firmware directory and delete all the files in there. Reboot the computer, open a terminal window su - to root and type yum install ipw2200-firmware. Once installed reboot the computer and try NEAT and add new

amaab
7th September 2006, 02:47 AM
It worked like a charm. Thanks alot Iron Mike. Finely and end to all the hair pulling:)

Iron_Mike
7th September 2006, 02:54 AM
Your welcome......

hybrid857
7th September 2006, 10:53 AM
Hi, I tried the guide Jim put up, but it still doesn't come up as a wireless device. I had previously tried to run other commands in the Intel guide, but got nowhere really. I was wondering do I have to reinstall FC5 over again or something? I'm a bit lost.

TTA89
26th September 2006, 09:40 PM
Well I don't know why I can't get this to work... I'm on a Dell D410.

Fresh FC5 install without any yum updates, running the default Kernel 2.6.15-1.2054_FC5.

lsmod | grep ipw2200

Comes back with nothing found which is where I think I have a problem but I just did a fresh reinstall 20 min ago, is there something extra I have to add from the DVD?

if I type modprobe ipw2200

it returns with no error so the module is in there somewhere. Then when I type

lsmod | grep ipw2200 I get

ipw2200 95633 0
iee80211 28681 1 ipw2200

ok...

I downloaded the firmware via yum, I can see it in the /lib/fireware folder but its version 2.4 which I tried but didn't work.

I used yum to remove it and installed 3.0 from sourceforge and copied it to /lib/firmware.

rmmod ipw2200
modprobe ipw2200

reboot

lsmod | grep ipw2200

Nothing returned again, just another command line

neat

try and add it and It just shows "other wireless card"

exit

modprobe ipw2200
lsmod | grep ipw2200

It then shows the module and ieee again.

neat

same thing...

What am I missing?

I also used the keyboard FN F2 to toggle the wireless card on and off with reboots in the middle...

Arggg...

marcelkraan
26th September 2006, 10:29 PM
THIS IS HAVE DONE!
- yum install ipw2200
- the filmware 2.4 installed
yum install ipw2200-firmware

yum install wpa_supplicant-gui-0.4.8-10.fc5
yum install wpa_supplicant-0.4.8-10.fc5

yum install libieee1284-0.2.9-3.2.1
yum install ieee80211-1.1.14-11.rhfc5.at
yum install ieee80211-kmdl-2.6.17-1.2157_FC5-1.1.14-11.rhfc5.at

REBOOT after this!


wpa_supplicant-0.4.9

rebooten is mega belangrijk!

TTA89
26th September 2006, 10:44 PM
Nevermind....

I threw a windows drive in it and it boots up with a Broadcom 1450 card. WTF... Dell says its supposed to have an Intel 2200 in it. Sigh....

marcelkraan
26th September 2006, 11:28 PM
hahaha and we just think windows suxx :)




Nevermind....

I threw a windows drive in it and it boots up with a Broadcom 1450 card. WTF... Dell says its supposed to have an Intel 2200 in it. Sigh....

TTA89
26th September 2006, 11:49 PM
I hate how they do that crap! What a waste of time I spent trying to get the stupid intel driver to work wondering why I'm having such a hard time! Now to see how much of a pain this is going to be.....

knchee
2nd October 2006, 03:56 PM
Dear All,
I followed the suggestions in this thread and managed to get connected to my Access Point. But I can not browse the Internet with the browser. The output of the 'iwconfig' is : -

[root@chee ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"Stapok Private Net 1" Nickname:"chee.ch.com"
Mode:Managed Frequency:2.437 GHz Access Point: 00:11:95:96:7B:38
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:BADC-E96E-CB48-15F8-311B-3EDB-20 Security mode:open
Power Management:off
Link Quality=87/100 Signal level=-42 dBm Noise level=-85 dBm
Rx invalid nwid:0 Rx invalid crypt:22 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:8

sit0 no wireless extensions.

I reconfirmed the connection with the Network Manager.

I double confirmed with KWiFiManager: - My WIFI is connected to my Access Point with the correct SSID.

But when when I tried to browse, the following error appeared in my browser:

Server not found
Firefox can't find the server at www.cnn.com.
* Check the address for typing errors such as
ww.example.com instead of
www.example.com

* If you are unable to load any pages, check your computer's network
connection.

* If your computer or network is protected by a firewall or proxy, make sure
that Firefox is permitted to access the Web.

Did I missed something in my browser setting or there is something else more seriouse? Am I very close to get WIFI working? Please help.

Thanks.

Oswald

Iron_Mike
3rd October 2006, 02:10 AM
Try to ping a ip address, try 4.2.2.1 this is verizon's dns server, if you can ping the ip but not google.com or yahoo.com you have a DNS problem and need to check your DNS settings.

snoze
3rd October 2006, 02:17 AM
i think it is default in FC5

knchee
3rd October 2006, 02:55 AM
I set DNS IP to my Internet provider. The thing is that when I activated my eth0, I can browse the Internet just fine. That mean that the setting to browse the Internet is fine. It just that when I deactivated my eth0 and activated my eth1 (WIFI), I double confirm it is connected to my Access Point, I can not browse the Internet.

There is one more thing, I set my default gateway to my Access Point/Router IP, with eth1, I can not ping my Access Point/Router. With eth0, everything is fine. Please help.

Thanks.

Oswald

Iron_Mike
3rd October 2006, 03:13 AM
I set DNS IP to my Internet provider. The thing is that when I activated my eth0, I can browse the Internet just fine. That mean that the setting to browse the Internet is fine. It just that when I deactivated my eth0 and activated my eth1 (WIFI), I double confirm it is connected to my Access Point, I can not browse the Internet.

There is one more thing, I set my default gateway to my Access Point/Router IP, with eth1, I can not ping my Access Point/Router. With eth0, everything is fine. Please help.

Thanks.

Oswald

OK, I noticed that according to your iwconfig, it shows that you are using encryption, to test your settings turn it off on the router temporarily. Now the above show that you are setting your DNS, are you using DHCP or STATIC ip addressing. If you are manually assigning IP addresses (STATIC) the first dns address should be your routers interface, be it 192.168.0.1 or 192.168.1.1 whatever the case may be. The second should be either your ISPs dns or use 4.2.2.1. Once you have connectivity you can re-enable your wireless encryption..

knchee
3rd October 2006, 04:04 AM
OK, I noticed that according to your iwconfig, it shows that you are using encryption, to test your settings turn it off on the router temporarily. Now the above show that you are setting your DNS, are you using DHCP or STATIC ip addressing. If you are manually assigning IP addresses (STATIC) the first dns address should be your routers interface, be it 192.168.0.1 or 192.168.1.1 whatever the case may be. The second should be either your ISPs dns or use 4.2.2.1. Once you have connectivity you can re-enable your wireless encryption..

I am manually assigning IP address (Static). In Windows XP, I set default gateway to IP of my AccessPoint/Router IP, and the DNS (primary and secondary) IP to Internet provider DNS. My laptop has connected to AccessPoint, it just can not ping to it and can not browse the Internet. I will try your suggestion tonight. Any other thing that I need to do ?

Thanks.

Oswald

knchee
3rd October 2006, 05:08 AM
By the way, is this has anything to do with Firewall setting that preventing WIFI Internet access?

knchee
3rd October 2006, 04:10 PM
SUCCESS! What I did wrong is that I forgot to put ' 0x ' infront of my Hex key input. This cost a few week ends family time and many reinstallations. Thanks.

Oswald

edmontontech
6th October 2006, 04:59 PM
I don't want to interfer in the thread ...

But there's a simple way, based on the livna repository, to set up a ipw2200 connection:

0- first of all, you will open a console with root rights:

$ su -
$ password: <the root password>

1- the ipw2200 drivers are part of the kernel . To verify:

# lsmod | grep ipw2200
ipw2200 95633 0
ieee80211 28681 1 ipw2200

3-To install the firmware, which is not provided, for legal matters:
* set up the Livna repository:


# rpm -ivh http://rpm.livna.org/livna-release5.rpm
* download and install the firmware:

# yum install ipw2200-firmware
* unload and load the module:

# rmmod ipw2200
# modprobe ipw2200

4- use system-config-network (it will be launched in a graphic interface):

# system-config-network&

5- set up the wireless connection (-> new connection ....)

Nota: don't forget to read the release note. "Fedora systems use Network Manager to automatically detect, select, and configure wired and wireless network connections. Wireless network devices may require third-party software or manual configuration to activate after the installation process completes. For this reason, Fedora Core 5 provides Network Manager as an optional component.

Refer to http://fedoraproject.org/wiki/Tools/NetworkManager for more information on how to install and enable Network Manager"



THANK YOU!!! YOU ARE GOD SENT!!! Worked first time, no issues

roni
7th October 2006, 01:32 AM
hello all,
im a new FC5 user and so far mi learning alot from all of you.
i have followed the instruction by .....



Originally Posted by herrib
I don't want to interfer in the thread ...

But there's a simple way, based on the livna repository, to set up a ipw2200 connection:

0- first of all, you will open a console with root rights:
Code:

$ su - $ password: <the root password>



1- the ipw2200 drivers are part of the kernel . To verify:
Code:

# lsmod | grep ipw2200 ipw2200 95633 0 ieee80211 28681 1 ipw2200



3-To install the firmware, which is not provided, for legal matters:
* set up the Livna repository:
Code:

# rpm -ivh http://rpm.livna.org/livna-release5.rpm


* download and install the firmware:
Code:

# yum install ipw2200-firmware


* unload and load the module:
Code:

# rmmod ipw2200 # modprobe ipw2200



4- use system-config-network (it will be launched in a graphic interface):
Code:

# system-config-network&



5- set up the wireless connection (-> new connection ....)

Nota: don't forget to read the release note. "Fedora systems use Network Manager to automatically detect, select, and configure wired and wireless network connections. Wireless network devices may require third-party software or manual configuration to activate after the installation process completes. For this reason, Fedora Core 5 provides Network Manager as an optional component.

Refer to http://fedoraproject.org/wiki/Tools/NetworkManager for more information on how to install and enable Network Manager"

the above steps worked fine so far, but then when i reboot my computer, the wireless is still not there, i mean not working. any help or suggestion are very much appreciated

thanks

djbox
14th October 2006, 08:25 AM
i haved the same problem. But can't seem to deleted the firmware that i installed before. i made the mistake of installing the 3.0 firmware, I know i have to put the 2.4 one so how can i take that one of and put the 2.4 on

djbox
15th October 2006, 03:23 AM
This was by far the easiest solution to me! Thanks :)
I did everything here but i downloaded vertion 3.0 and also when i tried to load and unload i can't

here is wa i got

[root@localhost djbox]# cd Desktop
[root@localhost Desktop]# rpm -ivh http://rpm.livna.org/livna-release5.rpm
Retrieving http://rpm.livna.org/livna-release5.rpm
warning: /var/tmp/rpm-xfer.YAgRfs: Header V3 DSA signature: NOKEY, key ID a109b1ec
Preparing... ########################################### [100%]
1:livna-release ########################################### [100%]
[root@localhost Desktop]# yum install ipw2200-firmware
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna [1/4]
livna 100% |=========================| 951 B 00:00
updates [2/4]
updates 100% |=========================| 1.2 kB 00:00
core [3/4]
core 100% |=========================| 1.1 kB 00:00
extras [4/4]
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 140 kB 00:00
livna : ################################################## 364/364
Added 364 new packages, deleted 0 old in 3.53 seconds
primary.xml.gz 100% |=========================| 379 kB 00:01
updates : ################################################## 1041/1041
Added 1041 new packages, deleted 0 old in 6.07 seconds
primary.xml.gz 100% |=========================| 767 kB 00:00
core : ################################################## 2207/2207
Added 2207 new packages, deleted 0 old in 9.05 seconds
primary.xml.gz 100% |=========================| 1.6 MB 00:05
extras : ################################################## 5384/5384
Added 5384 new packages, deleted 0 old in 23.19 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for ipw2200-firmware to pack into transaction set.
ipw2200-firmware-3.0-1.lv 100% |=========================| 4.4 kB 00:00
---> Package ipw2200-firmware.noarch 0:3.0-1.lvn5 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
ipw2200-firmware noarch 3.0-1.lvn5 livna 535 k

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 535 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): ipw2200-firmware-3 100% |=========================| 535 kB 00:01
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID a109b1ec
Public key for ipw2200-firmware-3.0-1.lvn5.noarch.rpm is not installed
Retrieving GPG key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
Importing GPG key 0xA109B1EC "Livna.org rpms <rpm-key@livna.org>"
Is this ok [y/N]: y
Key imported successfully
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: ipw2200-firmware ######################### [1/1]

Installed: ipw2200-firmware.noarch 0:3.0-1.lvn5
Complete!
[root@localhost Desktop]# rmmod ipw2200
bash: rmmod: command not found
[root@localhost Desktop]# modprobe ipw2200
bash: modprobe: command not found
[root@localhost Desktop]#


also check what i get now


[root@localhost Desktop]# rpm -qa | grep ipw2200
ipw2200-firmware-3.0-1.lvn5
[root@localhost Desktop]# rpm -qa | grep ieee
libieee1284-0.2.9-3.2.1

snoze
15th October 2006, 03:51 AM
check this link http://forums.fedoraforum.org/showthread.php?t=126662

wprauchholz
15th October 2006, 05:42 PM
I installed the ipw2200 firmware following the procedure mentiuoned above. I run under kernel kernel-2.6.17-1.2187_FC5, so I installed ipw2200-fw-3.0.
I downloaded it to user's home director (not root) and extraced it there. after I su to root and copied the files to the "directory /lib/firmware". I installed the ipw220 crd which shows as eth1.
I am able to screen the available wifi networks, but I cannot connet to them. Following some more detailes:
- content of /lib/firmware
[root@lap02 ~]# ls -al /lib/firmware
total 596
drwxr-xr-x 2 root root 4096 Oct 15 18:15 .
drwxr-xr-x 11 root root 4096 Oct 15 17:35 ..
-rw-r--r-- 1 root root 191142 Oct 15 18:15 ipw2200-bss.fw
-rw-r--r-- 1 root root 185660 Oct 15 18:15 ipw2200-ibss.fw
-rw-r--r-- 1 root root 187836 Oct 15 18:15 ipw2200-sniffer.fw
-rw-r--r-- 1 root root 12007 Oct 15 18:15 LICENSE.ipw2200-fw

-iwconfig gives me:
[root@lap02 ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

Warning: Driver for device eth1 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

eth1 unassociated ESSID:off/any Nickname:"lap02.ipnspain.biz"
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate=0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
- lsmod | grep ipw2200
[root@lap02 ~]# lsmod | grep ipw2200
ipw2200 103709 0
ieee80211 31625 1 ipw2200


Any ide wht I am doing wrong? Thanks

djbox
16th October 2006, 06:55 PM
I don't want to interfer in the thread ...

But there's a simple way, based on the livna repository, to set up a ipw2200 connection:

0- first of all, you will open a console with root rights:

$ su -
$ password: <the root password>

1- the ipw2200 drivers are part of the kernel . To verify:

# lsmod | grep ipw2200
ipw2200 95633 0
ieee80211 28681 1 ipw2200

3-To install the firmware, which is not provided, for legal matters:
* set up the Livna repository:


# rpm -ivh http://rpm.livna.org/livna-release5.rpm
* download and install the firmware:

# yum install ipw2200-firmware
* unload and load the module:

# rmmod ipw2200
# modprobe ipw2200

4- use system-config-network (it will be launched in a graphic interface):

# system-config-network&

5- set up the wireless connection (-> new connection ....)

Nota: don't forget to read the release note. "Fedora systems use Network Manager to automatically detect, select, and configure wired and wireless network connections. Wireless network devices may require third-party software or manual configuration to activate after the installation process completes. For this reason, Fedora Core 5 provides Network Manager as an optional component.

Refer to http://fedoraproject.org/wiki/Tools/NetworkManager for more information on how to install and enable Network Manager"


Mines worked with this Option

Learner Driver
6th November 2006, 02:45 PM
G,day as you may guess from the name i am new to linux.

I am limited to using the graphical interface only at this point as i know nothing about command line.

After recently installing fedora 5 i have been able to establish a cable connection to the internet (Incidently this shows as being a wireless connection in network manager).

I am experiencing problems with my wireless connectivity, I have an Asus m6000 model m6a laptop intel centrino.

My wireless card is listed as a ipw2200B under network configuration ¨hardware devices¨.

The ipw2200 card while present in ¨network configuration¨ under hardware devices is not present as an option to select when I create a new wireless device.

Instead the options to select a 3Com 3c501 device under the adaptor tab appears by default and i have access to a drop down list for a number of other devices that i dont see under my listed hardware devices in network configuration.

I have read a number of guides, the installed configuration help files and other online material and arrived here as a newly registered user.

From what i have read so far the instructions by Jim in this post are the most applicable to my situation, however I lack sufficient knowledge (experience) to understand the instructions well enough to apply them.

Perhaps for a user better educated than myself these would provide a solution.

I could do with a patient and detailed walk through on how to perform these tasks.

I do not know how to provide more detailed information about my version of fedora 5 and I am a little uncertain if this is the correct place or way to post a request for assistance.

I have downloaded four packages that i think may be needed.

They are ieee80211-1.2.15.tgz, ipw2200-fw-2.4.tgz, and ipw2200-firmware-3.0-3.noarch.rpm and ipw2200-1.2.0-45.fc5.at.i386.rpm.

I am not sure which if any are needed I have not played with these for fear of killing my system, but I have them on hand in case anyone is currently online that can guide me through this.

Your help would be greatly appreciated.

Many thanks in advance.

Iron_Mike
6th November 2006, 04:10 PM
Just install the ipw2200-firmware-3.0-3.noarch.rpm only, reboot the computer and you should be able to see it as a wireless device under network configuration. You will probally have to select "new", "wireless" and it it shjould be in the list....

Learner Driver
6th November 2006, 04:41 PM
Just install the ipw2200-firmware-3.0-3.noarch.rpm only, reboot the computer and you should be able to see it as a wireless device under network configuration. You will probally have to select "new", "wireless" and it it shjould be in the list....
Thank you replying so quickly and for the tip a couple of quick questions though before i proceed.

1. Is this done by right clicking on the package and choosing open with install software option?

2. If so I started this process earlier today and got a message saying Unable to verify ipw2200-firmware-3.0-3.noarch potential malicious software etc etc. Is this an issue? Iwas not sure so did not proceed

Thanks again

Learner Driver
6th November 2006, 05:28 PM
Thank you replying so quickly and for the tip a couple of quick questions though before i proceed.

1. Is this done by right clicking on the package and choosing open with install software option?

2. If so I started this process earlier today and got a message saying Unable to verify ipw2200-firmware-3.0-3.noarch potential malicious software etc etc. Is this an issue? Iwas not sure so did not proceed

Thanks again
A quick update i thought to heck with it and installed the rpm anyway.

The wireless card can now be seen in network configuration and i have created the new device.

I cant get the device to activate however and i get the following error message.

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Invalid argument.

Determining IP information for eth1... failed; no link present. Check cable?

Also i got the following error message when reactivating my wired connection

Determining IP information for eth0.../etc/sysconfig/network-scripts/ifup-eth: line 260: 4416 Terminated /sbin/dhclient ${DHCLIENTARGS} ${DEVICE}
failed.

I clicked ok and it activated anyway.

I am certainly in over my head.

Further assistance appreciated

Iron_Mike
6th November 2006, 06:44 PM
A quick update i thought to heck with it and installed the rpm anyway.

The wireless card can now be seen in network configuration and i have created the new device.

I cant get the device to activate however and i get the following error message.

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Invalid argument.

Determining IP information for eth1... failed; no link present. Check cable?

Also i got the following error message when reactivating my wired connection

Determining IP information for eth0.../etc/sysconfig/network-scripts/ifup-eth: line 260: 4416 Terminated /sbin/dhclient ${DHCLIENTARGS} ${DEVICE}
failed.

I clicked ok and it activated anyway.

I am certainly in over my head.

Further assistance appreciated

The "set bit rate" error is benign, to get rid of it though. Navigate to /etc/sysconfig/network-scripts and open this file: ifcfg-eth0 or ifcfg-eth1 whichever is your wireless card, and add this like:

RATE="Auto"

Notice the capitalization you need this that will take care of the bit rate error. Double check your ETH0 and ETH1 settings, usually ETH0 is your wired and ETH1 is your wireless. The DHCP daemon is not starting is why your getting a failed ip address, it is not able to assign one.

But to make it easier, navigate to system -->administration -->services. Put check marks in the top 2 services, NetworkManager, NetworkManagerDispatcher. Once that is done, save it and reboot the computer. You should have a new icon on your top panel, you can use this to configure your wired/wireless cards...

Learner Driver
6th November 2006, 10:36 PM
Iron Mike,

thanks for the help so far I think I am seeing some progress.

I have edited the ifcfg-eth1 file as directed after confirming it was my wireless card.

I inserted `Auto´ exactly as i have shown it here (hope that is correct)

The top two items in services were checked and started the configuration was saved and i preformed the necessary reboot.

I have set up a new device in network configuration gone through the motions and have come back with the following error message

Determining IP information for eth1... failed; no link present. Check cable?

I seem to have gotten rid of the bit rate issue where to from here?

Iron_Mike
6th November 2006, 11:48 PM
Plug in the ethernet cable, does it show a connection on the NM icon????

jim
7th November 2006, 01:28 AM
More wireless fun !
Wireless set in fc6 in 2 minutes including a reboot

Cant count how many time Iron Mike & I have suggested the firmware way to go

http://fedorajim.googlepages.com/ipw2200

Learner Driver
7th November 2006, 12:10 PM
Iron mike,

I have the wired connection plugged in and can see network icon in the top right hand corner beside the clock.

Is this the NM icon that you were refering too?

If i right click on the icon enable wireless configuration & enable wired connection are shown as check box options ¨both are checked¨.

As a curiosity I have visited the page posted by Jim I simply lacked the know how to employ the solutions offered.

Anyway on on

Learner Driver
7th November 2006, 12:17 PM
Iron mike,

I have the wired connection plugged in and can see network icon in the top right hand corner beside the clock.

Is this the NM icon that you were refering too?

If i right click on the icon enable wireless configuration & enable wired connection are shown as check box options ¨both are checked¨.

As a curiosity I have visited the page posted by Jim I simply lacked the know how to employ the solutions offered.

Anyway on on

Iron_Mike
7th November 2006, 02:11 PM
Iron mike,

I have the wired connection plugged in and can see network icon in the top right hand corner beside the clock.

Is this the NM icon that you were refering too?

If i right click on the icon enable wireless configuration & enable wired connection are shown as check box options ¨both are checked¨.

As a curiosity I have visited the page posted by Jim I simply lacked the know how to employ the solutions offered.

Anyway on on

That's the one, when it is connected by ethernet it will, as a mouse, when it is connected wireless it will show as signal strength bar, like a cell phone. Both options should have checked marks in them. So we know your wired connection works, yes??? Unplug your ethernet cable and the NM icon should change to a radar sweep or something that looks like it. What happens ??? Does it go to a mouse icon with a red circle and line through it??? If it does, left click the icon, does a list Wireless AP show up, if your AP and SSID shows up in the list, click on it to see if connects....

Learner Driver
7th November 2006, 05:24 PM
Iron Mike,

I have done as suggested results were as follows.

With the wired cable removed the network connection icon reappears with a red circle and slash in its center.

Right clicking on the changed icon after the cable is removed shows the two checked boxes enable networking and enable wireless the third icon connection information appears in a Grey field and is no longer accessible.

An interesting note is that what i assume to be an active (as in moving) wireless radar icon (which for all intents has the appearance of an orbiting electron field) starts in place of the network connection icon red circled or otherwise immediately after the wired connection is re-inserted, this eventually stops and the device gives the message reconnected and the network connection icon reappears again in its place. (this is the reverse of what described)

No devices are listed when the wired connection is unplugged ¨SSID¨ etc just the two checked boxes and the inaccessible connection information icon are present

I don´t mean to head off on a tangent but I have noticed some more odd things that have made me feel as though i may have missed something fundamental in the network device creation stage of this exercise. or indeed that the wireless /wired connections have somewhat miraculously been configured in reverse by yours truly (me).

With the aim of trying to provide you with as much detail as possible i have listed my observations below

1.The wired cable gets inserted and the wireless connection service thingy starts doing its thing as described
2.Remembering my earlier comments about my wired connection being listed as a wireless device in network manager
3.Choosing the wired network card when creating a new device only allows static ip and address details to be set (no auto obtain option)
4.If i try to activate this new wired device with all other devices deactivated the newly created device itself does not activate, but the incorrectly named wireless device activates instead.

Iron_Mike
7th November 2006, 07:57 PM
Goto system -->administration -->network

When you select network it will ask for the root password. Once the password is entered a dialog box should appear listing both your wireless and wired connections. Do both of them appear and have the appropiate "eth" names?? Do they show wireless and wired or something else?? Post them here.

BTW that should of been a left click on the icon....

NetworkManager is working the way it is suppose to. When the cable is plugged it shows it is connected, when you unplug the cable you will see the icon go into scan, if it desn't find a AP to connect with it will show the circle with line through it. Left clicking the icon should show a list of wireless access points that are within range of your card. If yours is listed, you can double click it and it should try and connect. If it is not listed maybe your wireless access point is not broadcasting the SSID, still when you left click the icon, an option is there to create a new wireless connection, select this and type in your SSID and all the info that pertains to it....

Learner Driver
7th November 2006, 09:16 PM
Iron Mike,

thank you for the tips i will have a crack at them and get back to you with the requested detail.

I have missed a deal of beauty sleep on this mission and and must away to the land of nod at this point I will be back in touch with results later today.

Cheers,

Learner Driver

Iron_Mike
8th November 2006, 02:03 AM
Iron Mike,

thank you for the tips i will have a crack at them and get back to you with the requested detail.

I have missed a deal of beauty sleep on this mission and and must away to the land of nod at this point I will be back in touch with results later today.

Cheers,

Learner Driver

SLEEP, who needs sleep????? WAKE UP...................
:D

Learner Driver
8th November 2006, 09:16 PM
Iron Mike,

Thank you for the last two pearls of wisdom specifically those regarding the possible none broadcast of SSID by the wireless modem and the left click on icon.

I had no idea of the left click option.

You were on the money on both counts.

I had have had success in establishing a wireless connection!

YE HA and thank you very much for all of your assistance.

I have ¨however¨ a somewhat terrible confession to make.

When I first started trying to configure my wireless connection I disabled all security on the wireless modem.

This was done to maximise (I thought) my chances of making an initial connection, hence the modem if i am correct would not have been broadcasting SSID.

Another factor I have had to consider is that I also had my wireless network device configured to ¨SSID Auto¨ and not ¨Specified Auto¨ perhaps an important factor in not being able to connect?

From there I unplugged my wired connection left clicked on the network disconnected icon and chose the option ¨connect to other wireless network¨ option and inputed the name of my wireless modem and away it went.

I am curious though why my wireless card would not pick up an unsecured wireless network.

Would that be due to the fact that i had my wireless card configured incorrectly (SSID Auto) and if this is the case are the only options available for connection to unsecured networks those that require you to specify a device name?

Quite a vague question i know.

Any how thanks again I have read many forums over the years (Microsoft) and never really gave thought to becoming involved in one.

This as a first hit out has been a very positive and informative experience.

Kind Regards,

Learner Driver

Iron_Mike
9th November 2006, 01:23 AM
Iron Mike,

Thank you for the last two pearls of wisdom specifically those regarding the possible none broadcast of SSID by the wireless modem and the left click on icon.

I had no idea of the left click option.

You were on the money on both counts.

I had have had success in establishing a wireless connection!

YE HA and thank you very much for all of your assistance.

I have ¨however¨ a somewhat terrible confession to make.

When I first started trying to configure my wireless connection I disabled all security on the wireless modem.

This was done to maximise (I thought) my chances of making an initial connection, hence the modem if i am correct would not have been broadcasting SSID.

Another factor I have had to consider is that I also had my wireless network device configured to ¨SSID Auto¨ and not ¨Specified Auto¨ perhaps an important factor in not being able to connect?

From there I unplugged my wired connection left clicked on the network disconnected icon and chose the option ¨connect to other wireless network¨ option and inputed the name of my wireless modem and away it went.

I am curious though why my wireless card would not pick up an unsecured wireless network.

Would that be due to the fact that i had my wireless card configured incorrectly (SSID Auto) and if this is the case are the only options available for connection to unsecured networks those that require you to specify a device name?

Quite a vague question i know.

Any how thanks again I have read many forums over the years (Microsoft) and never really gave thought to becoming involved in one.

This as a first hit out has been a very positive and informative experience.

Kind Regards,

Learner Driver


You are quite welcome......The broadcasting the SSID seems to be an issue with Fedora and Network Manager in general, by default, design NetworkManager will try to connect with an unsecure AP that is broadcasting the SSID.

You are absolutely right in resorting to the basics then building from there, ie disabling the encryption schema. No we have a working connection that is selectable using Network Manager Leave your configuration setting for SSID to Auto, it will not affect the connection and will allow you to "see" other networks should you happen to travel with your laptop.

There are 2 trains of thought, IF your wireless access point is boradcasting its SSID, the SSID will show up in the list when you left click the NM icon. You can just highlight it and double click and it will connect. (assuming the settings are correct)
The second is IF your wireless access point IS NOT broadcasting the SSID, it will not show up in the list when you left click the icon. This is why you have to select "connect to other network" and tell name, encryption, etc.

Hopefully I covered your questions, any others just ask. Now for encryption, I run WPA2 myself and FC supports WEP out of the box, but, WPA/WPA2 takes some editing of a file located in /etc/wpa_supplicant directory but it works fine.

Learner Driver
9th November 2006, 04:02 PM
cheers,

for that iron mike i will have a crack at the security side and get back in touch.

I am currently having a go at installing a dwl-g520 wireless ethernet card on my desktop which is presenting similar symptoms as the ipw2200b did.

I suppose I will start looking in the direction i have just come from!

I dont suppose you are the full bottleon where to locate firmware rpms for this critter?


thanks again be in touch soon.

Learner Driver

Dan
9th November 2006, 06:02 PM
To: Iron Mike and Jim

Thank you gentlemen! Info retrieved, will try install later today. Very Clear Instructions!

Dan

ittaydr
10th November 2006, 10:51 PM
hi,

i've upgraded from fc4 to fc6. now, my eth1 wireless (which used to work), is not working

i tried to follow the instructions posted by jim, and found that /lib/firmware already contained the ipw-2.4 files. in addition, it contains the file ipw2200_firmware

when i run neat, two things happen:
1. i get errors in the console about missing network.xpm file
2. when i try to add new hardware, the list of wireless devices is empty, except for the 'other' entry. when i choose that, the 2200 device is not in the list

thanks for your help. since it's hard for me to track the forum, i'd appriciate it if you cc my gmail address ittay.dror

thanks again
ittay

jim
10th November 2006, 11:01 PM
grab the 3.0 version and toss them into the firmware dir

see sig for my googlepages site

http://fedorajim.googlepages.com/ipw2200

ittaydr
10th November 2006, 11:11 PM
thanks for the quick reply.

i copied the files (not the directory which is created when extracting the tgz) to /lib/firmware (as root, does that matter?). didn't change anything (i left the 2.4 files there. should i delete them?)

ittaydr
10th November 2006, 11:14 PM
sorry,

i unloaded the driver. after modprobing it, the network started working. didn't need to go through any configuration in neat either. cool!

Dan
10th November 2006, 11:49 PM
Well done guys... Worked like a charm! :D

Iron_Mike
11th November 2006, 12:55 AM
thanks for the quick reply.

i copied the files (not the directory which is created when extracting the tgz) to /lib/firmware (as root, does that matter?). didn't change anything (i left the 2.4 files there. should i delete them?)

You can delete the old firmware files or leave them your choice, personally I remove unwanted stuff. Just make sure you get the right ones, they're tagged with 2-4 in the filename.

Iron_Mike
11th November 2006, 01:40 AM
grab the 3.0 version and toss them into the firmware dir

see sig for my googlepages site

http://fedorajim.googlepages.com/ipw2200

Way to go Jim, now if they actually use it.

Learner Driver
12th November 2006, 11:02 PM
Hello all,

I left your company last time with a newly established connection for my ipw2200b card on my laptop (curtesy the assistance of Iron Mike).

Yes it is still going strong.

I have been struggling with how to configure my Desktop computer that has a dwl-g520 wireless card so that my respective machines can talk to each other.

I have approached this task optimistically given the successes with the laptop and have spent an amount of time reading the forums help guides etc in the hope of nutting this one out on my lonesome.

I have tried a number of approaches to this end

1.downloaded and attempted to install madwifi rpms {one of the required three has installed other two return error cannot access software}.

2.run yum install madwifi {returns error message cannot find mirrors}

3.run the livna-release-5 rpm package: hoping that would correct issues with using yum

4.have gone to madwifi.org and tried to follow {best i can} the beginners how tot for installing madwifi i seem to reach stop points in each process.

On a positive note I have been able to locate my wireless card with some command line stuff i found in another forum so i suppose that is a start.

Given i got such great support with my last query I humbly return to seek further advice.

Regards,

Learner Driver

Iron_Mike
13th November 2006, 12:54 AM
Hello all,

I left your company last time with a newly established connection for my ipw2200b card on my laptop (curtesy the assistance of Iron Mike).

Yes it is still going strong.

I have been struggling with how to configure my Desktop computer that has a dwl-g520 wireless card so that my respective machines can talk to each other.

I have approached this task optimistically given the successes with the laptop and have spent an amount of time reading the forums help guides etc in the hope of nutting this one out on my lonesome.

I have tried a number of approaches to this end

1.downloaded and attempted to install madwifi rpms {one of the required three has installed other two return error cannot access software}.

2.run yum install madwifi {returns error message cannot find mirrors}

3.run the livna-release-5 rpm package: hoping that would correct issues with using yum

4.have gone to madwifi.org and tried to follow {best i can} the beginners how tot for installing madwifi i seem to reach stop points in each process.

On a positive note I have been able to locate my wireless card with some command line stuff i found in another forum so i suppose that is a start.

Given i got such great support with my last query I humbly return to seek further advice.

Regards,

Learner Driver

Learner,

I just looked in the Livna FC5 repos and the files are there, madwifi, kmod-madwifi and a couple others. Are you using Yumex, the graphical frontend for Yum? If not you can install it from root:

yum install yumex

It will put a icon in Applications -->system tools

It will show you the updates for currently installed programs, and it'll give you an install option to install programs that are not currently installed

Learner Driver
13th November 2006, 01:13 AM
Hey thanks Iron Mike I will have a go at this straight away

Learner Driver
13th November 2006, 01:28 AM
I just had a crack the recommended action and got the following output.

[root@localhost ~]# yum install yumex
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
atrpms [1/5]
http://apt.atrpms.net/fedora/5/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Mon, 13 Nov 2006 00:23:29 GMT
Server: Apache/2.2.2 (Fedora)
Content-Length: 323
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms
failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.
[root@localhost ~]#

Maybe this is something simple not sure hope it means something to you Iron Mike

Cheer,

Learner Driver

Iron_Mike
13th November 2006, 02:35 AM
Well the 404 error, is page / site is not found. But for myself and this is a personal preference and by all means not gospel, is that I only use 3 repos:

fedora-core.repo
fedora-development.repo
fedora-extras-development.repo
fedora-extras.repo
fedora-legacy.repo
fedora-updates.repo
fedora-updates-testing.repo
livna-devel.repo
livna.repo
livna.repo.rpmorig
livna-testing.repo
macromedia.repo


The fedora repos are pretty much standard, I added the livna and macromedia repos. With the atrpms repo, and the livna repo there might be some conflicts with naming and dependencies. The atrpms repo does not carry the yumex package, hence the error. If you go to your /etc/yum.repos.d and remove the atrpms repo files then go to:

http://rpm.livna.org/rlowiki/UsingLivna

and install the FC5 repos, you will be able to use yum install yumex

Learner Driver
13th November 2006, 11:02 AM
Ah Okay that makes sense,

Thanks for the pointer Mike

I will have a go at this and get back to you wth the results.


Cheers,

Learner Driver

Learner Driver
13th November 2006, 03:20 PM
Iron Mike, fantastic pointers mate!


Good news I followed your instructions and was successful in updating through the link to livna.org.

The FC5 Repos was successfully installed Yum was updated and I was able to install Yumex.

From here I was able to install Madwifi Rpms and a kernel upgrade which occurred automatically.

I rebooted the machine and went about setting up the network device ¨wifi0¨.

Here is the rub!


Under ¨hardware¨ the Atheros card (dwl-g520) is visible but here is the catch it is not accessible as a selectable device option when creating a new wireless device.

Instead the only options are from the default drop down list (incidently the list does have a dwl-650 card) there does not appear to be any reference to an Atheros device driver available as a recent addition to the drop down list either.

Interestingly though if you select the create new ¨Ethernet¨ device option the Atheros device (dwl-g520) is available as an adaptor.

I have gone through the motions of selecting this option and continuing with the setup on the odd chance that this might work sadly it does not Back to you Iron Mike.

So near and yet so far

Regards,

Learner

Iron_Mike
13th November 2006, 03:49 PM
Glad that it worked out. Did you happen to reboot the computer after the madwifi drivers were installed, it needs to.

Almost forgot you might have to edit your modprobe.conf file to get NM to reconize your card. Open a terminal window and su - to root and type:

gedit /etc/modprobe.conf

Add these lines:

alias wifi0 ath_pci
alias ath0 ath_pci
options ath_pci autocreate=sta

Save it and reboot.

Learner Driver
13th November 2006, 04:29 PM
Hey Iron Mike,

Yes i did reboot after installing the madwifi drivers.

Given that I am already logged in as root I opened a terminal and entered gedit/etc/modprobe.conf directly after (root@localhost~]#) and i got this response

bash: gedit/etc/modprobe.conf: No such file or directory

Mmh!

Does this mean that i have to do the su root thing?

Or can i go directly to the file etc/modprobe.conf and modify it given that i am already in the root user profile?

Cheers,

Learner Driver

Learner Driver
13th November 2006, 04:36 PM
Mike,

i have found etc/modprobe.d/modprobe.cong.dist.

Will this pass muster?

Learner

Iron_Mike
13th November 2006, 05:21 PM
If you're logged on as root you can go directly to /etc/modprobe.conf and edit it directly...Nope the file is called modprobe.conf and it is located in the /etc directory....

Learner Driver
13th November 2006, 08:36 PM
Mike,

Hope you are still with me mate! I can now see the Atheros device under hardware in the network manager.

I can select it as an adaptor in wireless configuration options and have had several attempts at connecting it to the wireless network. (wired network unplugged)

The Wlan name appears in net connection icon with left click I used wifi radar to set a persistent link (though i cannot establish an IP address) I am running wlassistant as well these three services (Wifi Raidar, Wlassistant. Network connection icon) all register the Wlan at good strength.

Each time the connection shows as having failed to connect too the network I get the following error message.

¨Error for wireless request ¨Set bit rate¨ (8B20) : SET failed on device ath0; Invalid argument, determining IP for ath0.... failed.¨

Is this in anyway like the ipw2200 where i had too set the bit rate to ¨Auto¨?

As a foot note I have gone into the file ¨etc/sysconfig/network-scripts/ ifcg-ath0¨ and edited the bit rate from
Rate=´0kbs´
to Rate=Auto. (a little knowledge can be dangerous!)

I rebooted and tried to connect again and got the following error message.

¨Error for wireless request ¨Set Mode¨ (8B06): SET failed on device ath0 ; Invalid argument.¨

¨Determining IP for ath0....failed.¨

Currently the file ifcg-ath0 reads as below

#Please read /usr/share/doc/iniscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no
USERCTL=no
IPV6INIT=no
PEERDNS=yes
TYPE=Wireless
DEVICE=ath0
HWADDR=00:15:e9:b9:89:d6
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMMAIN=
ESSID=Auto
CHANNEL=11
MODE=Auto
RATE=Auto

PS i have made a bit of a blue before hearing back from you last time round i went into the ¨etc/modprobe.d/modprobe.config.dist¨ file and inserted the alias atho text (three alias lines) and gave it a whirl thinking i could just remove it again if needs be.


This i have of course done, last reboot i saw an error message come up with the modprobe.config.dist file name attached to it saying error bad line 168 line set with ¨options¨.

Having said this i have not seen it again am wondering if i should be concerned!

Nearly there

Thanks for all the help s far Mike

Learner

Iron_Mike
13th November 2006, 10:02 PM
Mike,

Hope you are still with me mate! I can now see the Atheros device under hardware in the network manager.

I can select it as an adaptor in wireless configuration options and have had several attempts at connecting it to the wireless network. (wired network unplugged)

The Wlan name appears in net connection icon with left click I used wifi radar to set a persistent link (though i cannot establish an IP address) I am running wlassistant as well these three services (Wifi Raidar, Wlassistant. Network connection icon) all register the Wlan at good strength.

Each time the connection shows as having failed to connect too the network I get the following error message.

¨Error for wireless request ¨Set bit rate¨ (8B20) : SET failed on device ath0; Invalid argument, determining IP for ath0.... failed.¨

Is this in anyway like the ipw2200 where i had too set the bit rate to ¨Auto¨?

As a foot note I have gone into the file ¨etc/sysconfig/network-scripts/ ifcg-ath0¨ and edited the bit rate from
Rate=´0kbs´
to Rate=Auto. (a little knowledge can be dangerous!)

I rebooted and tried to connect again and got the following error message.

¨Error for wireless request ¨Set Mode¨ (8B06): SET failed on device ath0 ; Invalid argument.¨

¨Determining IP for ath0....failed.¨

Currently the file ifcg-ath0 reads as below

#Please read /usr/share/doc/iniscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no
USERCTL=no
IPV6INIT=no
PEERDNS=yes
TYPE=Wireless
DEVICE=ath0
HWADDR=00:15:e9:b9:89:d6
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMMAIN=
ESSID=Auto
CHANNEL=11
MODE=Auto
RATE=Auto

PS i have made a bit of a blue before hearing back from you last time round i went into the ¨etc/modprobe.d/modprobe.config.dist¨ file and inserted the alias atho text (three alias lines) and gave it a whirl thinking i could just remove it again if needs be.


This i have of course done, last reboot i saw an error message come up with the modprobe.config.dist file name attached to it saying error bad line 168 line set with ¨options¨.

Having said this i have not seen it again am wondering if i should be concerned!

Nearly there

Thanks for all the help s far Mike

Learner

We'll leave the "set bit rate error" for now, it is pretty benign. But for the time being remove the entries you put in modprobe.config.dist file and put those entries in the modprobe.conf file in /etc. reboot the computer. I see you have wifi-radar, wlassistant running. Do you also have NetworkManager running??? After you installed the drivers with yum and rebooted, did you go to system -->administration -->network and add the wireless device? What happens when you use NetworkManager to try and connect??

Learner Driver
13th November 2006, 10:27 PM
Mike,

Sorry if i have confused the situation at all, I have already removed the entries modprobe.conf file in /etc. I rebooted immediately after installing the drivers and have rebooted several times since. i have created the wireless device in network manager several times restarting both the network manager and network manager dispatcher mannualy on each occasion after creating the new device prior to testing it. I did not however create the hardware device in network manager it had already appeared. When we talk about adding the entries in the modprobe.conf file in /etc I will take it that these are the ath0 alias entries from earlier.

I will delete the current wireless hardware device and create a new one to see what happens, and be back to you soon with the results.

Cheers,

Learner

Learner Driver
13th November 2006, 10:38 PM
Iron Mike,

I have posted the data currently in /etc/modprobe.conf below inclusive of the additinal entries. I have added only the last 3 lines (alias wifi0 ath_pci) & (alias ath0 ath_pci) & (options ath_pci autocreate=sta).

Will reboot and get back in touch.

Learner

(Current entry list in etc/modprobe.conf)

alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias ath0 ath_pci
options ath_pci autocreate=sta
alias wifi0 ath_pci
alias ath0 ath_pci
options ath_pci autocreate=sta

Iron_Mike
13th November 2006, 10:41 PM
The alias ath0, wlan0 need to be added to the modprobe.conf file. When you say you created the wireless device in NetworkManager, I hope you mean the Network Configuration tool. After creating the wireless device, check all the settings and save it, then you will need to log off and log on. Open up the networkwork configuration tool again and it should show 2 entries, one wireless, one wired. If it does you should be able to left click the NetworkManager icon, select your AP and hit connect.

Learner Driver
13th November 2006, 11:17 PM
Yes sorry about that Mike the terminology had become lost on me! it was in the network configuration tool.

I have added too the modprobe.conf file the entry as shown below minus the inverted comaś.

¨alias ath0 wlan¨

After the last reboot i have one additional device registered under hardware devices and susequently now i have both
¨Atheros Communications Wireless ath0¨ (Status Ok) Adaptor for device ath0 (Atheros Communications AR 5212
¨ath_pci Ethernet wifi0¨ (Status Configured) Adaptor for device wifi0 (ath_pci).

I also have both wired and wireless networks shown under network connection icon.

Entries made devices checked and saved away to logon log off time.

Hope I have got it right fingers crossed back soon on wireless!

Learner

Learner Driver
13th November 2006, 11:28 PM
Well I should has said touch wood ill be back on wireless!

I cant activate the wireless device in network configuration tool.

The following error meesage is seen after a failed connection attempt!

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0...dhclient(3002) is already running - exiting.
exiting.
failed.

Iron_Mike
13th November 2006, 11:48 PM
It's close, but go back into the network configuration tool, highlight the wireless and on the first screen put a check mark in the box to "allow users to activate / disable" and try it again...

Learner Driver
13th November 2006, 11:51 PM
Will do back soon

Learner

Learner Driver
14th November 2006, 12:24 AM
All right Mike ready for something a little strange!

I removed the wired network connection from the PC and logged off.

Logged on again went to network configuration tool and saw to my delight ath0 Wireless active,

Went to network connection icon left clicked selected wireless network (my specific wlan) as a connection with the network configuration tool still open and noticed that the moment i clicked the option to connect to a wireless network that the ath0 connection visible in network configuration tool became immediately inactive.

When i attempted to re-activate the ath0 connection I get the following error.

Error for Wireless request ¨Set Bit Rate¨ (8B20) : SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0...dhclient(3509) is already running - exiting.
exiting.
failed.

I also got a new error message (The Application ¨system-config-network¨ has quit unexpectedly.
You can inform the developers of what happened to help them fix it. Or you can re-start the application right now).

I just restarted it.


Anyway OnOn

A penny for your thoughts Mike!

Learner Driver
14th November 2006, 12:53 AM
Mike you may get a grin out of this! I am certainly a little bemused.

I currently have wired network cable unplugged from my PC and have repeated the process of trying to connect to the wireless network. (no success)

Wireless assistant can see the ¨Wlan¨ Wifi Raidar can see it as well but cannot resolve an IP address for it.

Trying to connect to the wireless network via the network connection icon renders the ath0 device inactive immediately a connection attempt is made (no issue is presented if i am connecting to the wired network however).

After having said all of this i have just logged onto the Wlan without any outward sign of there being an active wireless connection.

I did this by simply opening the webrowser and playing around, in the current configuration i am trawling around the web!

An interesting point of note is that after aperiod of time ( a couple of minutes) an error meesage from Wireless Assistant appears saying that the link to Wlan has been lost and would you like to reconnect.

In fact the link has not been lost and it is still possible to browse sites.

In addition to this and only to confound I am certain, if you click to reconnect to the Wlan you guessed it you become disconnected for real!

Bizzare

Any Ideas?

Learner

Iron_Mike
14th November 2006, 01:20 AM
Not sure what it is but let's try to get rid of the "bit error rate" in your ifcfg-ath0 file change the:

RATE=Auto

to

RATE='0 kb/s'

with the single quotes and all

Save it unplug your ethernet cable and reboot. When it comes back up, see if it shows "active" again. If it does leave it alone and see if you have internet connection.

BTW I just noticed this you might want to remove your double entries.....

alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias ath0 ath_pci
options ath_pci autocreate=sta
alias wifi0 ath_pci
alias ath0 ath_pci
options ath_pci autocreate=sta

Learner Driver
14th November 2006, 02:17 AM
Mike,

I went into the ifcfg-ath0 file to change the Rate= entry and it had apparently defaulted back to the recommended entry.

I closed the file saving and exiting.

Upon reboot the wireless connection did not initiate on its lonesome I had to enter network configuration tool and activate it directly.

As a result it has a wirless connection, but still shows as not being connected under the network connection icon which still has a rather large red circle and slash through it.

I am not running Wifi Assistant at present so have avoided the pop up connection error dialouge.

Yes did notice those double entries in the ifcfg-ath0 file got ahead of myself and forgot to mention them,¨wasnt really sure¨ glad you saw them they have now been removed, file saved about to reboot and come back.

Learner

Learner Driver
14th November 2006, 02:24 AM
Pease disregard my way outhere comments on changing the alias entries in the ifcfg-ath0 file I did ofcourse mean the
etc/modprobe.conf file.

Learner

Iron_Mike
14th November 2006, 02:30 AM
Mike,

I went into the ifcfg-ath0 file to change the Rate= entry and it had apparently defaulted back to the recommended entry.

I closed the file saving and exiting.

Upon reboot the wireless connection did not initiate on its lonesome I had to enter network configuration tool and activate it directly.

As a result it has a wirless connection, but still shows as not being connected under the network connection icon which still has a rather large red circle and slash through it.

I am not running Wifi Assistant at present so have avoided the pop up connection error dialouge.

Yes did notice those double entries in the ifcfg-ath0 file got ahead of myself and forgot to mention them,¨wasnt really sure¨ glad you saw them they have now been removed, file saved about to reboot and come back.

Learner


Can you access the internet using it this way?? Does it stay active or does it go back to being inactive???

Learner Driver
14th November 2006, 02:33 AM
Mike when I went into modprobe.conf I found the below (a tripple up on alias ath0 wlan) I have modified to single entries and posted my reults bellow my discoveries for you to puruse if you would be so kind.

alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias ath0 wlan
options ath_pci autocreate=sta
alias ath0 wlan
options ath_pci autocreate=sta
alias wifi0 ath_pci
alias ath0 wlan

(Modified entry list)
alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
options ath_pci autocreate=sta
alias wifi0 ath_pci
alias ath0 wlan

Iron_Mike
14th November 2006, 02:34 AM
Mike when I went into modprobe.conf I found the below (a tripple up on alias ath0 wlan) I have modified to single entries and posted my reults bellow my discoveries for you to puruse if you would be so kind.

alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias ath0 wlan
options ath_pci autocreate=sta
alias ath0 wlan
options ath_pci autocreate=sta
alias wifi0 ath_pci
alias ath0 wlan

(Modified entry list)
alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
options ath_pci autocreate=sta
alias wifi0 ath_pci
alias ath0 wlan

The modified entry list is the one you want......

Iron_Mike
14th November 2006, 02:41 AM
Let me ask you this, do you have NetworkManager up and running on this box? If you do reboot the computer and see if it automatically connects to your wireless router. If it doesn't, left click the NetworkManager icon and select your wireless router and hit connect. Does it connect or error out?? If it errors out post the error here.

Then try this, open a terminal window and su - to root and type:

ifup ath0 then
dhclient ath0

does it connect now?

Learner Driver
14th November 2006, 03:26 AM
Mike,

on reboot the wireless card was functioning when I entered the terminal and inputed ¨ifup ath0¨ the link dropped out straight away.

The entry into teminal of ¨dhclient ath0¨ doesnt appear to have done anything that I could see.

In regards to your other question do I have network manager up and running on my PC I have to say I am not sure Now!

I will describe what I have and perhaps you can tell me.

Top right hand corner of the screen i have tool bar upon which next to the clock I have a network connection icon (when not connected it shows that it is and visa versa)

Under the menu System / Administration I have a blue and gold coloured ball thingy (maybe a planet) and what looks like a wand if i hold the mouse pointer over it, I get the message ¨configures network devices and connections¨

Under the menu System / Administration /i have ¨services¨ where I can see ämong others I have network manager and network manager dispatcher both I have been sure to see are running (i have been mannually restarting them to be certain.

Does this help at all.

Thanks for your patience Mike

Learner


terminal output returned as below

[root@localhost ~]# ifup ath0
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0... done.
[root@localhost ~]# dhclient ath0
[root@localhost ~]#

Iron_Mike
14th November 2006, 03:58 AM
Mike,

on reboot the wireless card was functioning when I entered the terminal and inputed ¨ifup ath0¨ the link dropped out straight away.

The entry into teminal of ¨dhclient ath0¨ doesnt appear to have done anything that I could see.

In regards to your other question do I have network manager up and running on my PC I have to say I am not sure Now!

I will describe what I have and perhaps you can tell me.

Top right hand corner of the screen i have tool bar upon which next to the clock I have a network connection icon (when not connected it shows that it is and visa versa)

Under the menu System / Administration I have a blue and gold coloured ball thingy (maybe a planet) and what looks like a wand if i hold the mouse pointer over it, I get the message ¨configures network devices and connections¨

Under the menu System / Administration /i have ¨services¨ where I can see ämong others I have network manager and network manager dispatcher both I have been sure to see are running (i have been mannually restarting them to be certain.

Does this help at all.

Thanks for your patience Mike

Learner


terminal output returned as below

[root@localhost ~]# ifup ath0
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0... done.
[root@localhost ~]# dhclient ath0
[root@localhost ~]#

OK, Not a problem just trying to find out where we are and what is happening. 1st things first.

1. Go to system -->administration -->services Put check marks in the top 2 services and save it. They should be NetworkManager and NetworkManagerDispatcher.

2. Reboot the computer

3. When the computer comes back up log on as a user, there should be a new icon in the top panel on the right side. This is going to work just like your laptop. Does it show a connection icon (4 vertical bars) or does it show a mouse icon with a red circle with a line through it??

4. If it shows a connection, 4 bars can you access the internet??

5. If it shows a mouse w/ red circle, left click the icon. Can you see your wireless router SSID?? If you can, highlight it and click connect. Does it connect and go to the 4 bars or does a error pop up. If it does connect, can you access the internet??

6. If you can't see you wireless router SSID, select connect to other wireless and enter your info and select connect, does it connect now??

Learner Driver
14th November 2006, 04:48 AM
Righto Mike,

No.1 - 2 done
No.3 - 4no new icon
No.5 The standard internet icon shows 1 wireless network address cant connect to it
No.6 selected to connect to other wireless network connection no joy

Iron_Mike
14th November 2006, 12:15 PM
Open a terminal window and type:

ifup ath0 then type

dhclient ath0

post the output of the terminal window. Leaving the terminal window open, try and access the internet.

Iron_Mike
14th November 2006, 12:30 PM
And if that doesn't work, let's try and force it. This is your ifcfg-ath0 make the changes that are in red.

Currently the file ifcg-ath0 reads as below

#Please read /usr/share/doc/iniscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no <--change to yes
USERCTL=no <--change to yes
IPV6INIT=no
PEERDNS=yes
TYPE=Wireless
DEVICE=ath0
HWADDR=00:15:e9:b9:89:d6
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMMAIN=
ESSID=Auto <--change to "your SSID"
CHANNEL=11 <--change to the channel your router is using
MODE=Auto <--change to Managed
RATE=Auto


Reboot the computer and watch for errors and post them. When th computer boots try to access the internet.....

Learner Driver
14th November 2006, 04:27 PM
Iron Mike thanks for sticking with this battle mate!

I am working through the last of your recommendations and will come back to you with the results shortly.

Regards,

Learner

Learner Driver
14th November 2006, 07:56 PM
Mike

I have implemented the recommendations that you made earlier the file ifcg-ath0 has been ammended.

Oh yes the error logs from reboot after modifying the file ifcg-ath0 are at the bottom of this doc.

I rebooted and logged back in as guest usr no change in icons (wifi did not appear)

I went to the wired network icon (red circle with slash) left clicked attempted connection to the listed wireless point (could not connect)

Left clicking on the wired network icon I selected the option connect to other wireless network I entered all of the required details to enable a connection to the network still no connection.

Also I have noticed that since forcing the device (making the configuration changes) some things have changed.

Previously as root I could activate the ath0 device in network configuration tool and while no external evidence was visible to suggest a wireless connection had been established one had indeed been made.

This is no longer possible under either usr or root.

Out of curiosity I looked at the connected devices on my router and noted that the pc had been connected via wireless to the router moments before my failed attempt to establish a wifi connection manually.

I did a bit of an experiment clearing all previously connected device listings from the router proving that a wireless connection is automatically established from pc to router on boot.

This wireless connection while not plainly visible if left alone appears quite happy doing its thing.

However if atempt is made to mannualy connect to the wireless network /activate ath0 in network tool the device drops out immediately. Other wifi apps i.e. wifi assistant kill the connection as well the moment they query the wifi card (if they are refreshed).

The only way the wireless connection can be re-established again is by rebooting the pc.

I dont know if this is helpful or just supurfalous information sorry.

(Error outputs noted on reboot after modifying (ifcg-ath0)
No1
Bringing up interface ath0: Error for wireless request ¨Set Bit Rate¨ (8B20) :
SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0...done.

No2

Starting RPC idmapd: WARNING: /etc/modprobe.d/modprobe.conf.dist~ line168: ignoring bad line starting with `options´
WARNING; /etc/modprobe.d/modprobe.conf.dist~ line168: ignoring bad line starting with `options´

Iron_Mike
14th November 2006, 08:14 PM
Something weird is going on here. Change all the settings in your modprobe.conf file back to the way they were. Don't change anything else. Reboot the computer

When the computer comes back up you say it automatically establishes a wireless connection if the cable is not plugged in????

Without doing anything open a terminal window and change to root (su -) and type:

iwconfig

and post the results here....

Learner Driver
15th November 2006, 01:48 PM
Iron Mike,

I have assumed that you intend me to remove our most recent entry to the etc/modprbe.config file.

The llast entry to this file was the addition of ¨alias ath0 wlan¨

The newly configured file entries are now shown below

(Modified entry list etc/modprobe.config 15.11.06 @20:40hrs)
alias eth0 e100
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
options ath_pci autocreate=sta
alias wifi0 ath_pci

Entering iwconfig into a terminal after su from guest account returns the error message no such file or command.

Entering iwconfig into a terminal from root account produces altogether differnet reuslts and returns the following output.

[root@localhost ~]# iwconfig
lo no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:"SpeedStream" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462 GHz Access Point: 00:13:A3:57:F0:8A
Bit Rate:11 Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=41/94 Signal level=-54 dBm Noise level=-95 dBm
Rx invalid nwid:66 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

The wireless connection is operational incidently in its off beat strange way.

Many thanks,

Learner Driver

Iron_Mike
15th November 2006, 02:06 PM
My bad, I meant the ifcfg-ath0 NOT the modprobe.conf mentioned above, sorry. The above shows it is associated with the wireless router. Now in the terminal window still as root, type:

ifconfig

Post the results here

Learner Driver
15th November 2006, 06:46 PM
Iron Mike,
not a worry in the world mate more than compensated for by your kind assistance to date.

I have returned etc/modprobe.config to its orignial state & removed the entries that I added earlier in the session to ¨ifcgath0¨

Terminal output from entry ifconfig as below.

[root@localhost ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:15:E9:B9:89:D6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2346 errors:0 dropped:0 overruns:0 frame:0
TX packets:2346 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2467725 (2.3 MiB) TX bytes:2467725 (2.3 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-15-E9-B9-89-D6-08-54-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101 errors:0 dropped:0 overruns:0 frame:6347
TX packets:308 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:8162 (7.9 KiB) TX bytes:14168 (13.8 KiB)
Interrupt:193 Memory:f0a20000-f0a30000

[root@localhost ~]#


Cheers,

Learner

Iron_Mike
15th November 2006, 07:14 PM
OK, now add these entries to the /etc/modprobe.conf file only.

options ath_pci autocreate=sta
alias wifi0 ath_pci
alias ath0 wlan

Save it and reboot the computer. Open a terminal window and type these 2 commands:

iwconfig
ifconfig

Then post the results again. After that in the same terminal window type this command:

dhclient ath0

Then run the same 2 commands as above and post the results here is the same msg.

Learner Driver
15th November 2006, 07:44 PM
Iron Mike,

I have modified the entries in /etc/modprobe.conf as directed, rebooted etc.

Output from terminal entries iwconfig & ifconfig as below with more to follow.

[root@localhost ~]# iwconfig
lo no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:13 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

[root@localhost ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:15:E9:B9:89:D6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
inet addr:10.0.0.5 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::207:e9ff:feba:494e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:734 errors:0 dropped:0 overruns:0 frame:0
TX packets:778 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:234840 (229.3 KiB) TX bytes:73851 (72.1 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2459 errors:0 dropped:0 overruns:0 frame:0
TX packets:2459 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2951877 (2.8 MiB) TX bytes:2951877 (2.8 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-15-E9-B9-89-D6-88-0B-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:53 errors:0 dropped:0 overruns:0 frame:5709
TX packets:251 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:4238 (4.1 KiB) TX bytes:11546 (11.2 KiB)
Interrupt:185 Memory:f0a20000-f0a30000

Learner Driver
15th November 2006, 07:48 PM
Iron Mike,

Here is the terminal output after entries dhclient, iwonfig and ifconfig were made.

[root@localhost ~]# dhclient ath0
[root@localhost ~]# iwconfig
lo no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:14 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

[root@localhost ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:15:E9:B9:89:D6
inet6 addr: fe80::215:e9ff:feb9:89d6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
inet addr:10.0.0.5 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::207:e9ff:feba:494e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:761 errors:0 dropped:0 overruns:0 frame:0
TX packets:808 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:252058 (246.1 KiB) TX bytes:81610 (79.6 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2462 errors:0 dropped:0 overruns:0 frame:0
TX packets:2462 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2952213 (2.8 MiB) TX bytes:2952213 (2.8 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-15-E9-B9-89-D6-F8-60-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:63 errors:0 dropped:0 overruns:0 frame:7766
TX packets:309 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:5034 (4.9 KiB) TX bytes:14214 (13.8 KiB)
Interrupt:185 Memory:f0a20000-f0a30000

[root@localhost ~]#

Iron_Mike
15th November 2006, 08:34 PM
OK, now unplug your ethernet cable and run the same commands, this is what I'm looking for. This is your ethernet connection I'm looking at this line right here, but I want to see it listed under your ath0 connection

inet addr:10.0.0.5 Bcast:10.0.0.255 Mask:255.255.255.0


eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
inet addr:10.0.0.5 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::207:e9ff:feba:494e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:761 errors:0 dropped:0 overruns:0 frame:0
TX packets:808 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:252058 (246.1 KiB) TX bytes:81610 (79.6 KiB)

Learner Driver
15th November 2006, 08:40 PM
Ok Mike here is the terminal ouput data (minus wired network connection)

[root@localhost ~]# iwconfig
lo no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:52 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

[root@localhost ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:15:E9:B9:89:D6
inet6 addr: fe80::215:e9ff:feb9:89d6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:1560 errors:0 dropped:0 overruns:0 frame:0
TX packets:1742 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:395512 (386.2 KiB) TX bytes:322552 (314.9 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2489 errors:0 dropped:0 overruns:0 frame:0
TX packets:2489 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2955237 (2.8 MiB) TX bytes:2955237 (2.8 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-15-E9-B9-89-D6-98-E3-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:212 errors:0 dropped:0 overruns:0 frame:36297
TX packets:1083 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:16928 (16.5 KiB) TX bytes:49818 (48.6 KiB)
Interrupt:185 Memory:f0a20000-f0a30000

[root@localhost ~]# dhclient
[root@localhost ~]# iwconfig
lo no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:52 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

[root@localhost ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:15:E9:B9:89:D6
inet6 addr: fe80::215:e9ff:feb9:89d6/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:1560 errors:0 dropped:0 overruns:0 frame:0
TX packets:1742 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:395512 (386.2 KiB) TX bytes:322552 (314.9 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2489 errors:0 dropped:0 overruns:0 frame:0
TX packets:2489 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2955237 (2.8 MiB) TX bytes:2955237 (2.8 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-15-E9-B9-89-D6-08-7D-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:212 errors:0 dropped:0 overruns:0 frame:36372
TX packets:1083 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:16928 (16.5 KiB) TX bytes:49818 (48.6 KiB)
Interrupt:185 Memory:f0a20000-f0a30000

[root@localhost ~]#

Iron_Mike
15th November 2006, 08:44 PM
I hope you are using:

dhclient ath0

Learner Driver
15th November 2006, 08:56 PM
Iron Mike you will have to tell me like i am a two year old! dhclient ath0?

Where should this be How should I be using it?

Learner

Iron_Mike
15th November 2006, 09:11 PM
Iron Mike you will have to tell me like i am a two year old! dhclient ath0?

Where should this be How should I be using it?

Learner

When you type the command in the terminal window did you type just:

dhclient

or did you use:

dhclient ath0

Also double check your the file /etc/modprobe.conf to make sure these entries are there:

alias wifi0 ath_pci
alias ath0 ath_pci
options ath_pci autocreate=sta

Just like this, no mistakes. If they don't look like this remove them and add the above. Now with the ethernet cable unplugged, reboot the computer, open a terminal window and type these 2 commands and posts the results:

iwconfig
ifconfig

Then run this command:

dhclient ath0

The run the iwconfig and ifconfig commands again and posts the results here.....

Learner Driver
15th November 2006, 09:43 PM
Mike output post 1 of 2

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:97 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

[root@localhost ~]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:15:E9:B9:89:D6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:722 errors:0 dropped:0 overruns:0 frame:0
TX packets:752 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:236552 (231.0 KiB) TX bytes:71568 (69.8 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2687 errors:0 dropped:0 overruns:0 frame:0
TX packets:2687 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2504253 (2.3 MiB) TX bytes:2504253 (2.3 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-15-E9-B9-89-D6-88-BF-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:155 errors:0 dropped:0 overruns:0 frame:13002
TX packets:384 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:12548 (12.2 KiB) TX bytes:17664 (17.2 KiB)
Interrupt:193 Memory:f0a20000-f0a30000

[root@localhost ~]#

Learner Driver
15th November 2006, 09:48 PM
Mike output post 2 of 2

[root@localhost ~]# dhclient ath0
iwconfig
ifconfig
[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:129 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

[root@localhost ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:07:E9:BA:49:4E
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:760 errors:0 dropped:0 overruns:0 frame:0
TX packets:813 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:257643 (251.6 KiB) TX bytes:85341 (83.3 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2690 errors:0 dropped:0 overruns:0 frame:0
TX packets:2690 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2504589 (2.3 MiB) TX bytes:2504589 (2.3 MiB)

Iron_Mike
15th November 2006, 10:11 PM
Now we're getting there. I want you to make these changes to the file /etc/sysconfig/network-scripts/ifcfg-ath0

#Please read /usr/share/doc/iniscripts-*/sysconfig.txt
# for the documentation of these parameters.
ONBOOT=no
USERCTL=no <--change to yes
IPV6INIT=no
PEERDNS=yes
TYPE=Wireless
DEVICE=ath0
HWADDR=
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMMAIN=
ESSID=Auto <--change to "your SSID"
CHANNEL=11 <--change to the channel your router is using
MODE=Auto <--change to Managed
RATE=Auto

Remove the comments that are preceeded with this (<--)
Once that is done, open a terminal window and type:

ifup-ath0

then type:

dhclient ath0

then type:

iwconfig

and post the output here....Remenber this is done with the ethernet unplugged

Learner Driver
15th November 2006, 10:27 PM
Mike,

here is the terminal output as requested.

[root@localhost ~]# ifup-ath0
bash: ifup-ath0: command not found
[root@localhost ~]# dhclient ath0
[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:293 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Iron_Mike
15th November 2006, 10:41 PM
ooops, that should of been:

ifcfg-ath0

Learner Driver
15th November 2006, 10:49 PM
Not to worry heres the requested terminal output.

[root@localhost ~]# ifcfg-ath0
bash: ifcfg-ath0: command not found
[root@localhost ~]# dhclient ath0
[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:294 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Iron_Mike
15th November 2006, 11:55 PM
Let try this: With the cable disconnected Open a terminal and type:

iwconfig ath0 essid XXXXXXX

replace the XXXXXXX with the SSID of your wireless router.....

Iron_Mike
15th November 2006, 11:55 PM
Let try this: With the cable disconnected Open a terminal and type:

ifconfig ath0 essid XXXXXXX

replace the XXXXXXX with the SSID of your wireless router.....

Learner Driver
16th November 2006, 01:03 AM
Ok Mike thats been done entry inputed as shown below

iwconfig ath0 essid SpeedStream

What next?

Iron_Mike
16th November 2006, 02:02 AM
Ok Mike thats been done entry inputed as shown below

iwconfig ath0 essid SpeedStream

What next?

any errors show up ??

type:

iwconfig

post the output, try the internet etc.....

Iron_Mike
16th November 2006, 02:22 AM
Let's stop! Nothing is this hard to get configured and working. How much hassle would it be to reinstall Fedora, and then start a new msg thread called madwifi drivers or such. We could start some scratch with a new install and complete update, then do the drivers .....Your choice...

Learner Driver
16th November 2006, 02:52 AM
Mike,

below is the output after terminal entry ¨iwconfig¨ (no apparent errors)

[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

Warning: Driver for device ath0 has been compiled with version 20
of Wireless Extension, while this program supports up to version 19.
Some things may be broken...

ath0 IEEE 802.11g ESSID:"SpeedStream" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462 GHz Access Point: 00:13:A3:57:F0:8A
Bit Rate:11 Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=31/94 Signal level=-64 dBm Noise level=-95 dBm
Rx invalid nwid:1452 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Other Observations:
I have been periodically testing and using wireless connectivity on the pc i.e. typing this post.
I have observed a couple of changes related to device activation in network configuration tool since the entriesifconfig/iwconfig ath0 essid have been made in the terminal.

when i re-activate the wireless connection in network confguration tool I no longer have to log off and on to reactivate the connection.

3 previously when activating the wireless connection an error would be reported ath0 could not acquire IP address then the connection would magically appear after the error dialouge box was Xéd off.

Now activating the wireless connection there is no error report posted and the ath0 ¨says¨ it has acquired an IP address something it did not do before. (this is not an exact science however quite unreliable 50/50 on successful connection & how long a connection will last once established varies from a few minutes to maybe a few more)

A good example of the intermitant connectivity being right now i am ready to post and have had to connect the wired cable connection as wireles doesnt want to play

Learner

No other changes mind you

Learner

Iron_Mike
16th November 2006, 03:38 AM
OK, let me get this straight, sometimes your wireless works (ie access to the internet) and sometimes it doesn't! Look at what you just posted, first you say your posting wireless then in mid stride your changing




Mike,


I have been periodically testing and using wireless connectivity on the pc i.e. typing this post.

A good example of the intermitant connectivity being right now i am ready to post and have had to connect the wired cable connection as wireles doesnt want to play

Learner

No other changes mind you

Learner

Learner Driver
16th November 2006, 04:04 AM
The wireless connection as we have seen it to date has not been stable. As previously any number of things have been demonstrated to knock it out.

Besides the fact that it does not appear anyware as connected (network connection icon) the duration of anyone connection can vary anyware within minutes to half an hour.

I suppose what i was trying to say is that some of the accompanying errors (error messages ¨cannot determine ip address for ath0¨) that previously occured when I tried to activate the wireless connection no longer appear.

In addition it is easier to activate the wireless device from in network management tool than before as the ath0 appears to be able to determine an IP address which is something it could not do previously.

I suppose i was looking off into the optomistic future there Mike sorry to have caused confusion.

Learner

Learner Driver
16th November 2006, 04:20 AM
Let's stop! Nothing is this hard to get configured and working. How much hassle would it be to reinstall Fedora, and then start a new msg thread called madwifi drivers or such. We could start some scratch with a new install and complete update, then do the drivers .....Your choice...
Iron Mike I am not sure how I managed to overlook this post Ops!

Great idea I have been thinking that we might have been flogging a dead horse here as well.

I have the means and opportunity to re-install fedora and start from scratch.

You will no doubt laugh at this one I am not sure how to start a new thread mate, I´ve only ever joined one.

Thank you for your patience Mike, I suspect this episode has been very frustrating I would like to note that I have gained alot from your assistance so please do not think your efforts have been wasted.


Kind Regards,

Learner