PDA

View Full Version : IDE 100 Mb Zip drive



Eli
27th March 2004, 05:24 PM
I have an IDE Zip drive (previously /dev/hdg4) that I moved from one IDE channel to another. The drive is actually connected to an IDE card that I purchased and whenever I would boot, it said "Found Zip Drive on 3." I switched it to reflect "...on 0," since I did not have any other devices hooked up, and wanted to keep order inside the machine.

Is there a way to get it working again?
Can Kudzu help this matter?

ghenry
27th March 2004, 07:00 PM
Hi, I would try Kudzu. Issue a
setup as root or goto System Systems > Server Systems > Services and make sure kudzu is enabled at startup. Also delete
/etc/sysconfig/hwconf which will completely reset all detected hardware, just to be sure.

Eli
27th March 2004, 11:37 PM
Well I had to install kudzu, which I did. Then I ran the setup utility and set it to start at bootup, and I deleted the /etc/.../hwconf file like you said.

Kudzu, did not detect my zip drive and I know that it is being seen, because the bios for the Silicon Image IDE card that I have is detecting it. Now though, my sound card is not working, since it was autodetected by Kudzu. I am going to uninstall Kudzu, and recompile my kernel with APM support.
(In the software forum.) I compiled it with acpi support, but am still looking for a plugin or someway to quite my cpu's fan.

I hope to find an answer to my Zip drive problem at least.

ghenry
28th March 2004, 12:32 AM
Fo your sound card, you can use either

redhat-config-soundcard

or

system-config-soundcard

Eli
28th March 2004, 07:08 PM
Kudzu detected my Silicon Image card., but has yet to aid in my Zip drive.
Here is an extract from my /etc/sysconfig/hwconf;
-
class: RAID
bus: PCI
detached: 0
driver: siimage
desc: "CMD Technology Inc|PCI0680"
vendorId: 1095
deviceId: 0680
subVendorId: 1095
subDeviceId: 3680
pciType: 1
pcibus: 0
pcidev: a
pcifn: 0
-
I ran the redhat-config-sound utility, thanks for letting me know about it by the way :) and it returned this.

sox: Can't open output file '/dev/dsp': No such device

I tried to change permissions to /dev/dsp with;
chmod 666 /dev/dsp*
and reran the sound util, but only got the same result.

By the way, I google searched for the alsa rpm's, (you had mentioned installing these in an article linked to the front page sometime last week) and after satisfying the deps got everything working. I am running 2.6.5-rc2 with sound support built in, and both ALSA & OSS are modular. I only get cdrom sound, the /dev/dsp or a /dev/sound error (permissions), and when I have to reset my alsamixer settings everytime I boot, because even when I issue /usr/sbin/./alsactl store it writes to /etc, but does not keep.
:confused:

Every action is performed as root also.

ghenry
28th March 2004, 07:42 PM
So, you got sound working? I think I have read your post wrong. Could you just write your problem again?

Sorry. :-)

Eli
28th March 2004, 08:55 PM
Not quite. :(

Actually, I can only get cd's to play. Weird! I have never had this happen before.
I am still running Fedora Core 1, but the problem is that whenever I try to play MP3's with xmms-mp3, I get an error and the redhat-sound util cannot play a test sound, then exits with

sox: Can't open output file '/dev/dsp': No such device
-9
and when I try to run "gnome-volume-control" I get
Volume control is unable to run correctly.

Unable to open audio device '/dev/mixer'.
Please check that you have permissions to open '/dev/mixer'
and that you have sound support in your kernel.

Press Quit to exit Volume control

I have changed permissions to the nth degree, but my actions are in vain for nothing comes of it.

"lsmod," looks like this:


Module Size Used by
maestro3 29320 0
ac97_codec 15628 1 maestro3
snd_maestro3 14500 0
snd_ac97_codec 55300 1 snd_maestro3
snd_pcm 76708 1 snd_maestro3
snd_page_alloc 8708 1 snd_pcm
snd_timer 19844 1 snd_pcm
snd 37304 4 snd_maestro3,snd_ac97_codec,snd_pcm,snd_timer

The penultimate (next-to-last) one, "snd," is what really stumps me. Its sheer presence seems redundant and I think it needs to be unloaded. If you see, it loads all of the other modules that are already loaded, and that is really weird to me.
Honestly I think I need that Linux power tools book or just a voyage to B@rders to uhemm browse their resources .