PDA

View Full Version : Vnc



closer
27th March 2004, 05:16 PM
When using vncserver and i log in from a remote computer
the X dislay is not gnome or kde it somthing I have never seen before. can gnome be loaded with vnc and how

Thanks

Closer

taylor65
27th March 2004, 05:20 PM
Are you trying to remotely access a linux machine with another linux machine? If so, use Xnest instead of vnc.

redhat71
28th March 2004, 12:14 AM
iirc, just modify .vnc/xstartup and change"twm &" to "exec gnome-session &" then restart vncserver

tchung
28th March 2004, 12:51 AM
Hello,

If you haven't, please refer to:

http://fedoranews.org/tchung/vnc/

Thomas

closer
28th March 2004, 09:22 PM
iirc, just modify .vnc/xstartup and change"twm &" to "exec gnome-session &" then restart vncserver


That was just what the doctor orderd. that worked perfect.
My vnc works great now thankyou very much for everyones help

Thankyou

Closer

closer
2nd April 2004, 04:00 PM
Moderator

Please note that this problem is resolved

thanks

Closer

maarten
10th April 2004, 04:59 PM
so i installed fedora core1
have a gnome desktop running
and tried to get vnc running, as a reference i used:
http://fedoranews.org/tchung/vnc/

check if it's there:
[root:]rpm -q vnc vnc-server
vnc-4.0-0.beta4.3
vnc-server-4.0-0.beta4.3

adapting:
/etc/sysconfig/vncservers
VNCSERVERS="1:maarten"

[root:]vncpasswd
Password:
Verify:

[root:]ls .vnc
passwd

but now it goes wrong:
[root:]sudo /sbin/service vncserver start
Starting VNC server: 1:maarten [FAILED]

who knows how to troubleshoot this.

maarten

jedtheHumanoid
24th May 2004, 12:00 AM
marteen: i had the same problem when i went though the guide on fedoranews.
I found out the problem was that i didn't follow the guide extensively but instead i was root all the time trough the guide, with the result of vncpasswd setting the passwd for root and not the user i intended to set it for:rolleyes:.

Being correct user (same as you set in the vnc config file) when running vncpasswd and then starting server again solved it!
Good luck :)