PDA

View Full Version : fglrx-kmod-common needed!



gpetroui
24th March 2006, 07:21 PM
Hi
I am trying to install the ATI drivers using the src.rpms to compile them for the 2070 kernel.
THe compilation goes fine and I produce the RPM's but when I go to install them I get an error
that its failing a dependancy to fglrx-kmod-common (8.23.7)
I cannot for the life of me find this rpm anywhere.
Any ideas?

I have not managed to find any ATI install guides for FC5 yet.

Rgds
G

BassHead
24th March 2006, 07:56 PM
I don't know about fglrx-kmod-common, but for FC4 I personal found the easiest way to install the ATI drivers was using the re-packaged rpm at livna (http://rpm.livna.org/). I'm planning on using them again for FC5, but



A note for users of ati-fglrx and nvidia-glx: Due to a bug in the FC5 release kernel users of non-GPLed kernel modules will have to wait for an errata kernel; that should happen soon. BTW, the driver packages got renamed; they are now xorg-x11-drv-fglr and xorg-x11-drv-nvidia.


So it looks a bit of a non-starter for the minute, unless you want to recompile the kernel too :)

gpetroui
24th March 2006, 08:01 PM
But I thought the newer revisions of the kernel, 2069 and 2070 are not buggy and allow you to install the drivers. Other posts in the forums do show people who have installed the drivers with the 2070 and 2069 kernels and it works fine for them. But I get dependancy failures and I cant for the life of me understand why.

smfinley
24th March 2006, 08:01 PM
The current situation is described here (https://www.redhat.com/archives/fedora-list/2006-March/msg04266.html).

BassHead
24th March 2006, 08:28 PM
Sorry, I didn't notice the kernel version in your post (my bad). I don't use any dev and/or test packages, so I'll shut up now :D