PDA

View Full Version : Vanilla 2.6.16 kernel: Problem with X



charlus
24th March 2006, 06:15 PM
I've recompiled a vanilla 2.6.16 kernel ( with a configuration that is working fine on my debian ppc install ) and i'm getting the following behaviour with Fedora 5 on my powerbook G4:

- gdm comes up fine.
- When i login as root, everything is fine, i get my gnome environment.
- When i login as non root, X dies and i'm brought back to the login screen. I've seen messages of gdm crashing because of SEGV in the logs. I've tried gnome and KDE with no success.
- The exact same configuration works great when i run the latest fedora core 5 kernel.
So it's a problem related to non root user using X on my custom kernel....
Does anyone have an idea of what the problem can be ?
Thanks in advance !

( note: Support for radeon drm has been included in the kernel )

DukeNukem
13th April 2006, 10:02 PM
Hello!

I have the exact same problem. When I use my own custom kernel users cannot login gnome, only root can. Everything is fine with the default fc5 kernels.

I dont have a solution, but would really like one.

However I am able to login users by booting at runtime level 3, logging in as a user and issuing the command startx.