PDA

View Full Version : reiser and fstab problem



sync
24th March 2006, 05:33 PM
Hi all
I got a little problem with my fstab. I have 2 partitions formated with reiserfs and I am not able to automount them at the systemstart.
here is my fstab:


LABEL=/1 / ext3 defaults 1 1
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
LABEL=SWAP-hda2 swap swap defaults 0 0
/dev/hdb2 /mnt/disk3 vfat rw,users,umask=000 0 0
/dev/hdb3 /mnt/disk4 vfat rw,users,umask=000 0 0
/dev/hda4 /mnt/disk1 reiserfs defaults 0 0
/dev/hdb1 /mnt/disk2 reiserfs defaults 0 0


I also tried it with these options:


/dev/hda4 /mnt/disk1 reiserfs auto,rw,exec,user 0 0
/dev/hdb1 /mnt/disk2 reiserfs auto,rw,exec,user 0 0

with the same result.
the fat32 disks work without a problem but with the reiser disks I get a error message.
here is my /var/log/messages:


ReiserFS: hda4: found reiserfs format "3.6" with standard journal
ReiserFS: hda4: using ordered data mode
ReiserFS: hda4: journal params: device hda4, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda4: checking transaction log (hda4)
ReiserFS: hda4: Using r5 hash to sort names
audit(1143215845.189:4): avc: denied { search } for pid=1814 comm="mount" name="/" dev=hda4 ino=2 scontext=system_u:system_r:mount_t:s0 tcontext=system_u:object_r:unlabeled_t:s0 tclass=dir
ReiserFS: hda4: warning: xattrs/ACLs enabled and couldn't find/create .reiserfs_priv. Failing mount.

both disk got formated under opensuse 10.0 and I can mount both disk as root with mount /dev/hda4 /mnt/disk1 without a problem.

I hope somebody can help a noob out :)

edit: forgot to write that I am using FC5 and kernel 2.6.16-1.2070_FC5

paulbarbee
25th March 2006, 12:55 AM
I'm having the same problem. I can't mount my reiserfs partition at boot but "sudo mount -a " works just fine. My kernel is 2.6.15-1.2054_FC5. Any help would be greatly appreciated.

sync
25th March 2006, 04:44 PM
Anybody know a solution?

daneel971
27th March 2006, 10:13 AM
try the "-o context" option for mount

proopnarine
4th April 2006, 11:28 PM
Apparently we were supposed to start the installation process with a "reiserfs" option. I do recall reading this several weeks ago, but I only just started to install Fedora 5 on my machines, and yes, one of them has 3 saved reiserfs partitions on it. The previous system was Suse 9.1. It also seems that mounting as root is the easy way to fix this, and since this machine is a server and I rarely re-boot it, that's not a problem. But what a pain if you re-boot your desktop regularly! There must be a boot time option out there or something.
Fedora should fix this. I generally use ext3, but I think that reiserfs is here to stay.

Firewing1
4th April 2006, 11:33 PM
SELinux seems to be blocking the mount command -- Disable SELinux.
Firewing1

daverj
5th April 2006, 12:23 AM
reiserfs and selinux do not play together. If you want to keep the reiserfs partitions, you might as well disable selinux.

By the way, the proper procedure for installing a system with reiserfs is at the boot prompt:

linux selinux=0 reiserfs

proopnarine, the the best of my knowledge, FC has no plans of officially supporting reiserfs, so in their mind, there is nothing to fix. ext3 is all the support. The rest you use at your own risk.


Dave

proopnarine
5th April 2006, 12:44 AM
Disabling SELinux did the trick!
Funny, a colleague here just mentioned to me this afternoon that he had given up on Linux and ad installed Windows on his PC because "there isn't enough support". Whatever.

proopnarine
5th April 2006, 12:48 AM
reiserfs and selinux do not play together. If you want to keep the reiserfs partitions, you might as well disable selinux.

By the way, the proper procedure for installing a system with reiserfs is at the boot prompt:

linux selinux=0 reiserfs

proopnarine, the the best of my knowledge, FC has no plans of officially supporting reiserfs, so in their mind, there is nothing to fix. ext3 is all the support. The rest you use at your own risk.


Dave
Well, that's too bad considering the widespread use of reiserfs already. The fix is pretty easy, and your boot prompt is the information that I had read some time back. However, one should not have to get into workarounds, and disable a specific filesystem or security, in order to have a functioning system. What's the technical reason for the incompatibility between SELinux and reiserfs?

daverj
5th April 2006, 01:10 AM
reiserfs does not support acl's or contexts.

sync
21st April 2006, 02:30 PM
just wanted to say thank you all.
disabling selinux did the trick.
I am using Fedora pure as my desktop os, are there any disadvantages for not using SELinux?