PDA

View Full Version : no icon on desktop when mounting /mnt/device...



tbl
24th March 2006, 11:22 AM
About the new fc5 (already on the fc5-test) :
having logical device on /dev/hda6 (e.g.)
creating /mnt/downloads
adding line to fstab :
/dev/hda6 /mnt/dwonloads vfat auto,users,umask=0 0 0

Then, when i mount /mnt/downloads, it mounts, but there is no icon on the desktop.
On fc4, it was !

Is there any config, or what is the possibility to create a shortcut to this mounted device, please ?


thx :)

SlowJet
24th March 2006, 12:16 PM
Try a Gnome panel custom application launcher - has FSDev as a type?
Does that mount show up in the Applications, System Tools, File Browser?

SJ

tbl
24th March 2006, 02:11 PM
please, could you give me few tips. I 've never made such a launcher.
BTW, i think FSdevice = SFdevice ?

thx :)

designbydave
25th March 2006, 04:59 AM
i have the same issue with FC5. Just formatted my FC4 machine this morning in favor of FC5. I have an extra drive /dev/hdb1 with fstab line:

/dev/hdb1 /mnt/storage ext3 defaults 0 0

same config as in FC4, and in FC4 it would show an icon for the drive in the "Computer" section of nautilus. It does not show in FC5. It does mount and on startup warn me that I am using 97% of it ( gotta stop downloading tv shows ;) )

ideas anyone?

EDIT: just tryed a USB flash drive and that automounted and displayed an icon both on the desktop and in the "computer" section....

tbl
25th March 2006, 07:25 AM
Here is a workaround :
ln -s /mnt/storage /home/$user/Desktop/name-4-the-shortcut
where $user is the username desktop you want to have the shortcut on.

tbl
25th March 2006, 08:31 AM
but i have another problem : how to make such a shortcut for smb mounted device :(
I have bookmark in nautilus, but that's all... i remember it works on fc5-test3 ... :-/

designbydave
25th March 2006, 07:06 PM
but i have another problem : how to make such a shortcut for smb mounted device :(
I have bookmark in nautilus, but that's all... i remember it works on fc5-test3 ... :-/

my mounted smb drives show on the desktop and in the "computer"

tbl
25th March 2006, 08:23 PM
interesting ! I gonna try again ! Thx :)

jhetrick62
25th March 2006, 10:21 PM
If you mount your Samba shares with the Places > Connect to Server option and choose Windows Share, they show up on your desktop. Doing it this way will prevent you from having to add a line to fstab unless you need it to automount for some reason. The icon sticks and you can just enter password on next login.

You do have the option of checking off "Remember this Password"

Jeff

arthurhanlon
25th March 2006, 10:44 PM
jhetrick62,

Do you know where this gets mounted to? Usually when I do this to mount my music share, I cannot play music directly from it by draggin MP3 files into XMMS. It will display the filename in XMMS but not actually be able to play. In order to get the music to play I have to mount it manually using 'mount -t cifs'.

Any ideas?

Arthur

jhetrick62
26th March 2006, 06:06 AM
If that is the case, install smb4k. It definitely mounts to /home/name/smb4k/hostname

That too I believe gives an icon and you can definitely open the location in the nautilus browser and drag the files.

Jeff

hcenteno
19th July 2006, 05:48 AM
I'm experiencing the same problem. Just installed FC5 and I can't get my fat32 partition to show in the Computer folder or in the Desktop... I added this to /etc/fstab

/dev/hda2 /media/documents vfat iocharset=utf8,umask=000 0 0

anyone found a solution?

thanks!

Hector