PDA

View Full Version : missing deps for NVU



tbl
24th March 2006, 11:21 AM
Trying to install nvu, for fc4 rhel4 .... - :-/) http://www.nvu.com/download.html
specialy this one : http://www.nvu.com/download/linux/1.0/nvu-1.0-RedHat_and_Fedora/nvu-1.0-1_nokde.rhel4.fs.i386.rpm
But get failed deps message :

> [root@Fopadix-fc5 downloads]# rpm -ivh nvu-1.0-1_nokde.rhel4.fs.i386.rpm
> error: Failed dependencies:
> xorg-x11-deprecated-libs is needed by nvu-1.0-1_nokde.rhel4.fs.i386


any way to resolve this problem , please ?

PS i know fc4 or rhel4 is not fc5 :-P ; but ,... never know :)

teotihuacano
6th April 2006, 03:40 AM
After three days I couldn't get NVU to work at all.
What I get is /home/nvu-1.0/run-mozilla.sh: line 159: 11850 Violación de segmento "$prog" ${1+"$@"}
Not even RPM is working on this FC5
¿?"###!!

twiistedkaos
6th April 2006, 03:44 AM
After three days I couldn't get NVU to work at all.
What I get is /home/nvu-1.0/run-mozilla.sh: line 159: 11850 Violación de segmento "$prog" ${1+"$@"}
Not even RPM is working on this FC5
¿?"###!!
Try just downloading the tar file off the NVU website, that's what I did and it works perfectly fine.


download
extract to dir

Terminal:
sh <dir name>/nvu

Spoon!
6th April 2006, 05:48 AM
> [root@Fopadix-fc5 downloads]# rpm -ivh nvu-1.0-1_nokde.rhel4.fs.i386.rpm
> error: Failed dependencies:
> xorg-x11-deprecated-libs is needed by nvu-1.0-1_nokde.rhel4.fs.i386

yum install nvu-1.0-1_nokde.rhel4.fs.i386.rpm

Wayne
6th April 2006, 06:34 AM
I installed this package first:

ftp://rpmfind.net/linux/fedora/core/updates/4/i386/xorg-x11-deprecated-libs-6.8.2-37.FC4.49.2.i386.rpm

So far my FC5 install hasn't blown up :-)

YMMV

Wayne

teotihuacano
7th April 2006, 11:36 PM
Ive tried yum install nvu-1.0-1_nokde.rhel4.fs.i386.rpm
This is what I got

[root@localhost ~]# yum install nvu-1.0-1_nokde.rhel4.fs.i386.rpm
Loading "installonlyn" plugin
Setting up Install Process

blablabla

updates : ################################################## 358/358
Added 269 new packages, deleted 0 old in 2.47 seconds
primary.xml.gz 100% |=========================| 52 kB 00:01
freshrpms : ################################################## 158/158
Added 1 new packages, deleted 0 old in 0.25 seconds
primary.xml.gz 100% |=========================| 765 kB 00:13
extras : ################################################## 2163/2163
Added 39 new packages, deleted 284 old in 3.98 seconds
Parsing package install arguments
No Match for argument: nvu-1.0-1_nokde.rhel4.fs.i386.rpm
Nothing to do

:(

And when I tried ftp://rpmfind.net/linux/fedora/core...4.49.2.i386.rpm
This is what I got
The file can't be opened "because the associated application doesn't exist" in Spanish...

Thanks for your help but it seems my FC5 doens't like me.

Wayne
8th April 2006, 12:26 AM
Try this in Firefox (or whatever browser you use)

http://rpmfind.net/linux/rpm2html/search.php?query=xorg-x11-deprecated-libs&submit=Search+...

Wayne

teotihuacano
8th April 2006, 12:48 AM
Sorry: I did also try the no kde version for yum install yum install nvu-1.0-1.rhel4.fs.i386.rpm

No luck either

And unpacking and trying sh /home/esteban/nvu-1.0/nvu just froze my console.

Sigo participando...

gavinw6662
8th April 2006, 08:14 AM
fc4 - I got nvu to install without a hitch. Just downloaded the file you mention. I assume you don't have xorg installed?

teotihuacano
8th April 2006, 08:58 PM
I've got many files called xorg, if that is what you were asking. I don't know what they are for though...

teotihuacano
11th April 2006, 01:12 AM
No that I ve managed to use yum localinstall I get this
Error: Missing Dependency: libgnome-2.so.0 is needed by package nvu
Error: Missing Dependency: xorg-x11-deprecated-libs is needed by package nvu

The problem is I have lignome and xorg but X86_64 version. I guess that is the problem now. Is it possible to solve it?
Thanks for all the effort.

Christy
11th April 2006, 02:05 AM
for the xorg missing dependency, if yum install xorg-x11-deprecated-libs doesn't work (which I assume it won't because you got th error in the first place...) try downloading it from here http://rpmfind.net/linux/rpm2html/search.php?query=xorg-x11-deprecated-libs

Are you sure you have libgnome? Does it come up when you do

rpm -q libgnome

The Wizzard
25th May 2006, 12:35 PM
@teotihuacano
i had the same problems when trying to download xorg-x11-deprecated-lib from rpmfind (and some other sites). in the end i found one on atrpms and it works.

ATrpms - by Distribution > Fedora Core 4 > xorg-x11-unichrome
http://dl.atrpms.net/all/xorg-x11-deprecated-libs-6.8.2-37.FC4.49.2_4.rhfc4.at.i386.rpm

jbannon
8th June 2006, 01:52 PM
Yeah, this last one worked for me as well. Looks very similar to the editor extension for firefox (Nanju) but with more buttons. I'll have a play & see what it's like.

centos_x
8th June 2006, 07:47 PM
problem probaby iis that xorg has changed considerable between fc3/4 and fc5, trying to get a package built against those deps probably not going to yield best results, another option is getting the SRPM from fc4/rhel and try rebuilding it in fc5 may need to tweak spec file a little but it's worth a try if you know what you are dong.

for FC3 I have packages built of it.......

sailor
8th June 2006, 07:56 PM
I have always just used the tar file from the NVU homepage and extracted to a directory...done.

Wayne
10th June 2006, 06:01 AM
I have always just used the tar file from the NVU homepage and extracted to a directory...done.

That never worked for me but this did without the xorg packages:

ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/testing/4/nvu/nvu-1.0-0.1.i386.rpm

Wayne