PDA

View Full Version : Problem with make command



tomahawker
24th March 2006, 12:43 AM
I get this problem with using the make command for "ieee80211-1.1.12.tgz"

[tomahawker@localhost ieee80211-1.1.12]$ make
Checking in /lib/modules/2.6.15-1.2054_FC5 for ieee80211 components...
find: /lib/modules/2.6.15-1.2054_FC5/build/: No such file or directory
egrep: /lib/modules/2.6.15-1.2054_FC5/build//.config: No such file or directory
egrep: /lib/modules/2.6.15-1.2054_FC5/build//include/linux/autoconf.h: No such file or directory
make -C /lib/modules/2.6.15-1.2054_FC5/build M=/home/tomahawker/Desktop/ieee80211-1.1.12 MODVERDIR=/home/tomahawker/Desktop/ieee80211-1.1.12 modules
make: *** /lib/modules/2.6.15-1.2054_FC5/build: No such file or directory. Stop.
make: *** [modules] Error 2
[tomahawker@localhost ieee80211-1.1.12]$

what does all this stuff mean?

jim
24th March 2006, 12:58 AM
A do you have gcc installed?
rpm -q gcc

B. did you read the README? ususally a ./configure is run before make

C. You can grab a compiled rpm for that package
http://atrpms.net/dist/fc5/ieee80211/

tomcat
24th March 2006, 01:03 AM
As already pointed out, you need the compilers installed. Without gcc you won't get far. Then, before you install a source package, always make sure to read the readme that is in it. It usually contains some valuable information (like used prefixes). The normal procedure is:
./configure (or ./configure --prefix=/usr)
make
and as root
make install

tomahawker
24th March 2006, 01:43 AM
I tried to read the README but I am totally confused with all this linux stuff. tar this, rpm that, yum what. This is my first time using anything linux. I am well versed in the ways of Microsoft/DOS, but this linux stuff I'm a retard. I'm trying to break away from Microsoft, but having a hard time doing so. Right now I'm trying out that link fedorajim gave me, it's doing stuff right now, let you know how it goes.

jim
24th March 2006, 01:58 AM
Dont be to hard on yourself! we were all ther once

What exactly are you trying to accomplish ?

tomahawker
24th March 2006, 02:14 AM
I'm trying to install my Intel wireless pro 2200BG card on my laptop

Iron_Mike
24th March 2006, 02:56 AM
If you look in your /var/log directory, there is a file called dmesg, open it and scan down about 2/3 of the way and you should see that it is already installed:

ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.7
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, git-1.0.8
ipw2200: Copyright(c) 2003-2005 Intel Corporation

This is from a fresh install

tomahawker
24th March 2006, 04:37 AM
I have to use landline to connect to the internet, no wireless

tomahawker
25th March 2006, 06:01 PM
this what I have, only eth0, no eth1(wireless card):
eth0: SiS 900 PCI Fast Ethernet at 0xd800, IRQ 18, 00:03:0d:3c:24:e8.
ipw2200: Unknown symbol ieee80211_wx_get_encodeext
ipw2200: Unknown symbol ieee80211_wx_set_encode
ipw2200: Unknown symbol ieee80211_wx_get_encode
ipw2200: Unknown symbol ieee80211_txb_free
ipw2200: Unknown symbol ieee80211_wx_set_encodeext
ipw2200: Unknown symbol ieee80211_wx_get_scan
ipw2200: Unknown symbol escape_essid
ipw2200: Unknown symbol ieee80211_rx
ipw2200: Unknown symbol ieee80211_rx_mgt
ipw2200: Unknown symbol free_ieee80211
ipw2200: Unknown symbol alloc_ieee80211

any ideals?

tashirosgt
26th March 2006, 08:40 AM
I don't know whether you tried fedorajim's suggestion of getting the *.rpm file for your module. If you didn't, it's a good idea. It would avoid having to compile it.

What is a link to the *.tgz file you are compiling?