PDA

View Full Version : FC5: xorg locks on startup



k3of4
23rd March 2006, 10:39 PM
Hi all,

I'm hoping someone can help me know where to look to find why the gui on FC5 is locking up on our server before it gets to the login prompt. (It worked the first time, but on subsequent restarts after configuring apache, mysql etc. it locks up)

I checked the xorg log and it doesn't show any errors (that I can tell). It ends with the following lines; I can post more or any other info that might be pertinent...


(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) RADEON(0): [drm] removed 1 reserved context for kernel
(II) RADEON(0): [drm] unmapping 8192 bytes of SAREA 0xf89b3000 at 0xb6e7b000

Thanks for any assistance you can offer. I prefer to use the terminal anyway but Boss needs the purty pictures. If this can't be fixed, how do I switch it back to terminal (non GUI) login?

Should be noted that all functions of the server continue work fine; just the GUI is frozen. I don't know if there's a way to shut down xserve from the remote terminal?

steve941
24th March 2006, 01:00 AM
try this:
http://forums.fedoraforum.org/showthread.php?t=100049

k3of4
24th March 2006, 04:59 AM
Sorry I should have clarified, I tried that before I made this post. ;) Had no effect.

steve941
24th March 2006, 06:39 AM
alright well thing that you could try is config your own kernel say using kernel.org 2.6.16 kernel, ... and compile that
.. the kernel.org main kernels like 2.6.16 don't yet load drm so as a result you shouldn't get that drm error ..
FC5 kernel seems to have experimental drm support so the lines:
(II) RADEON(0): [drm] removed 1 reserved context for kernel
(II) RADEON(0): [drm] unmapping 8192 bytes of SAREA 0xf89b3000 at 0xb6e7b000

would either be related to kernel or xorg, since you disable dri in xorg (it disables x from relying on kernel drm), now you could try disabling drm in the kernel which im thinking should work

k3of4
24th March 2006, 08:33 PM
I was afraid of that. Making my own custom kernel is beyond my level of knowledge.