PDA

View Full Version : cron problem



derelict
23rd March 2006, 08:15 PM
Greetings,

I'm having a slight problem with cron that I can't quite understand: I'm trying to set up the crontab to launch and shutdown aMule at a given time, and while the shutdown part works nicely, I can't get it to start :confused:
I've kept it as simple as possible, here are the two entries of the crontab so far:
07 19 * * * amule /usr/bin/amule
00 2 * * * amule killall -SIGINT amule

The first entry doesn't do anything, cron logs this:
Mar 23 19:07:01 server crond[4866]: (amule) CMD (/usr/bin/amule)
But the second entry works fine, it'll shutdown aMule perfectly, I tryed starting it manually and the shutdown went fine. I restarted crond after I changed the crontab and the user amule can run /usr/bin/amule, what could I be doing wrong?

Thanks in advance :)

giulix
23rd March 2006, 08:30 PM
Try


07 19 * * * /usr/bin/amule
00 2 * * * killall -SIGINT amule

derelict
23rd March 2006, 08:58 PM
It didn't run :(

giulix
24th March 2006, 11:32 AM
Darn!!! What happens if you run it from the command line ? Is crond running ?

derelict
24th March 2006, 01:51 PM
If I login as the user "amule" and run /usr/bin/amule from bash it starts up perfectly; crond is running and logging OK (I posted it's tail on the first post). aMule is a graphical application, could that be the problem?

giulix
24th March 2006, 02:18 PM
ehr.... yes. Check whether a command line version exists or maybe you can use the same version as command line only by specifying the proper options...