PDA

View Full Version : FC5 Does not boot



RandomLogic
23rd March 2006, 04:43 PM
I just finished installing FC5 on a 2nd hard drive of my Win2K machine. Upon rebooting, my PC froze at grub prompt. I had NO keyboard response. Even after a power-off reboot, I had no response.

Booting the CD into rescue mode, I was able to check the grub config file and it looks ok.

Has the copy of grub that got installed somehow gone bad?

I downloaded the CD images from torrent and they gave me a bit of trouble. (Disks 2 and 3 took me three tries to get an image that passed the testing phase.)

Any ideas?

icky
23rd March 2006, 04:49 PM
have u tried grub-install in rescue mode?

RandomLogic
23rd March 2006, 04:56 PM
Not yet. One of my installation attempts failed on CD 1, even though it had tested OK. I am starting to think I have a hardware problem with the drive that I used for installation.

I am currently reinstalling using another drive. If that fails, I will try your suggestion.

icky
23rd March 2006, 04:58 PM
One of my installation attempts failed on CD 1, even though it had tested OK.

It is common, I had same experience at cd 4, and i had to install again. :(

RandomLogic
23rd March 2006, 05:38 PM
I tried installing FC4 from disks that I had previously used successfully. This install failed - which led me to believe I was having hardware proplems with my drive. But after reinstalling FC5 from the other CD-ROM drive, I ran into the SAME PROBLEM - stuck at a grub prompt with no keyboard.

I have to go to work now, so I'll try the earlier posted suggestion when I get home.

Sugarat
23rd March 2006, 06:11 PM
It did this to me as well. Installed FC5 and it rebooted to a GRUB... and nothing else.

I had to fix the MBR with a windows cd

RandomLogic
26th March 2006, 09:11 PM
Well, I got it fixed, but the cause of the problem was not anything I expected. It turns out that the /boot/grub/devices.map file was faulty.

The file contained:


(hd0) /dev/hda

FC5 was installed on hdb, which was missing. To fix the problem, I changed the file to read:


(hd0) /dev/hda
(hd1) /dev/hdb

I rebooted and viola! Both Windows and FC5 booted without any problems.

My only question is why the devices.map file was wrong in the first place. This one puzzles me.