PDA

View Full Version : Opera Install Problem in FC5



buchalkalan
23rd March 2006, 04:07 PM
hi all,

I tried to install the rpm(for FC4) version of opera on FC5. After installation I was unable to see the opera in my applications menu under internet subcategory.

I thought to give it a try via command line.

following was the response on command line:

Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
swfdec-mozilla-player: error while loading shared libraries: libgstgconf-0.8.so.0: cannot open shared object file: No such file or directory

After that a plugins warning window appeared with the following text:

Opera encountered a problem during plug-in setup.
Plug-ins will not work properly.
Check your installation.

Could not start plug-in executable 'operamotifwrapper'.
/usr/lib/mozilla/plugins/operamotifwrapper-3
Please install Motif.

Plug-in path
(Path can be modified in Preferences dialog)

/usr/lib/opera/plugins
/usr/lib/mozilla/plugins


some googling about this error and motif stuff provided me the solution to install
libmotif3 or lesstif2.
I couldn't find any of the packages for FC5.

Can any body help me in this regard?
Also is it a good idea to install an rpm in FC5 thats specifically made for FC4?

looking for ur response!!!!

Lewdo85
25th March 2006, 12:40 AM
i used the .tar

d_GeNeRiT
25th March 2006, 04:30 AM
I recommend that you remove the rpm for FC4 which seems to be incompatible. I installed Opera from the tar.gz package at their website. The only error I get now is:

Could not start plug-in executable 'operamotifwrapper'.
/usr/lib/mozilla/plugins/operamotifwrapper-3
Please install Motif.

If anyone knows how to make this motif error go away I would be happy to hear it. Truth be told, my firefox works perfectly so if I hadnt installed this from tar and knew how to uninstall it cleanly I would just forget all about Opera until they create the FC5 rpm. It should probably be complete within 30 days.

Do that, bro. Just uninstall the rpm for FC4 and forget about Opera until they make an rpm for FC5.

brahms
2nd May 2006, 04:16 PM
There is now an FC5 option at opera.com - although it appears to produce the same rpm as the FC4. Anyway, it works fine for me.


opera-8.54-20060330.6-shared-qt.i386-en.rpm

Arodef5
3rd May 2006, 04:34 PM
Get the Opera 9.0b download , it takes care of the operamotif problem , it is beta FYI.

http://www.opera.com/download/index.dml?step=2&opsys=Linux%20i386&platform=Linux%20i386