PDA

View Full Version : FC5 installs fine, hangs at login screen



Phaethar
23rd March 2006, 04:01 PM
Hey guys,

Like the subject says, I'm having an issue with FC5 (64--bit) where it will install just fine, run through the entire firstboot wizard, and when it gets to the point where it should bring up the login screen everything just hangs up at a dark screen. I've installed 3-4 times now trying different options, all met with the same result. I've tested each CD to make sure they're ok. I've even went and updated all BIOS versions for my hardware, but I cannot get FC5 to work properly on this system. The hardware is known to be good as FC4_64 was running fine on this system prior to this install.

Relevant system specs are:

Intel SE7230NH1LX Server board
Intel Pentium D 920 Dual Core Processor
2GB DDR2 RAM
3Ware 9550SX SATA RAID Controller

As I'd mentioned, this hardware has been working find in FC4.

Anyone else running the 64-bit version on hardware similar to this, or know what could be causing things to hang up only at the login screen?

Thanks in advance.

tomcat
23rd March 2006, 04:15 PM
Most likely a graphic card problem. Which graphic card do you have?

Phaethar
23rd March 2006, 04:23 PM
Being that it's a server board, the graphics chip is onboard. It is the ATi ES1000 chipset, which FC5 detects correctly.

tomcat
23rd March 2006, 04:27 PM
Take a look at this howto: http://forum.fedoraforum.org/forum/showthread.php?t=99123

Phaethar
23rd March 2006, 04:40 PM
It looks like that guide assumes you can get the system up and running and bring up a terminal. In my case, once it goes through all the startup options and starts all services, the system locks up. I can't reboot or get to a terminal window at all to make any changes.

Edit: I should mention that I just tried another install, and this time it allowed me to get to the login screen. I logged in, ran some yum updates and made a few basic changes. Rebooted the system and got the same old problem: locked up when the login screen should have appeared. Based on this, I don't believe it's a problem with the graphics card, as it appeared to be working as it should have the 1 time I was able to get logged in.

Weird.

tomcat
23rd March 2006, 04:47 PM
Right, there seems to be another problem.
Try booting with different option like
linux noapic nolapic
linux nofb
Do you have a live-CD that you can boot up? If yes, fine. If not, try to boot into an init 3 environment (that is running only a command line and no gui). Then become root and take a look at fedoras /var/log/messages folder. Error messages will be stored there. If needed, copy the whole contents and attach it as a txt file here, so we can take a look at the cause of your hardware problem.

steve941
23rd March 2006, 07:24 PM
try this
http://forums.fedoraforum.org/showthread.php?t=100049