PDA

View Full Version : Broken cpu speed control



genneth
23rd March 2006, 12:02 PM
CPU frequency control has always never worked on my machine, but with the new kernel in FC5, I get this error message from the kernel on start up:


powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.60.0)
powernow-k8: 0 : fid 0xa (1800 MHz), vid 0x6 (1400 mV)
powernow-k8: 1 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV)
cpu_init done, current fid 0x2, vid 0x6
powernow-k8: ignoring illegal change in lo freq table-2 to 0x2
powernow-k8: transition frequency failed

Does anyone else see this? I have to turn cpuspeed off because of this, as when it transitions there's a possibility of it just rebooting the machine.

Stone Dragon
23rd March 2006, 01:37 PM
In Ubuntu and Gentoo I used powernowd or cpydynd or just the kernel rule "ondemand", which worked flawlessly. I will check this evening my FC5 installation, if I have the same problem...
I think with the strange kernel provided on release day, we can't work very well anyway and should await the new one (I'm too lazy to compile my own just now).

*gettingphilosophical*: I feel like amd64 alpha-test facility for red-hat company, but that seems to be the cost if we use a free distro

marko
25th March 2006, 09:29 PM
Make sure you have the newest available bios flashed to your motherboard.
I had a problem with powernow support on FC4 improve with my
X2 cpu after I reflashed.