Fedora Linux Support Community & Resources Center
  #1  
Old 14th March 2006, 07:25 PM
Parido Offline
Registered User
 
Join Date: Mar 2006
Posts: 23
boot problem

Hello everyone!
I am new to fedora and I have a problem. I installed fedora on a S-ATA drive with winXP. During the installation of fedora4 I choose as a default OS Windows. When I reboot I thought that a menu would show up and let me choose wich OS but the default would be Windows. Instead of that windowsXP started without any menu showing up. Like I never install Fedora! If anyone knows how to fix that I would be gratefull.

I apologise for my english.. Thank you!!!
Reply With Quote
  #2  
Old 14th March 2006, 08:07 PM
Lluisanunez Offline
Registered User
 
Join Date: Mar 2005
Location: Barcelona
Posts: 372
Reboot, and just after your BIOS screen, hit any key and the menu will show up. If you want the menu to appear every time, delete the line 'hiddenmenu' from the file /boot/grub/grub.conf
__________________
registered linux user #317675

Last edited by Lluisanunez; 14th March 2006 at 08:12 PM.
Reply With Quote
  #3  
Old 14th March 2006, 08:10 PM
matthewcheck Offline
Registered User
 
Join Date: Mar 2006
Posts: 21
I had same problem, read this , maybe you would be able to do something about it. I recommned first running rescue mode (after booting install CD/DVD type linux rescue) and executing
Code:
chroot /mnt/sysimage
and
Code:
grub-install /dev/sda
. I suppose that you have one HD or am i wrong?
Reply With Quote
  #4  
Old 14th March 2006, 09:07 PM
Parido Offline
Registered User
 
Join Date: Mar 2006
Posts: 23
Quote:
Originally Posted by Lluisanunez
Reboot, and just after your BIOS screen, hit any key and the menu will show up. If you want the menu to appear every time, delete the line 'hiddenmenu' from the file /boot/grub/grub.conf
It only prompts me to select o different hardware profile.
Reply With Quote
  #5  
Old 14th March 2006, 09:11 PM
Parido Offline
Registered User
 
Join Date: Mar 2006
Posts: 23
Quote:
Originally Posted by matthewcheck
I had same problem, read this , maybe you would be able to do something about it. I recommned first running rescue mode (after booting install CD/DVD type linux rescue) and executing
Code:
chroot /mnt/sysimage
and
Code:
grub-install /dev/sda
. I suppose that you have one HD or am i wrong?
I have one sata with 4 partitions(3NTFS) on it (one with fedora) and an ata drive
I think I havent set up correctly the boot loader. In which partition should I install it? The default is hda (strange i thing because the installation was made to sd7)
Reply With Quote
  #6  
Old 14th March 2006, 10:21 PM
matthewcheck Offline
Registered User
 
Join Date: Mar 2006
Posts: 21
Run rescue mode and execute
Code:
fdisk -l
Then write here the output you get.

The boot loader should be installed on drive, that is BIOS using for boot (if you have Win installed on disk hda, then boot loader should be installed on that disk"s MBR by default, there are also possibilities to install it elsewhere).
Reply With Quote
  #7  
Old 16th March 2006, 07:57 PM
Parido Offline
Registered User
 
Join Date: Mar 2006
Posts: 23
Quote:
Originally Posted by matthewcheck
Run rescue mode and execute
Code:
fdisk -l
Then write here the output you get.

The boot loader should be installed on drive, that is BIOS using for boot (if you have Win installed on disk hda, then boot loader should be installed on that disk"s MBR by default, there are also possibilities to install it elsewhere).
I did that an I found out that Windows is installed on sda1 and grub on hda1.
I run setup again and tried to create a new boot loader on sda1 but it said that the files where not copied. Now what
Reply With Quote
  #8  
Old 18th March 2006, 05:09 PM
Parido Offline
Registered User
 
Join Date: Mar 2006
Posts: 23
I finally reinstall fedora but I was more careful to the part of grub installation. Now everything works just fine! Thank's all of you for the help!
Reply With Quote
Reply

Tags
boot, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot problem, win xp won't boot. sweetrain Installation, Upgrades and Live Media 3 13th November 2007 08:18 PM
Problem with Dual-boot of WinXP and FC4 too!!! lost boot loader... freshmeat EOL (End Of Life) Versions 7 31st December 2005 05:55 AM
Dual boot problem - windows won't boot ! snorkrat Installation, Upgrades and Live Media 6 7th November 2005 01:04 PM
Grub boot problem / MBR problem flyboy Installation, Upgrades and Live Media 4 8th September 2005 01:53 PM
dual boot problem or hd problem agentblue Hardware & Laptops 2 29th April 2005 10:36 PM


Current GMT-time: 23:36 (Monday, 01-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat