Fedora Linux Support Community & Resources Center
  #1  
Old 15th February 2006, 06:31 PM
ucfagls Offline
Registered User
 
Join Date: Feb 2005
Posts: 97
Samba: smbd fails to start

Hi,

Having reset-up a print server from installation disks today, I did something stupid and blindly copied the contents of /etc/samba from the previous installation into the new installation. (New installation is a fresh FC4 updated to latest updates using YUM)

Now smbd refuses to start (nmbd starts OK). I am currently using a blank smb.conf file and the smb.conf file from the old installation. testparm doesn't report any errors in the smb.conf from the old installation.

This is what I see in the shell when restarting smb:
Code:
/sbin/service smb restart

Shutting down SMB services:                                [FAILED]
Shutting down NMB services:                                [  OK  ]
Starting SMB services: /etc/init.d/functions: line 83:  2945 Aborted  $nice $*
                                                           [FAILED]
Starting NMB services:                                     [  OK  ]
And this is the relevant part of the log file:
Code:
[2006/02/15 15:36:42, 0] lib/util.c:smb_panic2(1525)
  BACKTRACE: 7 stack frames:
   #0 smbd(smb_panic2+0x8a) [0x72507c]
   #1 smbd(smb_panic+0x19) [0x7252c2]
   #2 smbd(get_global_sam_sid+0x2bc) [0x6dd84c]
   #3 smbd(init_guest_info+0x65) [0x76b6be]
   #4 smbd(main+0x2a7) [0x7a6fb3]
   #5 /lib/libc.so.6(__libc_start_main+0xdf) [0x408d5f]
   #6 smbd [0x5a54f1]
[2006/02/15 15:47:21, 0] smbd/server.c:main(798)
  smbd version 3.0.14a-2 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2004
[2006/02/15 15:47:21, 0] passdb/secrets.c:secrets_init(64)
  Failed to open /etc/samba/secrets.tdb
[2006/02/15 15:47:21, 0] passdb/secrets.c:secrets_init(64)
  Failed to open /etc/samba/secrets.tdb
[2006/02/15 15:47:21, 0] passdb/secrets.c:secrets_init(64)
  Failed to open /etc/samba/secrets.tdb
[2006/02/15 15:47:21, 0] passdb/machine_sid.c:pdb_generate_sam_sid(176)
  pdb_generate_sam_sid: Failed to store generated machine SID.
[2006/02/15 15:47:21, 0] lib/util.c:smb_panic2(1517)
  PANIC: Could not generate a machine SID

[2006/02/15 15:47:21, 0] lib/util.c:smb_panic2(1525)
  BACKTRACE: 7 stack frames:
   #0 smbd(smb_panic2+0x8a) [0x31c07c]
   #1 smbd(smb_panic+0x19) [0x31c2c2]
   #2 smbd(get_global_sam_sid+0x2bc) [0x2d484c]
   #3 smbd(init_guest_info+0x65) [0x3626be]
   #4 smbd(main+0x2a7) [0x39dfb3]
   #5 /lib/libc.so.6(__libc_start_main+0xdf) [0x6a5d5f]
   #6 smbd [0x19c4f1]
Can anyone see what is wrong and how I can rectify this problem?

Thanks in advance,

G
Reply With Quote
  #2  
Old 19th March 2006, 08:49 AM
zenboy Offline
Registered User
 
Join Date: Mar 2006
Posts: 4
https://bugzilla.redhat.com/bugzilla....cgi?id=160582

Long story short?

/sbin/restorecon -v /etc/samba/secrets.tdb
/sbin/restorecon -v /etc/samba/smbpasswd

Fixed.
Reply With Quote
  #3  
Old 22nd March 2006, 12:22 PM
ucfagls Offline
Registered User
 
Join Date: Feb 2005
Posts: 97
Thanks for this - will give it a try when I find a minute to look at this machine again. Will post back what I find, but TIA.
Reply With Quote
  #4  
Old 22nd March 2006, 03:27 PM
zenboy Offline
Registered User
 
Join Date: Mar 2006
Posts: 4
Quote:
Originally Posted by ucfagls
Thanks for this - will give it a try when I find a minute to look at this machine again. Will post back what I find, but TIA.
Actually, this fixed it in a short term kind of way. When the context was set for those files, it allowed Samba to start, but the actual shares apparently have to have a context applied to them as well, which was causing a lot of errors to pop up in the log with "The file '/home/raid5' could not be found." and from Windows clients, the share would appear in the network browser, but was unconnectable, reported as a permissions error. Not having enough time to fiddle with it at the time, I instead disabled SELinux for samba. I was really racking my head over this one too, because I've set up Samba a lot of times, and the idea that somehow Share level security on a 777'd directory structure, with public and guest enabled was still somehow causing permissions errors drove me nearly mad.

I ended up simply disabling it with
'setsebool -P smbd_disable_trans 1'

Maybe I'll play with it some more when I get back from my trip. I'm very interested in SELinux, but I have yet to find a good solid set of resources to help identify problems with it.
Reply With Quote
Reply

Tags
fails, samba, smbd, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
smbd won't start josh100 Using Fedora 0 29th August 2009 03:33 AM
smbd doesn't start Coruba67 Servers & Networking 3 20th February 2007 05:29 AM
smbd can't start F4Rid Servers & Networking 4 4th August 2006 03:20 AM
Samba smbd processes keep increasing mhorsley Servers & Networking 0 19th August 2005 11:22 AM


Current GMT-time: 06:17 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Begamganj - Cottage Grove - Vladikavkaz