Fedora Linux Support Community & Resources Center
  #1  
Old 5th February 2006, 09:19 PM
jigarzon Offline
Registered User
 
Join Date: Feb 2006
Location: Buenos Aires, Argentina
Age: 31
Posts: 9
Exclamation Problems sharing internet connection

After using Mandrake for two years, I decided to try Fedora, and have recently installed FC4. After a week solving basic problems (video, audio, internet connection, even my mouse didn't work), now I'm a bit frustrated, I think that Mr Fedora hates me ...

I don't request to much: I have two NIC, a modem that connects to one of them, and the other NIC connects to another machine. I want to share my internet connection.

This configuration works ok under WinXP, and worked with Mandrake 10.1, just because these OS have wizards that do everything (I don't have big knowledges about networking).

I had my internet connection working, and followed a tutorial to share the connection. Now my internet connection doesnt work anymore.

I can activate both devices (eth0 is the internal NIC, and eth1 which connects to the modem), determine the IP information, but the connection does not work...

I really have no idea what's wrong, if I can renew my IP, then the connection should exist and work.... please help!

Thanks in advance!
Reply With Quote
  #2  
Old 3rd March 2006, 07:47 PM
manishsingh4u Offline
Registered User
 
Join Date: Mar 2006
Posts: 3
I have the same configuration at my place. My eth0 is connected to the modem and eth1 with other computer. I am writing here what I did for myself and it works fine. Connect your eth0 to the modem for better understanding.
Okay here's the stuff....
edit your /etc/sysconfig/network, add this line to it

GATEWAYDEV="eth0"


Then on the Konsole, run these commands

/etc/init.d/network restart
iptables -P FORWARD ACCEPT
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward


If you don't have dhcpd in ur computer, run this command

yum install dhcpd

edit your /etc/dhcpd.conf (if it does not exist, create one)

ddns-update-style interim;
subnet 192.168.0.0 netmask 255.255.255.0 {
option routers 192.168.0.1;
option subnet-mask 255.255.255.0;
# replace x.x.x.x's here with your dns1 and dns 2)
option domain-name-servers x.x.x.x, x.x.x.x ;
range 192.168.0.2 192.168.0.253;
}

And please let me know if if works
Reply With Quote
  #3  
Old 3rd March 2006, 07:55 PM
manishsingh4u Offline
Registered User
 
Join Date: Mar 2006
Posts: 3
Sorry, I forgot to add one command, please execute this on the obove computer

dhcpd


It should definitely work now
Reply With Quote
  #4  
Old 3rd March 2006, 08:16 PM
jigarzon Offline
Registered User
 
Join Date: Feb 2006
Location: Buenos Aires, Argentina
Age: 31
Posts: 9
I made the same thing you say, but it still didn't work. I installed Firestarter and followed the wizard to share my internet connection ... after that it worked right, but i'm still disapointed of course!

Thanks anyway!
Reply With Quote
  #5  
Old 3rd March 2006, 08:28 PM
manishsingh4u Offline
Registered User
 
Join Date: Mar 2006
Posts: 3
Yes, firestarter is a very nice utility to share it. It does the same procedure without our headacke. Anyway, I don't have anything else to say. See ya in some other threads. bye
Reply With Quote
  #6  
Old 13th March 2006, 10:26 AM
wizdom Offline
Registered User
 
Join Date: Mar 2006
Posts: 1
I just hd to add some feedback here....I was having the same exact problem. I did exactly the steps posted and it worked. I didn't even do the dhcp part.

I installed FC4 using the onlione walk thru "The Perfect Setup - Fedora Core 4" at http://www.howtoforge.com/perfect_setup_fedora_core_4

everything was fine except windows pc couldn't access outside (web)

followed the steps below and I was all set.

I did set one of the DNS address on the XP machine as the real one from my isp, and the other as my internal fedora box (192.168.0.1)

works perfect =)) thanks!!!!!


Quote:
Originally Posted by manishsingh4u
I have the same configuration at my place. My eth0 is connected to the modem and eth1 with other computer. I am writing here what I did for myself and it works fine. Connect your eth0 to the modem for better understanding.
Okay here's the stuff....
edit your /etc/sysconfig/network, add this line to it

GATEWAYDEV="eth0"


Then on the Konsole, run these commands

/etc/init.d/network restart
iptables -P FORWARD ACCEPT
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward


If you don't have dhcpd in ur computer, run this command................

Last edited by wizdom; 13th March 2006 at 10:29 AM.
Reply With Quote
  #7  
Old 2nd April 2006, 12:50 AM
Doritos Offline
Registered User
 
Join Date: Dec 2004
Location: Ribeirão Preto, SP, Brasil
Age: 31
Posts: 49
Quote:
Originally Posted by manishsingh4u
I have the same configuration at my place. My eth0 is connected to the modem and eth1 with other computer. I am writing here what I did for myself and it works fine. Connect your eth0 to the modem for better understanding.
Okay here's the stuff....
edit your /etc/sysconfig/network, add this line to it

GATEWAYDEV="eth0"


Then on the Konsole, run these commands

/etc/init.d/network restart
iptables -P FORWARD ACCEPT
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward


If you don't have dhcpd in ur computer, run this command

yum install dhcpd

edit your /etc/dhcpd.conf (if it does not exist, create one)

ddns-update-style interim;
subnet 192.168.0.0 netmask 255.255.255.0 {
option routers 192.168.0.1;
option subnet-mask 255.255.255.0;
# replace x.x.x.x's here with your dns1 and dns 2)
option domain-name-servers x.x.x.x, x.x.x.x ;
range 192.168.0.2 192.168.0.253;
}

And please let me know if if works

It works, until the system is rebooted
How do I make it permanent?
Reply With Quote
  #8  
Old 2nd April 2006, 01:37 AM
piforever Offline
Registered User
 
Join Date: Mar 2006
Posts: 28
/sbin/service iptables save
Reply With Quote
Reply

Tags
connection, internet, problems, sharing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet Connection Sharing king sabri Servers & Networking 6 31st December 2007 10:37 PM
Internet connection sharing solomon Servers & Networking 3 29th December 2007 07:37 AM
Internet Connection Sharing debudayan Using Fedora 2 11th May 2007 02:02 PM
Internet sharing connection glore2002 Servers & Networking 19 10th May 2006 07:54 PM
internet connection sharing graemekeatley Servers & Networking 2 30th July 2005 12:34 AM


Current GMT-time: 06:23 (Monday, 22-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Berzelii Choklad & Dessert Instagram Photos - Dubai Photos on Instagram - Calista Private Beach - Macys 34 Street New York City Photos - Lone Peak Wilderness Instagram Photos