Fedora Linux Support Community & Resources Center
  #1  
Old 25th October 2005, 12:56 AM
someuser77 Offline
Registered User
 
Join Date: Aug 2005
Posts: 47
INIT: Id "x" respawning too fast: disabled for 5 minutes. FC2.

hello. first of all i would like to mention i'm new to linux, so be as detailed as you can please.
i recently installed Fedora Core 2, all was fine, the system ran for a week or so.
today when i booted up i couldnt get to the login screen, the blue screen switched to black and to back to blue in a loop. i booted linux rescue from cd#1 and tried:
Code:
# yum remove pango
# yum remove pango-devel
# yum remove xorg-X11
# yum install pango
# yum install pango-devel
# yum install xorg-X11
so now when i boot up i get "INIT: Id "x" respawning too fast: disabled for 5 minutes."
i can press Ctrl+C and login as root, but when i run startx i get a funny colored terminal.
i added "/usr/X11R6/lib/font" to "/etc/X11/xorg.conf" but it didnt help.
i can boot up using Windows 2000 OS, Knoppix 3.9 or FC CD#1, but i dont know how i can use it to fix this mess, and i wouldnt want to format and reinstall FC2.
help will be appreciated.
Attached Files
File Type: txt Xorg.0.log.txt (33.2 KB, 147 views)

Last edited by someuser77; 25th October 2005 at 10:28 AM.
Reply With Quote
  #2  
Old 25th October 2005, 10:42 AM
daneel971 Offline
Registered User
 
Join Date: Jun 2005
Location: Italy
Posts: 1,108
It happened to me when I was on FC2, and it was due to a misconfigured xorg.conf. In my case, it loaded the wrong video card driver.
You can try to find out which driver is the correct one for your card (what kind of video card do you have?) and manually fix the xorg. file.
An alternative solution is:
boot in runlevel 3
log in as root
rename to something else (add a .bak suffix to them) /etc/sysconfig/hwconf, /etc/X11/xorg.conf, /etc/modprobe.conf
reboot: kudzu will prompt you for configuring new devices and hopfully will create a new working xorg.conf for you
__________________
- Captain...
- Yes, Spock?
- I can't believe my ears...
Reply With Quote
  #3  
Old 25th October 2005, 11:10 AM
someuser77 Offline
Registered User
 
Join Date: Aug 2005
Posts: 47
thank you for your reply daneel971.
i renamed the files and on boot kudzu did load, but he configured the network card, with audio and chipset, not the graphics card so the problem stayed the same.
i have a On-Board "S3 ProSavageDDR" card/chip.
is there a way to make the system rewrite xorg.conf and/or other needed files?
Reply With Quote
  #4  
Old 25th October 2005, 11:12 AM
brianmsu80 Offline
Registered User
 
Join Date: Aug 2004
Location: Michigan
Posts: 182
Have you tried just running setup?

setup
Reply With Quote
  #5  
Old 25th October 2005, 11:28 AM
someuser77 Offline
Registered User
 
Join Date: Aug 2005
Posts: 47
i didnt find any option in "setup" to configure the graphics card or the graphic user interface.
Reply With Quote
  #6  
Old 25th October 2005, 11:32 AM
brianmsu80 Offline
Registered User
 
Join Date: Aug 2004
Location: Michigan
Posts: 182
You want to pick X configuration.
Reply With Quote
  #7  
Old 25th October 2005, 12:02 PM
someuser77 Offline
Registered User
 
Join Date: Aug 2005
Posts: 47
Quote:
Originally Posted by someuser77
i didnt find any option in "setup" to configure the graphics card or the graphic user interface.


what should i pick?
is there some other way to call "X configuration"?


Thanks to ImageShack for Free Image Hosting
Reply With Quote
  #8  
Old 25th October 2005, 12:25 PM
brianmsu80 Offline
Registered User
 
Join Date: Aug 2004
Location: Michigan
Posts: 182
So you don't have an option for X configuration in setup? It should be at the bottom.

You could try
system-config-display --reconfig

Can you make sure xorg.conf exists (didnt you rename it?)
and that it's chmod is equal to -rw-rw-r--
Reply With Quote
  #9  
Old 25th October 2005, 01:01 PM
someuser77 Offline
Registered User
 
Join Date: Aug 2005
Posts: 47
i changed xorg.conf chmod to -rw-rw-r-- so now it shows green on 'ls'.
i used yum to install system-config-display and ran "system-config-display --reconfig" and got a blue screen with a mouse cursor on it. nothing happened so i rebooted the computer and ran "setup", now i do have a "X configuration", i ran it and again i got the same blue screen with a cursor and again nothing happened.
on boot i still get the " INIT: Id "x" respawning too fast" error. but i think its a progress.
Reply With Quote
  #10  
Old 25th October 2005, 08:44 PM
someuser77 Offline
Registered User
 
Join Date: Aug 2005
Posts: 47
# system-config-display --reconfig:


# startx:


Thanks to ImageShack for Free Image Hosting

Last edited by someuser77; 25th October 2005 at 08:47 PM.
Reply With Quote
  #11  
Old 28th October 2005, 01:20 PM
Twey Offline
Registered User
 
Join Date: Mar 2005
Location: England
Posts: 867
I'd switch to FC4, if I were you. I had this problem with Debian at one point.
__________________
Twey
Reply With Quote
  #12  
Old 28th October 2005, 09:38 PM
someuser77 Offline
Registered User
 
Join Date: Aug 2005
Posts: 47
i moved to FC4. so far so good. thanks everyone!
Reply With Quote
Reply

Tags
disabled, fast, fc2, init, minutes, respawning

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
init: Id "mo" respawning too fast: disabled for 5 minutes Jamwa Using Fedora 0 14th July 2008 09:20 AM
Init:ID "x" respawning too fast: disabled for 5 minutes Volans Using Fedora 21 25th June 2008 11:33 PM
INIT: ID "x" respawning too fast: disabled for 5 minutes (After removing GNOME) SicKn3sS Using Fedora 2 24th March 2008 07:31 PM
init: Id "X" respawning too fast: disabled for 5 minutes Dr.Death Using Fedora 0 6th June 2007 08:02 PM


Current GMT-time: 17:56 (Monday, 24-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Citrus Heights Instagram Photos - Kheda - Horstel