Fedora Linux Support Community & Resources Center
  #1  
Old 4th October 2005, 11:13 PM
lesliek Offline
Registered User
 
Join Date: Mar 2005
Location: Sydney, Australia
Posts: 208
Javascript problem in Firefox

My computer is set up to boot either Windows XP Professional or Fedora Core 3. I have Firefox version 1.0.7 for both Windows and Linux. Each version of Firefox tells me it has Javascript enabled.

I use Yahoo! Mail.

If I open it in Windows, all buttons on the screen, for example, "Move" (an email to a personal folder) and "Reply" (to an email received), work properly.

On the other hand, if I open it in Linux, some buttons on the screen, such as the two I've already mentioned, do not work.

If I open the Javascript Console in Firefox for Linux, I find many errors shown regarding Yahoo! Mail.

Is there a way to try to obtain complete functionality when using Firefox for Linux to open Yahoo! Mail, short of uninstalling Firefox and the Java plugin and reinstalling them?

Thank you.
Reply With Quote
  #2  
Old 4th October 2005, 11:21 PM
smfinley Offline
Retired Community Manager
 
Join Date: Jul 2004
Posts: 1,334
Javascript is not Java. Javascript works fine in the Fedora Core versions of Firefox. See the Java section here for installation instructions for Java and for enabling it for Java applications.
__________________
Stanton Finley
stanton-finley.net
Reply With Quote
  #3  
Old 4th October 2005, 11:58 PM
lesliek Offline
Registered User
 
Join Date: Mar 2005
Location: Sydney, Australia
Posts: 208
Thank you for your prompt reply, Stanton.

Please excuse what is probably a dumb question, but if Javascript's not Java, does that mean that the presence or absence of the Java plugin should not affect whether or not Javascript works when I'm using Firefox?

If so, can you suggest anything else I should be trying to do to avoid all the Javascript errors that occur when I try to use Yahoo! Mail?

The only advice Yahoo! Mail gave me was to enable Javascript, which was already enabled.

Thanks again.
Reply With Quote
  #4  
Old 5th October 2005, 12:06 AM
smfinley Offline
Retired Community Manager
 
Join Date: Jul 2004
Posts: 1,334
You are correct. The presence or absence of the Java plugin should not affect whether or not Javascript works in Firefox. I obtained my Fedora Core 4 Firefox from the offical Fedora repositories via yum by doing a "yum install firefox" as root. The javascript on my Yahoo mail page works fine. Did you get your version of Firefox via yum from the Fedora repositories or elsewhere? In Firefox you could go to "Edit" > "Preferences" > "Web Features" and make sure the "Enable Javascript" check box is ticked. You could then hit the "Advanced" button and make sure all options are ticked. Also hit "clear" in your javascript console.
__________________
Stanton Finley
stanton-finley.net

Last edited by smfinley; 5th October 2005 at 12:14 AM.
Reply With Quote
  #5  
Old 5th October 2005, 12:21 AM
lesliek Offline
Registered User
 
Join Date: Mar 2005
Location: Sydney, Australia
Posts: 208
Thanks again for your prompt reply.

I got my version of Firefox 1.0.7 from the Fedora repositories just recently via "yum update firefox".

Yesterday, after Yahoo! Mail help told me I probably didn't have Javascript enabled, I confirmed that I did indeed have it enabled. I also looked at "Advanced" and saw that not all options were ticked. I then booted into Windows and saw that those "Advanced" options not ticked in Firefox for Linux were also not ticked in Firefox for Windows. Since I have no problem with Yahoo! Mail when using Firefox for Windows, I assumed that ticking all the boxes under "Advanced" was unnecessary. Perhaps I should go back and tick them all. I'll try that when I get home later in the day.

Thanks again.
Reply With Quote
  #6  
Old 7th October 2005, 10:01 AM
lesliek Offline
Registered User
 
Join Date: Mar 2005
Location: Sydney, Australia
Posts: 208
In case anyone else should be suffering from a problem similar to mine and come across this thread while trying to find an answer, I would like to record how I have (I believe) solved my problem.

Mozilla says that extensions and themes may be the source of many Firefox problems and that, if one has a problem, one should run Firefox in safe mode and see whether one's problem disappears as a result. If it does, then play with enabling your extensions and themes one by one until you find the guilty party.

I did that and found that disabling the Greasemonkey extension seems to have brought my JavaScript errors to an end. At the same time, I discovered that the Adblock extension I had was said to be incompatible with Firefox 1.0.7 in any event and to have been automatically disabled on upgrade to v 1.0.7.
Reply With Quote
Reply

Tags
firefox, javascript, problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox Crashing: Javascript problem? Hairyloon Using Fedora 1 28th September 2009 12:32 PM
Firefox 3.5.x and hotmail javascript? erroneus Using Fedora 5 20th July 2009 05:12 PM
Firefox /w Javascript menus tfindlay Using Fedora 3 25th April 2006 08:41 AM
Firefox - or rather a javascript question?!? snoopydoo Using Fedora 6 30th January 2005 09:12 PM
javascript problem with firefox locally Nik Using Fedora 0 2nd April 2004 11:51 AM


Current GMT-time: 09:12 (Friday, 31-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Minnetonka Mills Photos - Portugal - Mauban