Fedora Linux Support Community & Resources Center
  #1  
Old 24th July 2005, 07:18 AM
BrandonV Offline
Registered User
 
Join Date: Jul 2005
Location: Chicago, IL
Age: 32
Posts: 24
Setting password for mysql root user.

Ok im three days new to linux, I installed fedora core 4 and have Fedora 4 unleashed as my guide. I have set up an FTP server with 10 accounts and I have apache running. Now I want to get sql going to I can start developing my web page.

In my book it says to type

mysql -u root

then it says to

mysql> SET PASSWORD FOR root = PASSWORD("yournewpasswordhere");

After i type that I get an error that says

ERROR 1133 (42000): Can't find any matching row in the user table

any insight on what is wrong or what im doing wrong?
Reply With Quote
  #2  
Old 24th July 2005, 07:21 AM
BrandonV Offline
Registered User
 
Join Date: Jul 2005
Location: Chicago, IL
Age: 32
Posts: 24
also I searc and only found this thread

http://forums.fedoraforum.org/forum/...earchid=972126

but was no help
Reply With Quote
  #3  
Old 24th July 2005, 07:23 AM
bytesniper Offline
Registered User
 
Join Date: May 2005
Location: Abq, NM
Age: 37
Posts: 1,158
1) make sure mysqld is running: service mysqld status
2) if there is not yet a password set then when you just type mysql and hit enter it should log you in with an unprivledged (usage only) user. type show databases; and make sure you have the 'mysql' database.
3) try using mysqladmin -u root password <my_password> to change your password

hth,
Joseph
__________________
I am root. If you see me laughing you better have a backup.
Reply With Quote
  #4  
Old 24th July 2005, 07:43 AM
BrandonV Offline
Registered User
 
Join Date: Jul 2005
Location: Chicago, IL
Age: 32
Posts: 24
Quote:
Originally Posted by bytesniper
1) make sure mysqld is running: service mysqld status
2) if there is not yet a password set then when you just type mysql and hit enter it should log you in with an unprivledged (usage only) user. type show databases; and make sure you have the 'mysql' database.
3) try using mysqladmin -u root password <my_password> to change your password

hth,
Joseph
mysql> show databases;
+----------+
| Database |
+----------+
| test |
+----------+
1 row in set (0.00 sec)


#3 didnt work
Reply With Quote
  #5  
Old 24th July 2005, 07:50 AM
bytesniper Offline
Registered User
 
Join Date: May 2005
Location: Abq, NM
Age: 37
Posts: 1,158
you should have another one in there called 'mysql' that holds, among many other things, the mysql user information. without it your not going to get anywhere at all. is this a version of mysql that you installed yourself or one that came with FC?

at this point i would recommend to uninstall it completely and reinstall it. other option is to find a default mysql.sql database that someone has mysqldump'ed or otherwise provided before any modifications were made to it.
__________________
I am root. If you see me laughing you better have a backup.
Reply With Quote
  #6  
Old 24th July 2005, 07:58 AM
BrandonV Offline
Registered User
 
Join Date: Jul 2005
Location: Chicago, IL
Age: 32
Posts: 24
Quote:
Originally Posted by bytesniper
you should have another one in there called 'mysql' that holds, among many other things, the mysql user information. without it your not going to get anywhere at all. is this a version of mysql that you installed yourself or one that came with FC?

at this point i would recommend to uninstall it completely and reinstall it. other option is to find a default mbvandermeersch
mysqlysql.sql database that someone has mysqldump'ed or otherwise provided before any modifications were made to it.
Yea it came with FC4.
Reply With Quote
  #7  
Old 24th July 2005, 08:19 AM
bytesniper Offline
Registered User
 
Join Date: May 2005
Location: Abq, NM
Age: 37
Posts: 1,158
very strange. only clean mysql installation i have ever seen (from FC) that didnt come with the 'mysql' base. i think your in luck though becuase i just setup a box at work with an sql server i havent done anything with yet so i ssh'd into it and dumped the mysql base which you should be able to import and all should be well.

1) create the mysql database in mysql. in mysql console type create database mysql;
2) download the mysql.sql file i have attached and type: mysql mysql < mysql.sql which is [mysql {database} < {dumpfile.sql}]

then try to set your admin password using any of the methods preciously discussed.

(edit) apparently this board won't accept .sql file as uploads so i gz'd it. you'll have to extract it out after you get it. tar xzf mysqldump.tar.gz

hope this works for ya,
Joseph
Attached Files
File Type: gz mysqldump.tar.gz (66.2 KB, 100 views)
__________________
I am root. If you see me laughing you better have a backup.
Reply With Quote
  #8  
Old 24th July 2005, 08:28 AM
BrandonV Offline
Registered User
 
Join Date: Jul 2005
Location: Chicago, IL
Age: 32
Posts: 24
read your last post to late, im doing a yum update to all my mysql packages and installing the updates right now.

if it dosent work then I will download your file.

thanks for all you help also, its much appreciated.
Reply With Quote
  #9  
Old 24th July 2005, 10:03 PM
BrandonV Offline
Registered User
 
Join Date: Jul 2005
Location: Chicago, IL
Age: 32
Posts: 24
Dosent work when I goto create the database I get:
ERROR 1044 (42000): Access denied for user ' '@'localhost' to database 'mysql'

This is getting really frustrating.
Reply With Quote
  #10  
Old 24th July 2005, 10:30 PM
bytesniper Offline
Registered User
 
Join Date: May 2005
Location: Abq, NM
Age: 37
Posts: 1,158
even after using the sql file i uploaded?
__________________
I am root. If you see me laughing you better have a backup.
Reply With Quote
  #11  
Old 24th July 2005, 11:08 PM
BrandonV Offline
Registered User
 
Join Date: Jul 2005
Location: Chicago, IL
Age: 32
Posts: 24
Quote:
Originally Posted by bytesniper

1) create the mysql database in mysql. in mysql console type create database mysql;
2) download the mysql.sql file i have attached and type: mysql mysql < mysql.sql which is [mysql {database} < {dumpfile.sql}]

then try to set your admin password using any of the methods preciously discussed.
Dosent work when I do the first step I get:
ERROR 1044 (42000): Access denied for user ' '@'localhost' to database 'mysql'
Reply With Quote
Reply

Tags
mysql, password, root, setting, user

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I change the root password of MYSQL server Muideen Installation, Upgrades and Live Media 8 19th March 2009 06:42 PM
Installation hangs after setting root password in anaconda eddieadams Installation, Upgrades and Live Media 0 21st November 2008 10:06 AM
Big problem resetting mysql root password rob2000007 Using Fedora 3 5th December 2005 07:38 PM
root password for mysql Ridgerunner Servers & Networking 3 13th September 2005 10:10 PM


Current GMT-time: 04:03 (Thursday, 24-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat