Fedora Linux Support Community & Resources Center
  #1  
Old 22nd June 2005, 06:23 PM
plee Offline
Registered User
 
Join Date: Jun 2005
Posts: 5
Installed Nvidia Driver, no more 1600x1200 and desktop becomes scrollable

I downloaded the nvidia drivers from website and installed it from the instructions. Launch terminal, sh nvidia...run, edited config file, rebooted. After I installed nvidia drivers, fedora won't let me do 1600x1200 resolution anymore, or at least when I try to change resolution through the gui desktop, 1600x1200 is not listed in the pulldown menu. I looked in the xorg.config file, and 1600x1200 is listed under modes.

Also, another weird problem is my desktop became scrollable, kind of hard to explain. But the whole desktop is not visible on the monitor, part of it is offscreen. I have to move the mouse to the edge of the screen and the desktop will scroll to that side.

Does anyone have any advice on how I can fix these problems. My system info is below:

Fresh FC4 Installation (installed EVERYTHING)
Shuttle nForce2 Board (using onboard geforce4mx video)
Using Dell 2001FP monitor (Analog)
Reply With Quote
  #2  
Old 22nd June 2005, 06:37 PM
bitrain Offline
Registered User
 
Join Date: Nov 2004
Location: Netherlands
Age: 26
Posts: 1,426
Do you have the drivers that came out today: http://www.fedoraforum.org/forum/showthread.php?t=60832
There was an issue that is fixed with your resolution.
__________________
Registered Linux user number 389291

Laptop: Nec Versa p550, Pentium M 1.86GHz, 1024MB ram, x300, 80 GB HD, bluetooth, 2915BG Wlan card
Desktop: Amd Athlon x2 4200+, 2GB ram, Geforce 7300GT 512MB silent, 160GB HD in a nice centurion 534 case :cool:
Reply With Quote
  #3  
Old 22nd June 2005, 06:45 PM
plee Offline
Registered User
 
Join Date: Jun 2005
Posts: 5
I just saw that post, I did this yesterday, so I had the old drivers. I will try out the new drivers. Thanks!
Reply With Quote
  #4  
Old 22nd June 2005, 06:59 PM
triplehead Offline
Registered User
 
Join Date: Mar 2004
Location: Helsinki, Finland
Age: 41
Posts: 187
i fixed that scrollable issue by removing all not 4:3 resolutions from xorg.conf (removed 1280x800 and 1280x1024, kept 1280x960).
__________________
Desktop1: Shuttle SN85G4, AMD64 3200+, 1GB 400MHz, EIZO 778, Asus N6600GT
Desktop2: Shuttle SN20G5, AMD64 X2 4200+, 1GB 400MHz, EIZO 778, ATI Radeon Express 200
Server:AMD64 3200+, 1GB 400MHz, matrox g400
network: G.SHDSL 2.3/2.3 Mbit/s
Reply With Quote
  #5  
Old 23rd June 2005, 01:05 AM
plee Offline
Registered User
 
Join Date: Jun 2005
Posts: 5
New drivers same problem, did a complete reinstall of fedora fc4 too. I tried removing non 4:3 resolutions in the xorg.config, but it didn't work for me, still have to scroll around to get to parts of the desktop.
Reply With Quote
  #6  
Old 23rd June 2005, 01:51 AM
triplehead Offline
Registered User
 
Join Date: Mar 2004
Location: Helsinki, Finland
Age: 41
Posts: 187
have you dried putting display size information in monitor section (add line "DisplaySize width height" to monitor section)
__________________
Desktop1: Shuttle SN85G4, AMD64 3200+, 1GB 400MHz, EIZO 778, Asus N6600GT
Desktop2: Shuttle SN20G5, AMD64 X2 4200+, 1GB 400MHz, EIZO 778, ATI Radeon Express 200
Server:AMD64 3200+, 1GB 400MHz, matrox g400
network: G.SHDSL 2.3/2.3 Mbit/s
Reply With Quote
  #7  
Old 23rd June 2005, 05:31 AM
plee Offline
Registered User
 
Join Date: Jun 2005
Posts: 5
Adding the DisplaySize value only changes some of the text sizes for me, didn't fix the problem.

I did somewhat fix the scrolling effect problem, if I remove all but one value in the Modes, the scrolling problem goes away, but I still can't run it at 1600x1200 resolution. My current xorg.conf snipplet:

Quote:
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 2001FP (Analog)"
DisplaySize 400 300
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1600x1200"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200"
EndSubSection
EndSection

This config boots into 1280x960 resolution. How I know? I fired up gimp, created a 1600x1200 image and set zoom to 1:1, and measured it. Plus, running non native resolution on lcd is quite noticiable.
Reply With Quote
  #8  
Old 23rd June 2005, 06:13 AM
buddha Offline
Registered User
 
Join Date: Apr 2005
Location: Texas
Posts: 367
Have you run the "nvidia-settings" GUI utility to see if everything looks okay?

In the past, I had some problems with not being able to set higher resolutions when the amount of video ram detected on my nvidia card was less than actual. Do you know how much video ram you have?

I finally resorted to explicitly setting the amount of video ram (128MB) in my xorg.conf file. Here's the relevant section:

Code:
Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "NVIDIA"
        BoardName   "GeForceFX 5700 Ultra"
        VideoRam    131072
        Option      "NoLogo" "on"
# Try AGPGART first, then NvAGP
        Option      "NvAGP" "3"
        Option      "Coolbits" "1"
EndSection
Reply With Quote
  #9  
Old 24th June 2005, 02:00 AM
plee Offline
Registered User
 
Join Date: Jun 2005
Posts: 5
Tried specifing video ram in config, still no go. Upped the shared memory to 128mb in bios, reset video ram, and still no. The nvidia-setting shows 128mb too.

Is there any other way to change resolution besides going through the gui menu, ie (Desktop -> Preferences -> Screen Resolution) ?
Reply With Quote
  #10  
Old 24th June 2005, 03:15 AM
triplehead Offline
Registered User
 
Join Date: Mar 2004
Location: Helsinki, Finland
Age: 41
Posts: 187
Quote:
Originally Posted by plee
Tried specifing video ram in config, still no go. Upped the shared memory to 128mb in bios, reset video ram, and still no. The nvidia-setting shows 128mb too.

Is there any other way to change resolution besides going through the gui menu, ie (Desktop -> Preferences -> Screen Resolution) ?
just edit /etc/X11/xorg.conf file, best way to get everything wright IMHO
__________________
Desktop1: Shuttle SN85G4, AMD64 3200+, 1GB 400MHz, EIZO 778, Asus N6600GT
Desktop2: Shuttle SN20G5, AMD64 X2 4200+, 1GB 400MHz, EIZO 778, ATI Radeon Express 200
Server:AMD64 3200+, 1GB 400MHz, matrox g400
network: G.SHDSL 2.3/2.3 Mbit/s
Reply With Quote
Reply

Tags
desktop, driver, installed, nvidia, scrollable

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia driver installed, and now fedora won't work at all LutraMan Using Fedora 34 17th April 2009 12:27 PM
nvidia driver installed lost cd/dvd drive wildchildc200 Hardware & Laptops 1 18th February 2007 08:45 AM
Why is ati driver installed? (i have nvidia) Link182 Installation, Upgrades and Live Media 0 30th March 2005 03:17 AM
Nvidia Driver installed, TUX Racer won't start.... Bigfatso Using Fedora 9 14th March 2005 03:22 PM
Installed NVidia driver - now what? Alfred Hardware & Laptops 5 1st March 2005 03:22 AM


Current GMT-time: 12:10 (Monday, 21-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat