Fedora Linux Support Community & Resources Center
  #1  
Old 16th June 2005, 01:40 PM
nomo_green Offline
Registered User
 
Join Date: Dec 2004
Posts: 6
What has happened to FC4?

Greetings all,

I just installed FC4 yesterday and I've noticed a few things I'm not happy about. No XMMS, nothing to play mp3's, nothing to play mpg's, no Xine, no Mplayer, nothing of any interest. Yum works for updates, but nothing else. I can't find any add-on rpm's for FC4 (using apt for rpms). Menus have changed and become even more illogical. Man, what are they thinking up there in RedHat Kingdom?

I'm going to give it some time, but I'm very disgusted with this release and if it keeps up, I guess I'll move elsewhere. I've been with RedHat for a long time and it makes me sad to see it going to the wayside.
Reply With Quote
  #2  
Old 16th June 2005, 01:51 PM
dnar Offline
Registered User
 
Join Date: Jun 2004
Location: /dev/null
Age: 51
Posts: 477
Well the mp3 codec has license issues, so I am guessing this is why xmms has been moved to extras. yum install xmms xmms-mp3 will grab it for you.

I find the menus more logical to be honest.

In the end, if Fedora doesnt meet you needs then there are many other distros that may, thats one good thing about the Linux/GNU Open Source movement.
__________________
Registered Linux User #212818. Ctl-Alt-What?
Reply With Quote
  #3  
Old 16th June 2005, 01:54 PM
markkuk Offline
Registered User
 
Join Date: Apr 2005
Location: Finland
Posts: 5,075
Quote:
Originally Posted by nomo_green
nothing to play mp3's, nothing to play mpg's, no Xine, no Mplayer
Those packages dind't exist in any previous versions of Fedora Core, either. The situation with patents on multimedia codecs prevents their inclusion on any past, current or future versions of Fedora Core.

Xmms has been moved to Fedora Extras because there are CD/media players better integrated in the Gnome and KDE desktops in the Core distribution.

Quote:
Originally Posted by nomo_green
Yum works for updates, but nothing else. I can't find any add-on rpm's for FC4 (using apt for rpms).
Just like in previous versions, you must configure the third-party repositories by yourself. The repo maintainers got the FC4 distribution at the same time as everybody else, it's going to take some time to rebuild the packages for the new distro.
Reply With Quote
  #4  
Old 16th June 2005, 02:03 PM
nomo_green Offline
Registered User
 
Join Date: Dec 2004
Posts: 6
Thanks for the quick replies guys.

I'm aware that most of this has been missing from previous distributions of FC, but I've been able to correct this easily with apt. Now that apt isn't working, I'm having difficulties getting the software I need.

If anyone has a good add-on repository for Yum, let me know.

I just want everyone to know this was not meant to be a flame against FC. I'm just disappointed. Hopefully things will change. After all, it was just released.

Thanks again.
Reply With Quote
  #5  
Old 16th June 2005, 02:06 PM
bitrain Offline
Registered User
 
Join Date: Nov 2004
Location: Netherlands
Age: 27
Posts: 1,426
See the 'some ready to go repos for fc4' thread

mplayer: yum --disablerepo=livna install mplayer mplayer-gui <--- if you don't have livna, forget the disablerepo=livna
xmms: yum install xmms xmms-mp3 <-- you need livna here for mp3
__________________
Registered Linux user number 389291

Laptop: Nec Versa p550, Pentium M 1.86GHz, 1024MB ram, x300, 80 GB HD, bluetooth, 2915BG Wlan card
Desktop: Amd Athlon x2 4200+, 2GB ram, Geforce 7300GT 512MB silent, 160GB HD in a nice centurion 534 case :cool:
Reply With Quote
  #6  
Old 16th June 2005, 02:10 PM
hubs Offline
Registered User
 
Join Date: Jun 2005
Posts: 46
The applet Inbox Monitor has also disappeared.
Reply With Quote
  #7  
Old 16th June 2005, 06:48 PM
grash Offline
Registered User
 
Join Date: Jun 2005
Location: Illinois - USA
Posts: 12
livna repo - mplayer

Hi all
Could someone post the livna repo for me? Thanks. Also I tried the yum install mplayer and yum reports "nothing to do". Could someone post what I need to do to get yum working properly wth livna preferably. Thanks again.
Reply With Quote
  #8  
Old 16th June 2005, 07:01 PM
markkuk Offline
Registered User
 
Join Date: Apr 2005
Location: Finland
Posts: 5,075
Remove all previous configuration for Livna (if you have any) and run the following:
Code:
rpm -Uvh http://rpm.livna.org/fedora/4/i386/RPMS.lvn/livna-release-4-0.lvn.2.4.noarch.rpm
Replace "i386" with "x86_64" if necessary.
This will install a working repo file and the GPG key.
Reply With Quote
  #9  
Old 16th June 2005, 07:11 PM
grash Offline
Registered User
 
Join Date: Jun 2005
Location: Illinois - USA
Posts: 12
Thanks markkuk...worked like a champ. I now have xmms.

Anyone know how I can get mplayer?
Thanks again.
Reply With Quote
  #10  
Old 16th June 2005, 10:00 PM
bitrain Offline
Registered User
 
Join Date: Nov 2004
Location: Netherlands
Age: 27
Posts: 1,426
yum install mplayer mplayer-gui
__________________
Registered Linux user number 389291

Laptop: Nec Versa p550, Pentium M 1.86GHz, 1024MB ram, x300, 80 GB HD, bluetooth, 2915BG Wlan card
Desktop: Amd Athlon x2 4200+, 2GB ram, Geforce 7300GT 512MB silent, 160GB HD in a nice centurion 534 case :cool:
Reply With Quote
  #11  
Old 16th June 2005, 11:27 PM
grash Offline
Registered User
 
Join Date: Jun 2005
Location: Illinois - USA
Posts: 12
Thanks bitrain. My previous post said this didn't work. The problem was that the freshrpms repo is not included in a fresh FC4 install. Adding it makes everything work as you describe. Thanks all.
Reply With Quote
Reply

Tags
fc4, happened

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What happened to vga= in F7? drunkahol Using Fedora 3 18th September 2007 05:56 PM
What happened to raw? erasmix Using Fedora 1 1st October 2005 09:10 AM
What happened here? goldstar1 Using Fedora 1 26th July 2005 06:51 PM
I do not know what happened. Please help Nevek Using Fedora 2 12th June 2005 07:44 AM


Current GMT-time: 01:39 (Thursday, 27-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
New Yekepa Photos on Instagram - White Plains Instagram Photos - Musselburgh Photos