Fedora Linux Support Community & Resources Center
  #1  
Old 7th June 2005, 06:13 PM
n3r0 Offline
Registered User
 
Join Date: Jun 2005
Posts: 20
Setting service to start on bootup

Hello

I have recently moved from debian to FC3 because it had support for my wireless card. Anyways, I am by no means an advanced linux user but I was just wondering if someone could help me.

Im trying to get named to start on boot (at the least) and also preferably be able to be sent commands with the 'service' command (service named start)

I uninstalled the built in named that came with my FC3 because my config files are all written for bind 9.3.1 and did not work with that weird DNS chroot business that was on the default install. so i rpm -e 'd all that and compiled named from source.

anyone know how i can get something to automatically generate init.d scripts for this program? can someone post a normal named init script along with the K or S rc.d entries? I never did this manually before but i tried using chkconfig --add /usr/sbin/named on and that didnt work.

The named server runs fine, all i really need to do is pass it

/usr/sbin/named start

when the machine starts. it doesnt need to be more complicated than that but if anyone know where i should put this line ( should i mess with init.d or jsut skip it?? ) let me know please.
Reply With Quote
  #2  
Old 7th June 2005, 06:14 PM
n3r0 Offline
Registered User
 
Join Date: Jun 2005
Posts: 20
i guess what im looking for is some sort of easy ( little coding if possible ) autoexec.bat
Reply With Quote
  #3  
Old 7th June 2005, 06:19 PM
fsck Offline
Registered User
 
Join Date: May 2005
Location: London, UK
Posts: 704
A quick hack would be to stick that start command in /etc/rc.d/rc.local. I've attached /etc/init.d/named (renamed to .txt because this bloody board needs an extension. wtf??) in case you want to do it that way..
Attached Files
File Type: txt named.txt (5.5 KB, 239 views)
__________________
Want to get better answers? Learn to ask better questions!
fukka.co.uk for spamassassin rules and random garbage.
Reply With Quote
  #4  
Old 7th June 2005, 06:57 PM
n3r0 Offline
Registered User
 
Join Date: Jun 2005
Posts: 20
Well thanks i put that in init.d and chmod 755 and now it works sort of.

the thing is it belches out



[root@northstar init.d]# /etc/init.d/named start
Starting named: /bin/chown: `named:named': invalid user
named: user 'named' unknown
[FAILED]
[root@northstar init.d]#


now i dont like creating user accounts willy nilly but if i were to create this account what kind of access should it have? can i just useradd named passwd named?

to me thats a big security risk. maybe ill put it in /etc/rc.d/rc.local then.
Reply With Quote
  #5  
Old 7th June 2005, 07:04 PM
pembo13 Offline
Registered User
 
Join Date: Jul 2004
Posts: 101
Run the following commands as root:

# cd /etc/init.d
# wget http://pembo13.dalive.com/linux/named.init
# mv named.init named
# chmod +x named
# chkconfig --add named
# chkconfig --level 2345 named on

This assumed that you installed the binaries to the same locations as FC3's package does.

On a side note, chrooting bind seems ot be a highly recommended practice.
Reply With Quote
  #6  
Old 7th June 2005, 07:42 PM
n3r0 Offline
Registered User
 
Join Date: Jun 2005
Posts: 20
hmm yes it might be better to run in chroot jail. i just want to get everything working right now. will probably set it up there later from

http://www.faqs.org/docs/Linux-HOWTO...IND-HOWTO.html

it doesnt look to hard, but i dont think bind is going to have some crazy security hole in it for a bit
Reply With Quote
  #7  
Old 7th June 2005, 08:36 PM
fsck Offline
Registered User
 
Join Date: May 2005
Location: London, UK
Posts: 704
Quote:
Originally Posted by n3r0
[root@northstar init.d]# /etc/init.d/named start
Starting named: /bin/chown: `named:named': invalid user
named: user 'named' unknown

now i dont like creating user accounts willy nilly but if i were to create this account what kind of access should it have? can i just useradd named passwd named?
It wants to run as user 'named' instead of as root, which is a good thing. create the user/group and lock it. Try and do this even if you use chroot.
There are no known massive holes in bind right now, but not so long ago the thing was swiss cheese. I mean a serious liability. It's much more secure now, though.
__________________
Want to get better answers? Learn to ask better questions!
fukka.co.uk for spamassassin rules and random garbage.
Reply With Quote
Reply

Tags
bootup, service, setting, start

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
chkconfig wokrs but service start says unknow service gkk Servers & Networking 4 10th December 2007 02:45 AM
How to start my_program at bootup gold Using Fedora 1 30th August 2007 10:38 AM
Bootup problem - stuck at setting up system clock vinhdt Using Fedora 0 3rd December 2005 08:49 PM
How do I get NetworkManagerInfo to start at bootup? terry_g Servers & Networking 1 14th August 2005 12:50 AM


Current GMT-time: 12:13 (Thursday, 30-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Bonao Photos - Ilha de Mocambique - Tibiri Travel Photos on Instagram