Fedora Linux Support Community & Resources Center
  #1  
Old 12th November 2003, 02:05 PM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
After Installing NVIDIA Drivers: Some fonts are HUGE (Ans)

Hello guys,

I really, really, really hope you have a solution for this 'cause i'm getting nuts of this problem.
I succesfully installed the Nvidia drivers following the Fedora Faq and Nvidia readme for changing the XF86Config file.

Tux racer works fine now, so it has been a succes

The only problem is, that I've got some font issues now.. The login screen's fonts are HUGE, i can't read one word! i just type my login name and password to login (hoping that i'm typing right.)

The same problem I've got in OpenOffice Writer: http://users.pandora.be/doms/problem.png

I also have the problem in AMSN

These are my settings for fonts: http://users.pandora.be/doms/fonts.png


If i let X put my XF86Config file to default, everything is ok , except that i'm not using the Nvidia drivers

Here is my XF86Config file:

[code:1]
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "AOC SPECTRUM 7Vlr & 7VlrA & 7Vlr+ & 7VlrA+"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 130.0
Option "dpms"
EndSection


Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
[/code:1]

I hope someone can save me from this hell

Tnx in Advance


Seminarian
Reply With Quote
  #2  
Old 13th November 2003, 11:21 PM
kai_t Offline
Registered User
 
Join Date: Nov 2003
Posts: 60
The dimensions of your monitor are not detected correctly via EDID (Extended Display Identification Data), resulting in a wrong DPI resolution. As you use NVIDIA's proprietary XFree86 driver, try adding the line Option "IgnoreEDID" "1" to the Device section in /etc/X11/XF86Config, but first, double-check that the HSync and VSync ranges (and ModeLines) suit the specifications of your monitor.

Other possibilities would be to use the DisplaySize option (man 5x XF86Config) or to pass a sane DPI value to the X server by means of the "-dpi" option.

--Kai
Reply With Quote
  #3  
Old 14th November 2003, 06:08 PM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
Quote:
Originally Posted by kai_t
The dimensions of your monitor are not detected correctly via EDID (Extended Display Identification Data), resulting in a wrong DPI resolution. As you use NVIDIA's proprietary XFree86 driver, try adding the line Option "IgnoreEDID" "1" to the Device section in /etc/X11/XF86Config, but first, double-check that the HSync and VSync ranges (and ModeLines) suit the specifications of your monitor.

Other possibilities would be to use the DisplaySize option (man 5x XF86Config) or to pass a sane DPI value to the X server by means of the "-dpi" option.

--Kai
tnx man adding the line "Option "IgnoreEDID" "1"" fixed it, i didn't check the HSync and VSync though.. cause my monitor was in the list..
Now only fixing my sound and maybe i'll stick to Fedora 'cause i was thinking about chaning back to RH 9 (i'm using linux for a thesis)

you're my hero!


Seminarian
Reply With Quote
  #4  
Old 14th November 2003, 07:04 PM
kai_t Offline
Registered User
 
Join Date: Nov 2003
Posts: 60
Quote:
Originally Posted by Seminarian
tnx man adding the line "Option "IgnoreEDID" "1"" fixed it
Great! :)
Quote:
Now only fixing my sound and maybe i'll stick to Fedora 'cause i was thinking about chaning back to RH 9 (i'm using linux for a thesis)
Opening another thread for this sounds right to me. The output of /sbin/lspci would be useful, as well as /sbin/lsmod and an excerpt from /var/log/messages after trying to play a sound.
Reply With Quote
  #5  
Old 15th November 2003, 09:15 PM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
ow crap

i only get FPS 400 .. some guys say i have bad drivers or something?

what should i do
Reply With Quote
  #6  
Old 16th November 2003, 12:37 AM
kai_t Offline
Registered User
 
Join Date: Nov 2003
Posts: 60
Did you follow the instructions in the unofficial FAQ, especially the part about removing the XFree86-Mesa-libGL package? If you use apt and it complains about the package inconsistency, you can do a "database-only install" from CD #1: rpm -ihv --justdb /path/to/XFree86-Mesa-libGL*.rpm
Reply With Quote
  #7  
Old 16th November 2003, 10:06 PM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
Quote:
Originally Posted by kai_t
Did you follow the instructions in the unofficial FAQ, especially the part about removing the XFree86-Mesa-libGL package? If you use apt and it complains about the package inconsistency, you can do a "database-only install" from CD #1: rpm -ihv --justdb /path/to/XFree86-Mesa-libGL*.rpm
I forgot to read that part, I removed the package with the --nodeps option:
rpm -e XFree86-Mesa-libGLU-4.3.0-42 --nodeps

, and I rebooted, but i still get this if do 'glxgears': [code:1][root@d5e0b396 root]# glxgears
1904 frames in 5.0 seconds = 380.800 FPS
1986 frames in 5.0 seconds = 397.200 FPS
1979 frames in 5.0 seconds = 395.800 FPS
1978 frames in 5.0 seconds = 395.600 FPS
[/code:1]

ofcourse when i the window's on the background i get high FPS like
[code:1]5979 frames in 5.0 seconds = 1195.800 FPS
9164 frames in 5.0 seconds = 1832.800 FPS
8327 frames in 5.0 seconds = 1665.400 FPS
6442 frames in 5.0 seconds = 1288.400 FPS
8806 frames in 5.0 seconds = 1761.200 FPS
[/code:1]

I've also tried to start glxgears like this but it had no effect:
_GL_SINGLE_THREADED=1 glxgears

Greetings

Seminarian


EDIT: I guess you're my hero again thank you very much ^^:
I started ET just to try and it works now! It even runs good now!
I guess the FPS doesn't say so much, right.. i think everything is allright now.. tnx
Reply With Quote
  #8  
Old 17th November 2003, 04:58 PM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
I get some really low fps though in ET... like 10-20, what could be wrong ??

tnx in advance


Seminarian
Reply With Quote
  #9  
Old 18th November 2003, 06:18 AM
Avatraxiom Offline
Registered User
 
Join Date: Mar 2004
Location: San Jose, CA
Posts: 323
Quote:
Originally Posted by Seminarian
I get some really low fps though in ET... like 10-20, what could be wrong ??
Are you playing on really large servers? ET wasn't designed to be played on really humongous servers (over 30 players). It tends to get a bit slow in that situation.

-M
Reply With Quote
  #10  
Old 18th November 2003, 08:49 AM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
Quote:
Originally Posted by avatraxiom
Quote:
Originally Posted by Seminarian
I get some really low fps though in ET... like 10-20, what could be wrong ??
Are you playing on really large servers? ET wasn't designed to be played on really humongous servers (over 30 players). It tends to get a bit slow in that situation.

-M
Nope, not real big servers, I would except my GF II Mx performs better, there must be something wrong!

Seminarian
Reply With Quote
  #11  
Old 19th November 2003, 09:32 AM
Avatraxiom Offline
Registered User
 
Join Date: Mar 2004
Location: San Jose, CA
Posts: 323
Quote:
Originally Posted by Seminarian
[Nope, not real big servers, I would except my GF II Mx performs better, there must be something wrong!
So you're using a GF 2 MX normally, or do you have some other card normally? (It's unclear.)

I get an average of 1100 FPS on glxgears when it's in the foreground, using my GF 2 GTS.

-M
Reply With Quote
  #12  
Old 19th November 2003, 12:36 PM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
Quote:
Originally Posted by avatraxiom
Quote:
Originally Posted by Seminarian
[Nope, not real big servers, I would except my GF II Mx performs better, there must be something wrong!
So you're using a GF 2 MX normally, or do you have some other card normally? (It's unclear.)

I get an average of 1100 FPS on glxgears when it's in the foreground, using my GF 2 GTS.

-M
I Have only one card and that is Geforce 2 mx 200 or 400 i don't know for sure..
Reply With Quote
  #13  
Old 20th November 2003, 10:01 AM
Avatraxiom Offline
Registered User
 
Join Date: Mar 2004
Location: San Jose, CA
Posts: 323
Do you have AGP disabled--or turned down to 1x or 2x--in your BIOS settings? Is that XF86Config file correct according to the nVidia README? (I didn't look your config over closely.)

-M
Reply With Quote
  #14  
Old 23rd January 2004, 03:56 PM
Seminarian Offline
Registered User
 
Join Date: Nov 2003
Posts: 14
Quote:
Originally Posted by avatraxiom
Do you have AGP disabled--or turned down to 1x or 2x--in your BIOS settings?
I really don't know anything about my BIOS, but in windows i get decent FPS..

Could anyone help me please? If not i'll have to switch back to rh9 :x
Reply With Quote
Reply

Tags
ans, drivers, fonts, huge, installing, nvidia

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing nvidia drivers from the Nvidia Homepage (was:confused need help) leopard Using Fedora 6 19th July 2009 05:30 PM
fonts, buttons, and Menus missed up after Nvidia drivers ramy.m Using Fedora 4 14th August 2008 04:09 AM
Huge fonts in KDE 4 steve_c1972 Using Fedora 12 5th August 2008 09:38 AM
Huge Fonts--How to Fix? Soda Ant Using Fedora 4 23rd April 2008 04:19 AM
Installing Nvidia Drivers: No Nvidia Graphics Driver Found! unholy1 Hardware & Laptops 9 6th April 2005 08:50 PM


Current GMT-time: 15:51 (Sunday, 21-12-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
...Avalon Park Photos on Instagram - Spiaggia Pozzarello - Rambla de Montevideo, Uruguay Photos on Instagram