Fedora Linux Support Community & Resources Center
  #1  
Old 18th March 2004, 03:41 PM
gatep5 Offline
Registered User
 
Join Date: Mar 2004
Posts: 4
Kernel Preemption Not Default...

How come kernel preemption is not turned on by default in the 2.6 builds for FC 2 test 1? Well, maybe I am assuming too much because when I make xconfig from the source file it is not on by default. Anyway, I thought that that was supposed to be one of "the key features" of the new kernel.

Also, there is still the problem with the USB KVM switches that has yet to be resolved. Switching off and then back to my linux computer make the mouse and keyboard stop functioning. I guess that this is more of a kernel development thing, but I was wondering if anyone has any sugguestions?

I think that test 2 should be put out on a live-eval CD just like Suse 9.1 so I can try it before I update my system with the new packages.

Anyway, that is just my little rant. Otherwise, things are great and I love fedora!!!!
  #2  
Old 18th March 2004, 08:35 PM
Prometheus Offline
Registered User
 
Join Date: Mar 2004
Location: Michigan, USA
Posts: 374
try posting the KVM thing on bugzilla, theyll know more about it that us and theyre really the place to report bugs
__________________
Registered Linux User #371104

Become a Registered Linux User Here
  #3  
Old 19th March 2004, 05:54 AM
Bana Offline
Retired Community Manager
 
Join Date: Feb 2004
Location: Austin, Texas
Age: 27
Posts: 581
I don't think that that config is the same one that was used in building the rpm kernel, that is just the default (I believe), I am not sure as to the status of preemptibility though, I hope it is enabled.
__________________
http://coolhands.blogspot.com/
binarybana AT gmail.com
  #4  
Old 2nd April 2004, 08:58 PM
jgeorgeson Offline
Registered User
 
Join Date: Feb 2004
Posts: 8
The config you get from installing the kernel-source package is a generic one with lots of stuff missing. Look in /usr/src/linux-2.6/configs for the config files to build the RH packaged kernels. Just cp the appropriate one to /usr/src/linux-2.6/.config and then run 'make oldconfig' to apply it.
 

Tags
default, kernel, preemption

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 11 upgrade problem kernel PAE/kernel default Martin Pail Using Fedora 2 10th October 2009 05:41 PM


Current GMT-time: 13:57 (Wednesday, 23-07-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat